IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 3 replies
  • Latest Post - ‏2006-06-15T18:21:37Z by SystemAdmin
SystemAdmin
SystemAdmin
7754 Posts

Pinned topic ds_loadlibrary: error in dlopen

‏2006-06-12T19:53:30Z |
I'm an extreme novice at DataStage. Just installed 7.5.1A on AIX and imported a very simple project from a 7.5.1 windows install where it runs correctly. All it does is read from one DB2 table and write to another using DB2/UDB API in a Server job. I'm getting the subject error both when run and when simply trying to view data on either the read or the write link.

I did the AIX install non-root and did the things needed to run in impersonation mode. At first I didn't install all the plugins (since we don't need all the DB types), but added the rest just in case that had something to do with it. It didn't change the behavior.

I can connect to the db from the account where DataStage is installed.

The type of the error is "OTHER=21".

Any hints as to what this might be? Is there any documentation of errors?
Updated on 2006-06-15T18:21:37Z at 2006-06-15T18:21:37Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    7754 Posts

    Re: ds_loadlibrary: error in dlopen

    ‏2006-06-13T21:41:03Z  
    Turns out that I didn't have DB2 env exports in dsenv. I had them in the .profile of the admin user under which the engine runs, but apparently that is not enough.
  • SystemAdmin
    SystemAdmin
    7754 Posts

    Re: ds_loadlibrary: error in dlopen

    ‏2006-06-15T17:56:38Z  
    It seems to me it is related with permission problem on the DS files.
  • SystemAdmin
    SystemAdmin
    7754 Posts

    Re: ds_loadlibrary: error in dlopen

    ‏2006-06-15T18:21:37Z  
    Thanks for the reply, but I already figured it out. It was simply that the db2 environment settings were not in the dsenv file.