• 2 replies
  • Latest Post - ‏2009-04-21T12:55:13Z by SystemAdmin
706 Posts

Pinned topic DLPAR on openSUSE10

‏2006-06-19T17:05:54Z |
I have a problem with DLPAR on openSuse10.1 running on p550, All the IBM Specific packages for SUSE (listed in doc by Clifford Spinac at installed without problems however lssrc -a does not show IBM.HostRM, and when I attempt to use DLPAR I get a "no RMC Connection" error.

I checked and the file(s) from rsct.core- are installed.

What else can I check to determine the problem?

Tim B
Updated on 2009-04-21T12:55:13Z at 2009-04-21T12:55:13Z by SystemAdmin
  • fengdao
    15 Posts

    Re: DLPAR on openSUSE10

    You can run the AIX command "lssrc -a" to see if the subsystem started. If not, you can start it by using "startsrc -s theNameOfSubsystem" or "startsrc -g theNameoftheGroup".
  • SystemAdmin
    706 Posts

    Re: DLPAR on RedHat

    Thanks for your reply, I checked and noticed a some not running. I started and re-tried remove device (dvd+tape) with same error.
    I then stopped and restarted ALL SRC and tried again, but still didn't work.
    I then Rebooted and ensured all SRC running.
    I was able to DLPAR and 2nd external SAS Tape Drive (st1) and noticed this on console :
    iommu_free_table: Unexpected TCEs for /pci@800000020000202

    I also noticed SRC had stopped a number of resources :
    Subsystem Group PID Status
    ctrmc rsct 1905 active
    IBM.DRM rsct_rm 1950 active
    IBM.ServiceRM rsct_rm 2022 active
    IBM.CSMAgentRM rsct_rm 2032 active
    ctcas rsct 2567 active
    IBM.SensorRM rsct_rm 2576 active
    IBM.ERRM rsct_rm inoperative
    IBM.AuditRM rsct_rm inoperative
    IBM.LPRM rsct_rm inoperative
    IBM.HostRM rsct_rm inoperative

    I restarted all SRC and tried to DLPAR (cd/dvd+tape) but got same error :
    DLPAR REMOVE I/O resources failed: The I/O slot dynamic logical partitioning operation failed. Here are the I/O Slot IDs that failed and the reasons for failure:
    1. Apr 22 00:41:07 2009 ########## : kernel remove failed for PHB 512, rc = -16 U789C.001.DQDF527-P1-T9 (21010200)

    So I rebooted, ensured all SRC active (had to manually start ctcas and IBM.SensorRM) and tried DLPAR again, but still get same error.