Topic
  • 2 replies
  • Latest Post - ‏2010-02-13T06:43:56Z by Rishukumar
SystemAdmin
SystemAdmin
1215 Posts

Pinned topic Failed in r_gsk_secure_soc_init: GSK_ERROR_BAD_CERT(gsk rc = 414) with

‏2006-04-21T01:58:12Z |
Hi,
I am running IBM HttpServer 6.0.2 on Widnows XP ( version 5.1 ) with WebSphere Plugin on running on Windows.
IHS Version: IBM_HTTP_Server/2.0.42.2-PK07831 Apache/2.0.47

Now I have SSL enabled IHS ( port 443 )and did mutual authentication between IHS and plugin.

Now when I try to access my Application using secure mode,
https://windowshost/applicationrunnigonZOS

I get following failures.

I have installed Gskit 7.0.3.17. ( Gsk5 ). I change the plugin login with trace.

TRACE: lib_stream: openStream: Opening the stream
Thu Apr 20 17:54:19 2006 000016c0 00001610 - TRACE: lib_stream: openStream: Stream is SSL
Thu Apr 20 17:54:19 2006 000016c0 00001610 - ERROR: lib_stream: openStream: Failed in r_gsk_secure_soc_init: GSK_ERROR_BAD_CERT(gsk rc = 414)
Thu Apr 20 17:54:19 2006 000016c0 00001610 - TRACE: lib_stream: destroyStream: Destroying the stream
Thu Apr 20 17:54:19 2006 000016c0 00001610 - ERROR: ws_common: websphereGetStream: Could not open stream
Thu Apr 20 17:54:19 2006 000016c0 00001610 - TRACE: ws_common: websphereGetStream: socket 10752 closed - failed to open stream
Thu Apr 20 17:54:19 2006 000016c0 00001610 - ERROR: ws_common: websphereExecute: Failed to create the stream
Can anybody help me?

Thanks

Jayesh
Updated on 2010-02-13T06:43:56Z at 2010-02-13T06:43:56Z by Rishukumar
  • SystemAdmin
    SystemAdmin
    1215 Posts

    Re: Failed in r_gsk_secure_soc_init: GSK_ERROR_BAD_CERT(gsk rc = 414) with

    ‏2007-12-24T19:16:01Z  
    Try this

    What I did though was I removed the "WCInboundDefaultSecure" chain under:
    Servers -> Application Servers -> <server name(Websphere Portal in my case)> -> Web container settings -> Web container Transport chains.
    I then regenerated the plugin under the servers -> webserver menu and everything worked like a charm!

    Meer
  • Rishukumar
    Rishukumar
    1 Post

    Re: Failed in r_gsk_secure_soc_init: GSK_ERROR_BAD_CERT(gsk rc = 414) with

    ‏2010-02-13T06:43:56Z  
    Try this

    What I did though was I removed the "WCInboundDefaultSecure" chain under:
    Servers -> Application Servers -> <server name(Websphere Portal in my case)> -> Web container settings -> Web container Transport chains.
    I then regenerated the plugin under the servers -> webserver menu and everything worked like a charm!

    Meer
    Meer
    How did you regenerated the plugin under the servers
    Cheers