Topic
  • 11 replies
  • Latest Post - ‏2013-01-17T10:17:46Z by SystemAdmin
SystemAdmin
SystemAdmin
17917 Posts

Pinned topic Unable to start DAS.

‏2006-04-19T00:15:12Z |
Hi all,
I'm using DB2 v8.1 fix pack 5 .When I start the DAS using the 'db2admin start' command, it returned with SQL Error code 4401c. Since I don't have much knowledge about DB2, kindly let me know what's wrong.
Since I needed a seperate instance for installing MQ Workflow, I configured it a month ago and installed Workflow. Now when I tried to stop & start the DAS,it's reporting the above mentioned error.

#ls (HOME DIRECTORY)
dasusr4 db2_08_01 db2fenc4 db2inst4 lost+found
dasusr5 db2_data db2fenc5 db2inst5 tmp
#cd dasusr4/das
das
#cd ../dasusr5
Nothing

I'm not sure, but just posting the directory structure just to know if I should be having some files in the dasusr5 directory.
Please guide me.
Vru.
Updated on 2013-01-17T10:17:46Z at 2013-01-17T10:17:46Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    17917 Posts

    Re: Unable to start DAS.

    ‏2006-04-19T07:52:38Z  
    Hi Vru,
    DAS by default uses port 523. So in your case some other process may be running DAS on this port already and hence you are unable to start DAS.
    Run the following commands

    $> db2dasport -q
    to check the port on which DAS is running. If it is 523 then change it to some other port no and restart DAS

    $> db2dasport 4001
    $> db2admin start

    If the problem persists then let me know.

    regards,
    debugDAS
  • SystemAdmin
    SystemAdmin
    17917 Posts

    Re: Unable to start DAS.

    ‏2006-04-19T13:57:04Z  
    Hi Vru,
    DAS by default uses port 523. So in your case some other process may be running DAS on this port already and hence you are unable to start DAS.
    Run the following commands

    $> db2dasport -q
    to check the port on which DAS is running. If it is 523 then change it to some other port no and restart DAS

    $> db2dasport 4001
    $> db2admin start

    If the problem persists then let me know.

    regards,
    debugDAS
    Hi,
    Thanks for your reply.
    When I followed the commands given by you,it says db2dasport not found.I logged in as instance owner(the one that i created,db2inst5).

    db2 => quit
    DB20000I The QUIT command completed successfully.

    $ db2dasport -q
    ksh: db2dasport: not found.

    $ find / -name db2dasport 2>/dev/null

    $

    Where can I find this executable, db2dasport?

    Thank you,
    Vru
  • SystemAdmin
    SystemAdmin
    17917 Posts

    Re: Unable to start DAS.

    ‏2006-04-19T19:13:57Z  
    Hi,
    Thanks for your reply.
    When I followed the commands given by you,it says db2dasport not found.I logged in as instance owner(the one that i created,db2inst5).

    db2 => quit
    DB20000I The QUIT command completed successfully.

    $ db2dasport -q
    ksh: db2dasport: not found.

    $ find / -name db2dasport 2>/dev/null

    $

    Where can I find this executable, db2dasport?

    Thank you,
    Vru
    hi vru,

    it seems that the db2dasport command does not exist.
    it is also not listed in the db2 help pages at:

    http://publib.boulder.ibm.com/infocenter/db2luw/v8/index.jsp

    if you want to know what went wrong look in the db2dasdiag.log file in the /home/dasuser/das/dump directory.

    maybe that helps find the problem. there every action of the das server is logged.

    normally the port 523 is reserved for the das server to communicate. with the linux program netstat (refer to the man pages) you might find out of there is something else using this port while the das server is down.

    but i would look first into the logs to find out what the problem exacly is.

    hope that helps.

    kitgo
  • SystemAdmin
    SystemAdmin
    17917 Posts

    Re: Unable to start DAS.

    ‏2006-04-19T20:52:44Z  
    hi vru,

    it seems that the db2dasport command does not exist.
    it is also not listed in the db2 help pages at:

    http://publib.boulder.ibm.com/infocenter/db2luw/v8/index.jsp

    if you want to know what went wrong look in the db2dasdiag.log file in the /home/dasuser/das/dump directory.

    maybe that helps find the problem. there every action of the das server is logged.

    normally the port 523 is reserved for the das server to communicate. with the linux program netstat (refer to the man pages) you might find out of there is something else using this port while the das server is down.

    but i would look first into the logs to find out what the problem exacly is.

    hope that helps.

    kitgo
    Thanks for your reply.
    Here is the complete dasusr5 file:

    2006-02-27-15.26.22.269978 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - dasRootInit() probe:10
    data #1 (131 bytes)
    DAS startup error. Failed to bind to port 523. Please ensure
    that no other applications are using this port. Then restart the DAS.

    2006-02-27-15.26.22.270809 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - dasRootInit() probe:10
    data #1 (4 bytes)
    -2129723365

    2006-02-27-15.26.24.270898 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - db2dasSearchDscvInit() probe:30
    data #1 (4 bytes)
    67

    2006-02-27-15.26.24.270969 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - dasRootInit() probe:60
    data #1 (4 bytes)
    -1

    2006-02-27-15.26.24.271018 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - rrm_main() probe:80
    data #1 (4 bytes)
    -3020

    2006-04-18-15.05.52.745391 pid:495814 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x9000000C Invalid parameter

    2006-04-18-15.10.52.769480 pid:704724 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x90000013 Time out

    2006-04-18-15.46.11.830043 pid:700476 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x90000013 Time out

    2006-04-18-15.56.06.835713 pid:708834 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x90000013 Time out

    Initially part of file shows that 523 port is in use. But later part do not indicate anything like that.Just says TimeOut.
    What am I supposed to do now?
    One more question. Is it ok if I have two DAS(dasusr4,dasusr5) installed on same machine, but DAS has nothing in its directory?
  • SystemAdmin
    SystemAdmin
    17917 Posts

    Re: Unable to start DAS.

    ‏2006-04-19T21:24:53Z  
    Thanks for your reply.
    Here is the complete dasusr5 file:

    2006-02-27-15.26.22.269978 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - dasRootInit() probe:10
    data #1 (131 bytes)
    DAS startup error. Failed to bind to port 523. Please ensure
    that no other applications are using this port. Then restart the DAS.

    2006-02-27-15.26.22.270809 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - dasRootInit() probe:10
    data #1 (4 bytes)
    -2129723365

    2006-02-27-15.26.24.270898 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - db2dasSearchDscvInit() probe:30
    data #1 (4 bytes)
    67

    2006-02-27-15.26.24.270969 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - dasRootInit() probe:60
    data #1 (4 bytes)
    -1

    2006-02-27-15.26.24.271018 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - rrm_main() probe:80
    data #1 (4 bytes)
    -3020

    2006-04-18-15.05.52.745391 pid:495814 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x9000000C Invalid parameter

    2006-04-18-15.10.52.769480 pid:704724 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x90000013 Time out

    2006-04-18-15.46.11.830043 pid:700476 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x90000013 Time out

    2006-04-18-15.56.06.835713 pid:708834 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x90000013 Time out

    Initially part of file shows that 523 port is in use. But later part do not indicate anything like that.Just says TimeOut.
    What am I supposed to do now?
    One more question. Is it ok if I have two DAS(dasusr4,dasusr5) installed on same machine, but DAS has nothing in its directory?
    well, it shouldn't be a problem that you have 2 users but hopefully there is just one server! both users should belong to the dasadm_group. The dasadm_group is specified in the DAS configuration parameters.

    i actually don't know what happens when you try to create 2 DAS servers on the same maschine (like one for dasuser4 and one for dasuser5).

    i would try to login as dasuser4 and try to stop the DAS server (in case one is already running and blocking port 523).

    regarding two DAS on the same maschine: (quote from the ibm help center)
    You can only have one DAS on a machine. DAS is configured during installation to start when the operating system is booted. (end quote)

    so i guess that you have two DAS (i didn't know that that might even be possible) and one is running and you are trying to get the second DAS running. so you'll probably need to get rid of one. or just leave it because one is already running (probably)

    kitgo
  • SystemAdmin
    SystemAdmin
    17917 Posts

    Re: Unable to start DAS.

    ‏2006-04-20T05:12:10Z  
    well, it shouldn't be a problem that you have 2 users but hopefully there is just one server! both users should belong to the dasadm_group. The dasadm_group is specified in the DAS configuration parameters.

    i actually don't know what happens when you try to create 2 DAS servers on the same maschine (like one for dasuser4 and one for dasuser5).

    i would try to login as dasuser4 and try to stop the DAS server (in case one is already running and blocking port 523).

    regarding two DAS on the same maschine: (quote from the ibm help center)
    You can only have one DAS on a machine. DAS is configured during installation to start when the operating system is booted. (end quote)

    so i guess that you have two DAS (i didn't know that that might even be possible) and one is running and you are trying to get the second DAS running. so you'll probably need to get rid of one. or just leave it because one is already running (probably)

    kitgo
    Since DAS listens to port 523 only. It is possible to attach only one process to the port. And hence single DAS can run on a server.
    A single DAS is capable of performing admin tasks against multiple DB2 instances.

    One question :What is the specific requirement that you need to have two DAS running on the same system? I can try to help you here.

    (PS: Sorry for stating the db2 dasport command. It is incorrect. My apologies).

    • debugDAS.
  • SystemAdmin
    SystemAdmin
    17917 Posts

    Re: Unable to start DAS.

    ‏2006-04-20T13:51:54Z  
    Since DAS listens to port 523 only. It is possible to attach only one process to the port. And hence single DAS can run on a server.
    A single DAS is capable of performing admin tasks against multiple DB2 instances.

    One question :What is the specific requirement that you need to have two DAS running on the same system? I can try to help you here.

    (PS: Sorry for stating the db2 dasport command. It is incorrect. My apologies).

    • debugDAS.
    But could someone go thorugh the das dump file and please let me know the solution for it?
    I have no knowledge as how to deal with these issues.I can provide some more information if needed.
    Thank you,
  • SystemAdmin
    SystemAdmin
    17917 Posts

    Re: Unable to start DAS.

    ‏2006-04-21T08:49:53Z  
    But could someone go thorugh the das dump file and please let me know the solution for it?
    I have no knowledge as how to deal with these issues.I can provide some more information if needed.
    Thank you,
    vru,
    The bottom part of the dump file indicates IPC error while starting DAS. What is the version of db2 and DAS you are using. You can check the levels with the following commands
    db2level - for DB2 level info
    db2daslevel - DAS level info

    • DebugDAS
  • SystemAdmin
    SystemAdmin
    17917 Posts

    Re: Unable to start DAS.

    ‏2006-04-21T16:14:20Z  
    vru,
    The bottom part of the dump file indicates IPC error while starting DAS. What is the version of db2 and DAS you are using. You can check the levels with the following commands
    db2level - for DB2 level info
    db2daslevel - DAS level info

    • DebugDAS
    Hi debugDAS,
    Here is a part of the output:
    "32 bits" "DB2 v8.1.4.428", "s040122", "WR21338", and FixPak "4".
    When I typed the command db2daslevel, it says that command is not a recognized command.
    Thank you.
  • SystemAdmin
    SystemAdmin
    17917 Posts

    Re: Unable to start DAS.

    ‏2006-04-24T12:13:28Z  
    Thanks for your reply.
    Here is the complete dasusr5 file:

    2006-02-27-15.26.22.269978 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - dasRootInit() probe:10
    data #1 (131 bytes)
    DAS startup error. Failed to bind to port 523. Please ensure
    that no other applications are using this port. Then restart the DAS.

    2006-02-27-15.26.22.270809 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - dasRootInit() probe:10
    data #1 (4 bytes)
    -2129723365

    2006-02-27-15.26.24.270898 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - db2dasSearchDscvInit() probe:30
    data #1 (4 bytes)
    67

    2006-02-27-15.26.24.270969 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - dasRootInit() probe:60
    data #1 (4 bytes)
    -1

    2006-02-27-15.26.24.271018 pid:282648 tid:1 level:2
    DB2 tools - DB2 administration server - rrm_main() probe:80
    data #1 (4 bytes)
    -3020

    2006-04-18-15.05.52.745391 pid:495814 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x9000000C Invalid parameter

    2006-04-18-15.10.52.769480 pid:704724 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x90000013 Time out

    2006-04-18-15.46.11.830043 pid:700476 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x90000013 Time out

    2006-04-18-15.56.06.835713 pid:708834 tid:1 level:2
    DB2 tools - DB2 administration server - readRrmSqlca() probe:20
    called OSSHIPCQueue::get()
    return code 0x90000013 Time out

    Initially part of file shows that 523 port is in use. But later part do not indicate anything like that.Just says TimeOut.
    What am I supposed to do now?
    One more question. Is it ok if I have two DAS(dasusr4,dasusr5) installed on same machine, but DAS has nothing in its directory?
    You may try to drop DAS and recreate it.

    -debugDAS
  • SystemAdmin
    SystemAdmin
    17917 Posts

    Re: Unable to start DAS.

    ‏2013-01-17T10:17:46Z  
    You may try to drop DAS and recreate it.

    -debugDAS
    Droping and recreating works. you can try it