Topic
5 replies Latest Post - ‏2006-03-08T03:59:33Z by SystemAdmin
SystemAdmin
SystemAdmin
684 Posts
ACCEPTED ANSWER

Pinned topic maxchannels attribute

‏2006-03-02T16:03:34Z |
Hi All,

I've craeted a listener using the MQeTcpipHistoryAdapter setting the
maxchannels attribute to 10 because i don´t want that have more than 10
clients receiving messages from the gateway at the same time.

When i try to get a message with only one client i get the following
exception:

com.ibm.mqe.MQeException: Channels limithttp://EDA0D.GTWAY.QM 38 (code=23)
at com.ibm.mqe.communications.MQeChannel.checkError(DashoA8173)
at com.ibm.mqe.communications.MQeChannel.activateMaster(DashoA8173)
at
com.ibm.mqe.communications.MQeConnectionDefinition._createNewChannel(DashoA8
173)
at
com.ibm.mqe.communications.MQeConnectionDefinition.getChannel(DashoA8173)
at
com.ibm.mqe.communications.MQeCommunicationsManager.getChannelControlBlock(D
ashoA8173)
at com.ibm.mqe.MQeTransporter._getChannelControlBlock(DashoA8173)
at com.ibm.mqe.MQeTransporter._prepare(DashoA8173)
at com.ibm.mqe.MQeTransporter.remoteExecute(DashoA8173)
at com.ibm.mqe.MQeTransporter.getMessage(DashoA8173)
at com.ibm.mqe.MQeRemoteQueue._synchronousGetMessage(DashoA8173)
at com.ibm.mqe.MQeRemoteQueue.getMessage(DashoA8173)
at com.ibm.mqe.MQeQueueControlBlock.getMessage(DashoA8173)
at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
at nt.mqe.WaitForMQeMessage.doIt(WaitForMQeMessage.java:98)
at nt.mqe.WaitForMQeMessage.main(WaitForMQeMessage.java:149)

I don´t know why i'm getting this exception. I'm only using one client
invoking the MQeQueueManager.waitForMessage method.

Any ideas?

Thanks,
Javier

Updated on 2006-03-08T03:59:33Z at 2006-03-08T03:59:33Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    684 Posts
    ACCEPTED ANSWER

    Re: maxchannels attribute

    ‏2006-03-03T04:34:12Z  in response to SystemAdmin
    Hi,

    Can you restart Gateway QM and try connecting the client.
    One thing to remember is the channel time out.
    Suppose a client connects to Gateway QM,does get/put operations and
    disconnects.
    The channel created for the disconnected client will remain in the
    Gateway QM till its timeout period.
    Hence next time a client connects ,the Gateway will have 2 channels
    opened (even if there is only one client connected at that time)

    regards,
    Vijay

    "Javier" <jaltauz@newtechnologies.com.ar> wrote in message
    news:du74st$3486s$1@news.boulder.ibm.com...
    > Hi All,
    >
    > I've craeted a listener using the MQeTcpipHistoryAdapter setting the
    > maxchannels attribute to 10 because i don´t want that have more than 10
    > clients receiving messages from the gateway at the same time.
    >
    > When i try to get a message with only one client i get the following
    > exception:
    >
    > com.ibm.mqe.MQeException: Channels limithttp://EDA0D.GTWAY.QM 38 (code=23)
    > at com.ibm.mqe.communications.MQeChannel.checkError(DashoA8173)
    > at com.ibm.mqe.communications.MQeChannel.activateMaster(DashoA8173)
    > at
    >
    com.ibm.mqe.communications.MQeConnectionDefinition._createNewChannel(DashoA8
    > 173)
    > at
    > com.ibm.mqe.communications.MQeConnectionDefinition.getChannel(DashoA8173)
    > at
    >
    com.ibm.mqe.communications.MQeCommunicationsManager.getChannelControlBlock(D
    > ashoA8173)
    > at com.ibm.mqe.MQeTransporter._getChannelControlBlock(DashoA8173)
    > at com.ibm.mqe.MQeTransporter._prepare(DashoA8173)
    > at com.ibm.mqe.MQeTransporter.remoteExecute(DashoA8173)
    > at com.ibm.mqe.MQeTransporter.getMessage(DashoA8173)
    > at com.ibm.mqe.MQeRemoteQueue._synchronousGetMessage(DashoA8173)
    > at com.ibm.mqe.MQeRemoteQueue.getMessage(DashoA8173)
    > at com.ibm.mqe.MQeQueueControlBlock.getMessage(DashoA8173)
    > at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
    > at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
    > at nt.mqe.WaitForMQeMessage.doIt(WaitForMQeMessage.java:98)
    > at nt.mqe.WaitForMQeMessage.main(WaitForMQeMessage.java:149)
    >
    > I don´t know why i'm getting this exception. I'm only using one client
    > invoking the MQeQueueManager.waitForMessage method.
    >
    > Any ideas?
    >
    > Thanks,
    > Javier
    >
    >

    • SystemAdmin
      SystemAdmin
      684 Posts
      ACCEPTED ANSWER

      Re: maxchannels attribute

      ‏2006-03-03T21:27:04Z  in response to SystemAdmin
      I've restarted the queue manager and i still getting the exception.
      Another idea?

      "vijay" <vij_mur@hotmail.com> wrote in message
      news:du8h2k$3po0m$1@news.boulder.ibm.com...
      > Hi,
      >
      > Can you restart Gateway QM and try connecting the client.
      > One thing to remember is the channel time out.
      > Suppose a client connects to Gateway QM,does get/put operations and
      > disconnects.
      > The channel created for the disconnected client will remain in the
      > Gateway QM till its timeout period.
      > Hence next time a client connects ,the Gateway will have 2 channels
      > opened (even if there is only one client connected at that time)
      >
      > regards,
      > Vijay
      >
      > "Javier" <jaltauz@newtechnologies.com.ar> wrote in message
      > news:du74st$3486s$1@news.boulder.ibm.com...
      > > Hi All,
      > >
      > > I've craeted a listener using the MQeTcpipHistoryAdapter setting the
      > > maxchannels attribute to 10 because i don´t want that have more than 10
      > > clients receiving messages from the gateway at the same time.
      > >
      > > When i try to get a message with only one client i get the following
      > > exception:
      > >
      > > com.ibm.mqe.MQeException: Channels limithttp://EDA0D.GTWAY.QM 38 (code=23)
      > > at com.ibm.mqe.communications.MQeChannel.checkError(DashoA8173)
      > > at com.ibm.mqe.communications.MQeChannel.activateMaster(DashoA8173)
      > > at
      > >
      >
      com.ibm.mqe.communications.MQeConnectionDefinition._createNewChannel(DashoA8
      > > 173)
      > > at
      > >
      com.ibm.mqe.communications.MQeConnectionDefinition.getChannel(DashoA8173)
      > > at
      > >
      >
      com.ibm.mqe.communications.MQeCommunicationsManager.getChannelControlBlock(D
      > > ashoA8173)
      > > at com.ibm.mqe.MQeTransporter._getChannelControlBlock(DashoA8173)
      > > at com.ibm.mqe.MQeTransporter._prepare(DashoA8173)
      > > at com.ibm.mqe.MQeTransporter.remoteExecute(DashoA8173)
      > > at com.ibm.mqe.MQeTransporter.getMessage(DashoA8173)
      > > at com.ibm.mqe.MQeRemoteQueue._synchronousGetMessage(DashoA8173)
      > > at com.ibm.mqe.MQeRemoteQueue.getMessage(DashoA8173)
      > > at com.ibm.mqe.MQeQueueControlBlock.getMessage(DashoA8173)
      > > at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
      > > at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
      > > at nt.mqe.WaitForMQeMessage.doIt(WaitForMQeMessage.java:98)
      > > at nt.mqe.WaitForMQeMessage.main(WaitForMQeMessage.java:149)
      > >
      > > I don´t know why i'm getting this exception. I'm only using one client
      > > invoking the MQeQueueManager.waitForMessage method.
      > >
      > > Any ideas?
      > >
      > > Thanks,
      > > Javier
      > >
      > >
      >
      >

      • SystemAdmin
        SystemAdmin
        684 Posts
        ACCEPTED ANSWER

        Re: maxchannels attribute

        ‏2006-03-06T11:51:53Z  in response to SystemAdmin
        Can i know the version of MQe used?
        regards,
        Vijay
        "Javier" <jaltauz@newtechnologies.com.ar> wrote in message
        news:duac4g$7j07q$1@news.boulder.ibm.com...
        > I've restarted the queue manager and i still getting the exception.
        > Another idea?
        >
        > "vijay" <vij_mur@hotmail.com> wrote in message
        > news:du8h2k$3po0m$1@news.boulder.ibm.com...
        > > Hi,
        > >
        > > Can you restart Gateway QM and try connecting the client.
        > > One thing to remember is the channel time out.
        > > Suppose a client connects to Gateway QM,does get/put operations and
        > > disconnects.
        > > The channel created for the disconnected client will remain in the
        > > Gateway QM till its timeout period.
        > > Hence next time a client connects ,the Gateway will have 2 channels
        > > opened (even if there is only one client connected at that time)
        > >
        > > regards,
        > > Vijay
        > >
        > > "Javier" <jaltauz@newtechnologies.com.ar> wrote in message
        > > news:du74st$3486s$1@news.boulder.ibm.com...
        > > > Hi All,
        > > >
        > > > I've craeted a listener using the MQeTcpipHistoryAdapter setting the
        > > > maxchannels attribute to 10 because i don´t want that have more than
        10
        > > > clients receiving messages from the gateway at the same time.
        > > >
        > > > When i try to get a message with only one client i get the following
        > > > exception:
        > > >
        > > > com.ibm.mqe.MQeException: Channels limithttp://EDA0D.GTWAY.QM 38 (code=23)
        > > > at com.ibm.mqe.communications.MQeChannel.checkError(DashoA8173)
        > > > at com.ibm.mqe.communications.MQeChannel.activateMaster(DashoA8173)
        > > > at
        > > >
        > >
        >
        com.ibm.mqe.communications.MQeConnectionDefinition._createNewChannel(DashoA8
        > > > 173)
        > > > at
        > > >
        > com.ibm.mqe.communications.MQeConnectionDefinition.getChannel(DashoA8173)
        > > > at
        > > >
        > >
        >
        com.ibm.mqe.communications.MQeCommunicationsManager.getChannelControlBlock(D
        > > > ashoA8173)
        > > > at com.ibm.mqe.MQeTransporter._getChannelControlBlock(DashoA8173)
        > > > at com.ibm.mqe.MQeTransporter._prepare(DashoA8173)
        > > > at com.ibm.mqe.MQeTransporter.remoteExecute(DashoA8173)
        > > > at com.ibm.mqe.MQeTransporter.getMessage(DashoA8173)
        > > > at com.ibm.mqe.MQeRemoteQueue._synchronousGetMessage(DashoA8173)
        > > > at com.ibm.mqe.MQeRemoteQueue.getMessage(DashoA8173)
        > > > at com.ibm.mqe.MQeQueueControlBlock.getMessage(DashoA8173)
        > > > at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
        > > > at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
        > > > at nt.mqe.WaitForMQeMessage.doIt(WaitForMQeMessage.java:98)
        > > > at nt.mqe.WaitForMQeMessage.main(WaitForMQeMessage.java:149)
        > > >
        > > > I don´t know why i'm getting this exception. I'm only using one client
        > > > invoking the MQeQueueManager.waitForMessage method.
        > > >
        > > > Any ideas?
        > > >
        > > > Thanks,
        > > > Javier
        > > >
        > > >
        > >
        > >
        >
        >

        • SystemAdmin
          SystemAdmin
          684 Posts
          ACCEPTED ANSWER

          Re: maxchannels attribute

          ‏2006-03-06T13:54:34Z  in response to SystemAdmin
          Yes, of course.

          I'm using MQ Everypace 2.0.2.0. My getway is running as a windows service
          using MQe_Service tool included in the Server Support.

          As a client, i'm using an extension of the ExamplaBase.java implementing th
          doIt() method.

          Thanks a lot!
          "vijay" <vij_mur@hotmail.com> wrote in message
          news:duh7rd$2rg7s$1@news.boulder.ibm.com...
          > Can i know the version of MQe used?
          > regards,
          > Vijay
          > "Javier" <jaltauz@newtechnologies.com.ar> wrote in message
          > news:duac4g$7j07q$1@news.boulder.ibm.com...
          > > I've restarted the queue manager and i still getting the exception.
          > > Another idea?
          > >
          > > "vijay" <vij_mur@hotmail.com> wrote in message
          > > news:du8h2k$3po0m$1@news.boulder.ibm.com...
          > > > Hi,
          > > >
          > > > Can you restart Gateway QM and try connecting the client.
          > > > One thing to remember is the channel time out.
          > > > Suppose a client connects to Gateway QM,does get/put operations
          and
          > > > disconnects.
          > > > The channel created for the disconnected client will remain in the
          > > > Gateway QM till its timeout period.
          > > > Hence next time a client connects ,the Gateway will have 2
          channels
          > > > opened (even if there is only one client connected at that time)
          > > >
          > > > regards,
          > > > Vijay
          > > >
          > > > "Javier" <jaltauz@newtechnologies.com.ar> wrote in message
          > > > news:du74st$3486s$1@news.boulder.ibm.com...
          > > > > Hi All,
          > > > >
          > > > > I've craeted a listener using the MQeTcpipHistoryAdapter setting the
          > > > > maxchannels attribute to 10 because i don´t want that have more than
          > 10
          > > > > clients receiving messages from the gateway at the same time.
          > > > >
          > > > > When i try to get a message with only one client i get the following
          > > > > exception:
          > > > >
          > > > > com.ibm.mqe.MQeException: Channels limithttp://EDA0D.GTWAY.QM 38
          (code=23)
          > > > > at com.ibm.mqe.communications.MQeChannel.checkError(DashoA8173)
          > > > > at com.ibm.mqe.communications.MQeChannel.activateMaster(DashoA8173)
          > > > > at
          > > > >
          > > >
          > >
          >
          com.ibm.mqe.communications.MQeConnectionDefinition._createNewChannel(DashoA8
          > > > > 173)
          > > > > at
          > > > >
          > >
          com.ibm.mqe.communications.MQeConnectionDefinition.getChannel(DashoA8173)
          > > > > at
          > > > >
          > > >
          > >
          >
          com.ibm.mqe.communications.MQeCommunicationsManager.getChannelControlBlock(D
          > > > > ashoA8173)
          > > > > at com.ibm.mqe.MQeTransporter._getChannelControlBlock(DashoA8173)
          > > > > at com.ibm.mqe.MQeTransporter._prepare(DashoA8173)
          > > > > at com.ibm.mqe.MQeTransporter.remoteExecute(DashoA8173)
          > > > > at com.ibm.mqe.MQeTransporter.getMessage(DashoA8173)
          > > > > at com.ibm.mqe.MQeRemoteQueue._synchronousGetMessage(DashoA8173)
          > > > > at com.ibm.mqe.MQeRemoteQueue.getMessage(DashoA8173)
          > > > > at com.ibm.mqe.MQeQueueControlBlock.getMessage(DashoA8173)
          > > > > at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
          > > > > at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
          > > > > at nt.mqe.WaitForMQeMessage.doIt(WaitForMQeMessage.java:98)
          > > > > at nt.mqe.WaitForMQeMessage.main(WaitForMQeMessage.java:149)
          > > > >
          > > > > I don´t know why i'm getting this exception. I'm only using one
          client
          > > > > invoking the MQeQueueManager.waitForMessage method.
          > > > >
          > > > > Any ideas?
          > > > >
          > > > > Thanks,
          > > > > Javier
          > > > >
          > > > >
          > > >
          > > >
          > >
          > >
          >
          >

          • SystemAdmin
            SystemAdmin
            684 Posts
            ACCEPTED ANSWER

            Re: maxchannels attribute

            ‏2006-03-08T03:59:33Z  in response to SystemAdmin
            Hi,

            Can you report the same through the Electronic Service Request?
            You can access it by following link

            http://www-306.ibm.com/software/support/help.html
            regards,
            Vijay
            "Javier" <jaltauz@newtechnologies.com.ar> wrote in message
            news:duhenv$1o84o$1@news.boulder.ibm.com...
            > Yes, of course.
            >
            > I'm using MQ Everypace 2.0.2.0. My getway is running as a windows service
            > using MQe_Service tool included in the Server Support.
            >
            > As a client, i'm using an extension of the ExamplaBase.java implementing
            th
            > doIt() method.
            >
            > Thanks a lot!
            >
            >
            > "vijay" <vij_mur@hotmail.com> wrote in message
            > news:duh7rd$2rg7s$1@news.boulder.ibm.com...
            > > Can i know the version of MQe used?
            > > regards,
            > > Vijay
            > > "Javier" <jaltauz@newtechnologies.com.ar> wrote in message
            > > news:duac4g$7j07q$1@news.boulder.ibm.com...
            > > > I've restarted the queue manager and i still getting the exception.
            > > > Another idea?
            > > >
            > > > "vijay" <vij_mur@hotmail.com> wrote in message
            > > > news:du8h2k$3po0m$1@news.boulder.ibm.com...
            > > > > Hi,
            > > > >
            > > > > Can you restart Gateway QM and try connecting the client.
            > > > > One thing to remember is the channel time out.
            > > > > Suppose a client connects to Gateway QM,does get/put operations
            > and
            > > > > disconnects.
            > > > > The channel created for the disconnected client will remain in
            the
            > > > > Gateway QM till its timeout period.
            > > > > Hence next time a client connects ,the Gateway will have 2
            > channels
            > > > > opened (even if there is only one client connected at that time)
            > > > >
            > > > > regards,
            > > > > Vijay
            > > > >
            > > > > "Javier" <jaltauz@newtechnologies.com.ar> wrote in message
            > > > > news:du74st$3486s$1@news.boulder.ibm.com...
            > > > > > Hi All,
            > > > > >
            > > > > > I've craeted a listener using the MQeTcpipHistoryAdapter setting
            the
            > > > > > maxchannels attribute to 10 because i don´t want that have more
            than
            > > 10
            > > > > > clients receiving messages from the gateway at the same time.
            > > > > >
            > > > > > When i try to get a message with only one client i get the
            following
            > > > > > exception:
            > > > > >
            > > > > > com.ibm.mqe.MQeException: Channels limithttp://EDA0D.GTWAY.QM 38
            > (code=23)
            > > > > > at com.ibm.mqe.communications.MQeChannel.checkError(DashoA8173)
            > > > > > at
            com.ibm.mqe.communications.MQeChannel.activateMaster(DashoA8173)
            > > > > > at
            > > > > >
            > > > >
            > > >
            > >
            >
            com.ibm.mqe.communications.MQeConnectionDefinition._createNewChannel(DashoA8
            > > > > > 173)
            > > > > > at
            > > > > >
            > > >
            > com.ibm.mqe.communications.MQeConnectionDefinition.getChannel(DashoA8173)
            > > > > > at
            > > > > >
            > > > >
            > > >
            > >
            >
            com.ibm.mqe.communications.MQeCommunicationsManager.getChannelControlBlock(D
            > > > > > ashoA8173)
            > > > > > at com.ibm.mqe.MQeTransporter._getChannelControlBlock(DashoA8173)
            > > > > > at com.ibm.mqe.MQeTransporter._prepare(DashoA8173)
            > > > > > at com.ibm.mqe.MQeTransporter.remoteExecute(DashoA8173)
            > > > > > at com.ibm.mqe.MQeTransporter.getMessage(DashoA8173)
            > > > > > at com.ibm.mqe.MQeRemoteQueue._synchronousGetMessage(DashoA8173)
            > > > > > at com.ibm.mqe.MQeRemoteQueue.getMessage(DashoA8173)
            > > > > > at com.ibm.mqe.MQeQueueControlBlock.getMessage(DashoA8173)
            > > > > > at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
            > > > > > at com.ibm.mqe.MQeQueueManager.waitForMessage(DashoA8173)
            > > > > > at nt.mqe.WaitForMQeMessage.doIt(WaitForMQeMessage.java:98)
            > > > > > at nt.mqe.WaitForMQeMessage.main(WaitForMQeMessage.java:149)
            > > > > >
            > > > > > I don´t know why i'm getting this exception. I'm only using one
            > client
            > > > > > invoking the MQeQueueManager.waitForMessage method.
            > > > > >
            > > > > > Any ideas?
            > > > > >
            > > > > > Thanks,
            > > > > > Javier
            > > > > >
            > > > > >
            > > > >
            > > > >
            > > >
            > > >
            > >
            > >
            >
            >