Topic
  • 6 replies
  • Latest Post - ‏2011-03-15T22:23:30Z by mmalc
SystemAdmin
SystemAdmin
6089 Posts

Pinned topic Unable to initialize deferred EJB.

‏2006-02-28T07:56:17Z |
Hi,

I am running WID 6.0.1 and when I try to launch my process via the BPC explorer. I get the following:
Root exception is com.ibm.ejs.container.ContainerEJBException: Unable to initialize deferred EJB.

I have seen there is a fix for WAS 6.0, is it applicable to WID ?
What does that exception means?

Any idea?

Thanks.
Fabrice.
Updated on 2011-03-15T22:23:30Z at 2011-03-15T22:23:30Z by mmalc
  • kolban
    kolban
    518 Posts

    Re: Unable to initialize deferred EJB.

    ‏2006-02-28T14:56:20Z  
    Fabrice,
    I think I want to say that ive seen this problem before and it seemed to be that the WID project and the published projects in the server were somehow out of synch. I would:

    1. Remove the published project from the server
    2. Restart the server
    3. Publish the project
    4. Retest ....

    If that doesn't work, try posting back with more details. Realize that this is a communal self help forum and not a replacement for PMRs raised with IBM support.

    Neil

    IBM pre-sales technical support on WID and WPS
  • SystemAdmin
    SystemAdmin
    6089 Posts

    Re: Unable to initialize deferred EJB.

    ‏2006-03-01T14:34:32Z  
    • kolban
    • ‏2006-02-28T14:56:20Z
    Fabrice,
    I think I want to say that ive seen this problem before and it seemed to be that the WID project and the published projects in the server were somehow out of synch. I would:

    1. Remove the published project from the server
    2. Restart the server
    3. Publish the project
    4. Retest ....

    If that doesn't work, try posting back with more details. Realize that this is a communal self help forum and not a replacement for PMRs raised with IBM support.

    Neil

    IBM pre-sales technical support on WID and WPS
    Hi Neil,

    Thanks for your response. I have already try to stop/start, add/remove the project and...that does not solve my problem.

    I think the problem comes from the fact that I am migratin a complete EAR file (containing EJB and service projects) from WSADI 5.1 to WID 6.0.1. I have followed the migration documentation. I have no compilation error and I am even able to see the process in the BPC explorer...but when I start the instance , I received a message saying that the component is not found...

    For the moment it is only experimental , of course if that would come business relevant I will manage to contact the IBM Support.
    I am busy setting up a weblog about wid and integration, just have a look if you are interested: http://fabriceyans.blogspot.com

    Thx.
    Fabrice.
  • Workflow
    Workflow
    1 Post

    Re: Unable to initialize deferred EJB.

    ‏2007-01-15T03:35:28Z  
    • kolban
    • ‏2006-02-28T14:56:20Z
    Fabrice,
    I think I want to say that ive seen this problem before and it seemed to be that the WID project and the published projects in the server were somehow out of synch. I would:

    1. Remove the published project from the server
    2. Restart the server
    3. Publish the project
    4. Retest ....

    If that doesn't work, try posting back with more details. Realize that this is a communal self help forum and not a replacement for PMRs raised with IBM support.

    Neil

    IBM pre-sales technical support on WID and WPS
    Yes. Restarting the server and deploying again will help solve this issue. Even for WID 6.0.2, we have this issue.
  • Thiru_Reddy
    Thiru_Reddy
    1 Post

    Re: Unable to initialize deferred EJB.

    ‏2010-02-22T08:43:49Z  
    • Workflow
    • ‏2007-01-15T03:35:28Z
    Yes. Restarting the server and deploying again will help solve this issue. Even for WID 6.0.2, we have this issue.
    Hi ,

    Please let me know the solution for this, am getting this error when i make call to
    remote (ejb) from a webservice.
  • SystemAdmin
    SystemAdmin
    6089 Posts

    Re: Unable to initialize deferred EJB.

    ‏2011-03-10T20:57:05Z  
    We are also having this issue deploying to WPS 7. If anyone could provide further info on how to fix this it would be appreciated.
  • mmalc
    mmalc
    216 Posts

    Re: Unable to initialize deferred EJB.

    ‏2011-03-15T22:23:30Z  
    We are also having this issue deploying to WPS 7. If anyone could provide further info on how to fix this it would be appreciated.
    I'd raise a PMR for this.

    Cheers
    Marvin