Topic
1 reply Latest Post - ‏2005-09-27T10:12:56Z by SystemAdmin
SystemAdmin
SystemAdmin
1479 Posts
ACCEPTED ANSWER

Pinned topic Setting WAS Test Server "home" directory.

‏2005-06-10T10:37:22Z |
How can I pass the current Workspace location as the "home" directory when starting a WAS 5.1 test server withing WSAD 5.1.1?

I am currently setting the system property "user.dir" to the absolute path of the workspace location, but this means that when I share the Servers project with colleagues using PVCS, they have to edit the property before running the server, if their workspace location is different to mine.

It would be much easier to use a WSAD variable to set the workspace path automatically.

Unfortunately, stetting the "user.dir" to "${workspace_loc} doesn't seem to work.

Any ideas welcomed.

Thanks
Updated on 2005-09-27T10:12:56Z at 2005-09-27T10:12:56Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1479 Posts
    ACCEPTED ANSWER

    Re: Setting WAS Test Server "home" directory.

    ‏2005-09-27T10:12:56Z  in response to SystemAdmin
    Hi,
    I am working in the same way (sharing projects), using the same environment (WSAD 5.1.1 and WAS 5.1).
    Our apps are retrieving files from working directory (we are not allowed to mess with server classpath and -D command line arguments). This works fine under WAS (when virtual server working directory is manually set to an absolute path), but as you said in your post, it does not work for the test server in WSAD.
    We also tried to modify user.dir in WSAD test server, but without succes.
    So we tried to set manually the test server working directory through the admin console, but this does not work (it keeps looking in the user.dir).
    So far, we are also using a property (JNDI) to set working directory locally (and change this value back to ./ before sending it to production (to deploy in WAS) (bad, bad, bad thing I know )).
    I wonder if this difference of server behaviour is a WSAD bug.
    I hope someone will provide a better solution.
    Regards