Topic
  • 5 replies
  • Latest Post - ‏2005-06-13T06:10:11Z by SystemAdmin
SystemAdmin
SystemAdmin
232 Posts

Pinned topic color text in gnome-terminal

‏2005-05-10T10:40:43Z |
Previuosly I was using Linux.
In that, when I do "ls", it used to list the files with different colors based on their types.

Now I am using solaris and gnome-terminal.
Here, I am not able to get the colors for file listing.
Also, I am not able to get colors in vim!

Please give tips to solve this.

Thanks,
Narendra
Updated on 2005-06-13T06:10:11Z at 2005-06-13T06:10:11Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    232 Posts

    Re: color text in gnome-terminal

    ‏2005-05-12T23:24:09Z  
    Did you try adding this to you .bashrc ( if you're using the bash shell )
    alias 'ls'='ls --color=always'

    I think it's the .kshrc if you're using the Korn shell.
  • SystemAdmin
    SystemAdmin
    232 Posts

    Re: color text in gnome-terminal

    ‏2005-05-12T23:25:44Z  
    Did you try adding this to you .bashrc ( if you're using the bash shell )
    alias 'ls'='ls --color=always'

    I think it's the .kshrc if you're using the Korn shell.
    Oops, forgot my colors in vim suggestion...

    I have this in my ~/.vimrc file
    if &t_Co > 2 || has("gui_running")
    syntax on
    set hlsearch
    endif
  • SystemAdmin
    SystemAdmin
    232 Posts

    Re: color text in gnome-terminal

    ‏2005-05-13T04:22:24Z  
    Oops, forgot my colors in vim suggestion...

    I have this in my ~/.vimrc file
    if &t_Co > 2 || has("gui_running")
    syntax on
    set hlsearch
    endif
    Hi,

    Thanks for the tips.
    I had all those things.
    Still it was not working.
    The ls program, I was using didn't have color option.
    So, I had to download the GNU-ls and after that it is working.
    For the vim, I had to create .Xdefaults program and set the .vimrc with the "syntax on".
    After these, it is working fine.

    But, still there is one problem. It takes a long time (nearly 10 seconds) to open any file using the new vi!
    Any idea how to solve this?

    Regards,
    Narendra
  • SystemAdmin
    SystemAdmin
    232 Posts

    Re: color text in gnome-terminal

    ‏2005-06-10T15:33:14Z  
    Hi,

    Thanks for the tips.
    I had all those things.
    Still it was not working.
    The ls program, I was using didn't have color option.
    So, I had to download the GNU-ls and after that it is working.
    For the vim, I had to create .Xdefaults program and set the .vimrc with the "syntax on".
    After these, it is working fine.

    But, still there is one problem. It takes a long time (nearly 10 seconds) to open any file using the new vi!
    Any idea how to solve this?

    Regards,
    Narendra
    Did you change anything else in the .vimrc ? I have a decent .vimrc I can post or email to you. Also, what kernel are you using? What are your system specs? Does this happen on any file or just large files? What version of VIM is it?
  • SystemAdmin
    SystemAdmin
    232 Posts

    Re: color text in gnome-terminal

    ‏2005-06-13T06:10:11Z  
    Did you change anything else in the .vimrc ? I have a decent .vimrc I can post or email to you. Also, what kernel are you using? What are your system specs? Does this happen on any file or just large files? What version of VIM is it?
    I use Solaris.
    I re-installed with the help of www.blastwave.org and everything is working fine now.

    Still, I am curious to see the contents of your .vimrc and add whatever is missing in mine:-)

    Thanks,
    Narendra