Topic
14 replies Latest Post - ‏2011-09-02T21:20:07Z by albert1245
SystemAdmin
SystemAdmin
1479 Posts
ACCEPTED ANSWER

Pinned topic web.xml and application.xml error

‏2004-11-03T14:26:41Z |
I imported a mystery application and got it to run on local
WS server - but I have this error that I can't seem to fix
(even though application compiles and runs)

CHKJ3000E: WAR Validation Failed: com.ibm.etools.archive.exception.DeploymentDescriptorLoadException: WEB-INF/web.xml

and this

IWAE0033W The module pdas-nva.war in Enterprise Application project pdas-nva is not mapped to a workbench project. Use the application editor to correct.

  • are there steps/clicks I can take to resolve mapping
the war to a project? Within application.xml on the
workbench the xml has no errors and all the field are filled in

Thanks for responses

T
Updated on 2011-09-02T21:20:07Z at 2011-09-02T21:20:07Z by albert1245
  • SystemAdmin
    SystemAdmin
    1479 Posts
    ACCEPTED ANSWER

    Re: web.xml and application.xml error

    ‏2006-03-20T20:45:02Z  in response to SystemAdmin
    I got same problem now. When I practice the red_book 246449 and rebuild the dynamic Web Projects (clean) by uing RAD 6.0:

    Severity Description Resource In Folder Location Creation Time
    2 CHKJ3000E: WAR Validation Failed: com.ibm.etools.j2ee.commonarchivecore.exception.DeploymentDescriptorLoadException: WEB-INF/web.xml BankBasicWeb March 20, 2006 2:31:16 PM

    Anyone can help?
    Wayne
    • SystemAdmin
      SystemAdmin
      1479 Posts
      ACCEPTED ANSWER

      Re: web.xml and application.xml error

      ‏2006-05-31T15:14:00Z  in response to SystemAdmin
      Wayne,

      Could you resolve your issue.
      I got the same problem.
      Can you pls let me know the solution.

      thanks
      Kalpana
      • SystemAdmin
        SystemAdmin
        1479 Posts
        ACCEPTED ANSWER

        Re: web.xml and application.xml error

        ‏2006-06-07T19:18:16Z  in response to SystemAdmin

        Hi,
        I had the same issue with an application I'm developing in RAD6 .. the error message just "suddenly appeared" one day after weeks of development.

        I resolved the issue (i.e. got the message to go away) by running the xml validator on my web.xml (in RAD 6.0 navigator or package explorer view right click on the web.xml and select "Run Validation")
        • SystemAdmin
          SystemAdmin
          1479 Posts
          ACCEPTED ANSWER

          Re: web.xml and application.xml error

          ‏2006-12-21T07:58:58Z  in response to SystemAdmin
          The other solution is.

          Open project properties.
          In Validation section check "Override validation preferences".

          And then

          Uncheck "Run validation when you manually..."
          Uncheck "Run validation automatically..."

          clean project and rebuild.
          • SystemAdmin
            SystemAdmin
            1479 Posts
            ACCEPTED ANSWER

            Re: web.xml and application.xml error

            ‏2007-04-13T13:51:58Z  in response to SystemAdmin
            That solution seems to have worked for me using "WebSphere Developer for System Z - 7.0"

            To reiterate:
            * I opened the project properties for the web app, overrode validation and suspended all validators.
            * Did the same for the EAR project associated with the web app.
            * Cleaned both projects.
            * Rebuilt both projects.
            * Re-enabled validators.
        • SystemAdmin
          SystemAdmin
          1479 Posts
          ACCEPTED ANSWER

          Re: web.xml and application.xml error

          ‏2007-12-27T11:18:13Z  in response to SystemAdmin
          This is the best and more appropriate solution!
        • SystemAdmin
          SystemAdmin
          1479 Posts
          ACCEPTED ANSWER

          Re: web.xml and application.xml error

          ‏2008-12-04T09:58:21Z  in response to SystemAdmin
          Very good!
          I have got ridded of it!
          TK!
          • albert1245
            albert1245
            1 Post
            ACCEPTED ANSWER

            Re: web.xml and application.xml error

            ‏2011-09-02T21:20:07Z  in response to SystemAdmin
            Adding a space in web.xml is the solution also worked for me. Error message CHKJ3000E is gone.
            Thanks for the suggestion. IBM should figure out what causes the original error and fix.
    • SystemAdmin
      SystemAdmin
      1479 Posts
      ACCEPTED ANSWER

      Re: web.xml and application.xml error

      ‏2008-04-11T07:17:17Z  in response to SystemAdmin
      Hi
      can mail me the zip file for BankBasicWeb project. my mail id is luckychawla2k@gmail.com
      Thanks In advance .
  • SystemAdmin
    SystemAdmin
    1479 Posts
    ACCEPTED ANSWER

    Re: web.xml and application.xml error

    ‏2007-07-25T11:37:04Z  in response to SystemAdmin
    Hi,

    Even I have got the same error. Did any one knows the solution.

    Error:-
    CHKJ3000E: WAR Validation Failed: com.ibm.etools.archive.exception.DeploymentDescriptorLoadException: WEB-INF/web.xml

    Thanks
    • SystemAdmin
      SystemAdmin
      1479 Posts
      ACCEPTED ANSWER

      Re: web.xml and application.xml error

      ‏2007-09-15T11:42:40Z  in response to SystemAdmin
      Hi,

      I tried disabling the validation, error disappeared. But when I deployed on WAS I got the same error..

      Please help resolve this issue.

      Thanks
      Ayub
    • SystemAdmin
      SystemAdmin
      1479 Posts
      ACCEPTED ANSWER

      Re: web.xml and application.xml error

      ‏2007-10-26T21:18:32Z  in response to SystemAdmin
      Hey, One fine morning I opened my RAD and I got the same problem; all that I did was, I opened the Web.xml just added a space and then saved and did a clean build; to my surprise the error disappeared.
  • spansoft
    spansoft
    2 Posts
    ACCEPTED ANSWER

    Re: web.xml and application.xml error

    ‏2007-10-01T20:15:50Z  in response to SystemAdmin
    Same Error. Tried disabling and enabling Validation in RAD 7.0.0
    Any solution would be great.
    • spansoft
      spansoft
      2 Posts
      ACCEPTED ANSWER

      Re: web.xml and application.xml error. I think I fixed it.

      ‏2007-10-01T21:54:08Z  in response to spansoft
      Hello there,
      I think my problem is fixed. You can check my reply to one other post here http://www.ibm.com/developerworks/forums/dw_thread.jsp?message=13997532&cat=24&thread=141106&treeDisplayType=threadmode1&forum=1018#13997532

      Best regards...