Topic
  • 1 reply
  • Latest Post - ‏2003-03-13T12:51:56Z by SystemAdmin
SystemAdmin
SystemAdmin
3908 Posts

Pinned topic IBM Http 2.0, ssl and reverse proxy

‏2003-03-13T12:51:17Z |
Hi all, I'm trying to set up IHS 2.0 as a reverse proxy using mod_proxy.
It works fine for non-ssl, but fails for my ssl'ed virtual host.
The relevant configuration lines:
ProxyPass / http://10.0.0.2:8080/
ProxyPassReverse / http://10.0.0.2:8080/

From the error.log:

For the ssl-virtual host:

Thu Mar 13 13:47:39 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(109): proxy: HTTP:
canonicalising URL //10.0.0.2:8080/1023/
Thu Mar 13 13:47:39 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\mod_proxy.c(461): Trying to run
scheme_handler
Thu Mar 13 13:47:39 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(1063): proxy: HTTP:
serving URL http://10.0.0.2:8080/1023/
Thu Mar 13 13:47:39 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(221): proxy: HTTP
connecting http://10.0.0.2:8080/1023/ to 10.0.0.2:8080
Thu Mar 13 13:47:39 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_util.c(1167): proxy: HTTP:
fam 2 socket created to connect to 10.0.0.2
Thu Mar 13 13:47:39 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(370): proxy: socket
is connected
Thu Mar 13 13:47:39 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(404): proxy:
connection complete to 10.0.0.2:8080 (10.0.0.2)
Thu Mar 13 13:48:39 2003 info SSL0240I: SSL Handshake Failed, Socket
has been closed.
Thu Mar 13 13:48:39 2003 error (-1)Unknown error: proxy: request
failed to 10.0.0.2:8080 (10.0.0.2)
Thu Mar 13 13:48:39 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_ftp.c(816): proxy: FTP:
declining URL http://10.0.0.2:8080/1023/ - not ftp:
Thu Mar 13 13:48:39 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_connect.c(145): proxy:
CONNECT: declining URL http://10.0.0.2:8080/1023/
Thu Mar 13 13:48:39 2003 warn proxy: No protocol handler was valid
for the URL /1023/. If you are using a DSO version of mod_proxy, make
sure the proxy submodules are included in the configuration using
LoadModule.
Thu Mar 13 13:48:55 2003 info SSL0400I: I/O failed, RC 406
Thu Mar 13 13:48:58 2003 info SSL0400I: I/O failed, RC 406
For the non-ssl virtual host:

Thu Mar 13 13:49:28 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(109): proxy: HTTP:
canonicalising URL //10.0.0.2:8080/1023/
Thu Mar 13 13:49:28 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\mod_proxy.c(461): Trying to run
scheme_handler
Thu Mar 13 13:49:28 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(1063): proxy: HTTP:
serving URL http://10.0.0.2:8080/1023/
Thu Mar 13 13:49:28 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(221): proxy: HTTP
connecting http://10.0.0.2:8080/1023/ to 10.0.0.2:8080
Thu Mar 13 13:49:28 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_util.c(1167): proxy: HTTP:
fam 2 socket created to connect to 10.0.0.2
Thu Mar 13 13:49:28 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(370): proxy: socket
is connected
Thu Mar 13 13:49:28 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(404): proxy:
connection complete to 10.0.0.2:8080 (10.0.0.2)
Thu Mar 13 13:49:28 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(903): proxy: start
body send
Thu Mar 13 13:49:28 2003 debug
D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(962): proxy: end
body send

AND:
This works fine with IHS 1.3.19.*

Any help would be appreciated

-Gaute Småland
Updated on 2003-03-13T12:51:56Z at 2003-03-13T12:51:56Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    3908 Posts

    Re: IBM Http 2.0, ssl and reverse proxy

    ‏2003-03-13T12:51:56Z  
    The exact version number is 2.0.42.

    -Gaute

    Gaute Smaaland wrote:

    > Hi all, I'm trying to set up IHS 2.0 as a reverse proxy using
    > mod_proxy. It works fine for non-ssl, but fails for my ssl'ed virtual
    > host.
    > The relevant configuration lines:
    > ProxyPass / http://10.0.0.2:8080/
    > ProxyPassReverse / http://10.0.0.2:8080/
    >
    > From the error.log:
    >
    > For the ssl-virtual host:
    >
    > Thu Mar 13 13:47:39 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(109): proxy: HTTP:
    > canonicalising URL //10.0.0.2:8080/1023/
    > Thu Mar 13 13:47:39 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\mod_proxy.c(461): Trying to run
    > scheme_handler
    > Thu Mar 13 13:47:39 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(1063): proxy:
    > HTTP: serving URL http://10.0.0.2:8080/1023/
    > Thu Mar 13 13:47:39 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(221): proxy: HTTP
    > connecting http://10.0.0.2:8080/1023/ to 10.0.0.2:8080
    > Thu Mar 13 13:47:39 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_util.c(1167): proxy:
    > HTTP: fam 2 socket created to connect to 10.0.0.2
    > Thu Mar 13 13:47:39 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(370): proxy:
    > socket is connected
    > Thu Mar 13 13:47:39 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(404): proxy:
    > connection complete to 10.0.0.2:8080 (10.0.0.2)
    > Thu Mar 13 13:48:39 2003 info SSL0240I: SSL Handshake Failed,
    > Socket has been closed.
    > Thu Mar 13 13:48:39 2003 error (-1)Unknown error: proxy: request
    > failed to 10.0.0.2:8080 (10.0.0.2)
    > Thu Mar 13 13:48:39 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_ftp.c(816): proxy: FTP:
    > declining URL http://10.0.0.2:8080/1023/ - not ftp:
    > Thu Mar 13 13:48:39 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_connect.c(145): proxy:
    > CONNECT: declining URL http://10.0.0.2:8080/1023/
    > Thu Mar 13 13:48:39 2003 warn proxy: No protocol handler was valid
    > for the URL /1023/. If you are using a DSO version of mod_proxy, make
    > sure the proxy submodules are included in the configuration using
    > LoadModule.
    > Thu Mar 13 13:48:55 2003 info SSL0400I: I/O failed, RC 406
    > Thu Mar 13 13:48:58 2003 info SSL0400I: I/O failed, RC 406
    >
    >
    > For the non-ssl virtual host:
    >
    > Thu Mar 13 13:49:28 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(109): proxy: HTTP:
    > canonicalising URL //10.0.0.2:8080/1023/
    > Thu Mar 13 13:49:28 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\mod_proxy.c(461): Trying to run
    > scheme_handler
    > Thu Mar 13 13:49:28 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(1063): proxy:
    > HTTP: serving URL http://10.0.0.2:8080/1023/
    > Thu Mar 13 13:49:28 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(221): proxy: HTTP
    > connecting http://10.0.0.2:8080/1023/ to 10.0.0.2:8080
    > Thu Mar 13 13:49:28 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_util.c(1167): proxy:
    > HTTP: fam 2 socket created to connect to 10.0.0.2
    > Thu Mar 13 13:49:28 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(370): proxy:
    > socket is connected
    > Thu Mar 13 13:49:28 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(404): proxy:
    > connection complete to 10.0.0.2:8080 (10.0.0.2)
    > Thu Mar 13 13:49:28 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(903): proxy: start
    > body send
    > Thu Mar 13 13:49:28 2003 debug
    > D:\Build\WWWIHS20\apache\modules\proxy\proxy_http.c(962): proxy: end
    > body send
    >
    > AND:
    > This works fine with IHS 1.3.19.*
    >
    > Any help would be appreciated
    >
    > -Gaute Småland
    >