Topic
  • 8 replies
  • Latest Post - ‏2013-06-03T23:33:07Z by wernerK
wernerK
wernerK
34 Posts

Pinned topic RPE process not finishing off

‏2013-05-23T05:14:23Z |

Hello all -

Synopsis:  RPE does not finish /kill its own process once the export is complete on the host machine.

Description: RPE is presented to the user via CITRIX; the host servers are loadbalanced in the way that when to many users, or processes, are on one host, then the next host is addressed, etc; this worked fine until we upgraded to RPE 1.2 - now RPE does not finishes/ ends /kills its own process and users have to logout and then re-login - which is not desirable.

Platform: Windows 2003 server, XenApp with a plugin of 11.0.05357 - I think its something like XenApp5.1 (guessing at the moment)

Can not find any setting for the ini file or on install to make this go away -
anyone else with similar problems??

 

Thanks in advance

Werner

 

 

  • Dragos.Cojocari
    Dragos.Cojocari
    1654 Posts

    Re: RPE process not finishing off

    ‏2013-05-28T12:44:39Z  

    Hey Werner,

    are you using RPE Launcher   through the command line API? What RPE version are you on?

    Regards,

       Dragos

  • wernerK
    wernerK
    34 Posts

    Re: RPE process not finishing off

    ‏2013-05-29T23:54:59Z  

    Hey Werner,

    are you using RPE Launcher   through the command line API? What RPE version are you on?

    Regards,

       Dragos

    Hello and G'day Dragos -

    yes, we are using RPE Launcher via command line and we are using

    RPE 1.2

    DOORS 9.5

    Microsoft WORD 2007 and 2010

    sorry  it did not come across clearly, but I did say in my post that we upgraded to RPE 1.2, I should have been clearer on that.

     

    cheers

    werner

  • Dragos.Cojocari
    Dragos.Cojocari
    1654 Posts

    Re: RPE process not finishing off

    ‏2013-05-30T10:21:13Z  
    • wernerK
    • ‏2013-05-29T23:54:59Z

    Hello and G'day Dragos -

    yes, we are using RPE Launcher via command line and we are using

    RPE 1.2

    DOORS 9.5

    Microsoft WORD 2007 and 2010

    sorry  it did not come across clearly, but I did say in my post that we upgraded to RPE 1.2, I should have been clearer on that.

     

    cheers

    werner

    Hey Werner,

    I assume you have a command line looking like this: "%RPE_HOME%\launcher\rpe-launcher.exe" -publish <dx path> -noresult

    RPE 1.2 would indeed not close after executing it but we have addressed this in RPE 1.2.0.1

    Regards,

       Dragos

  • wernerK
    wernerK
    34 Posts

    Re: RPE process not finishing off

    ‏2013-05-31T00:25:17Z  

    Hey Werner,

    I assume you have a command line looking like this: "%RPE_HOME%\launcher\rpe-launcher.exe" -publish <dx path> -noresult

    RPE 1.2 would indeed not close after executing it but we have addressed this in RPE 1.2.0.1

    Regards,

       Dragos

    Hi Dragos,

    affirmative, yes, we are using a similar command line indeed.

    I have now downloaded the next version of RPE and am in progress to uninstall Installation manager, RPE and then re-install Installation manager and install the patch. I find it quite annoying that I have to download a new version of installation manager to install a patch.

    Rather time consuming really. Because you have to uninstall ALL installed Products you have installed with Installation Manager 1.6.0

    in order to:

    download  Installation Manager 1.6.2 - which is luckily accumulative and does contain/ include Installation Manager 1.6.1

    download RPE 1.2.0.1

    install Installation Manager 1.6.2 - reinstall ALL products again, including RPE 1.2.0.1

    test it on a test server - fingers crossed

    and then apply to all our servers - which we have to raise Change Requests, obtain approvals for etc etc etc....

    --- very time consuming indeed ---

    I checked the date when the patch 1.2.0.1 was released to the IBM website - April 2013 - I find -

    I checked the date when we downloaded RPE 1.2 - and it shows a date of December 2012

    Now then, why on earth were we ( all IBM RPE customers ) not informed of this bug ??? Or was there an announcement I missed ?

    Can I ask whether you have tested this patch, RPE 1.2.0.1, thouroughly on a similar, hopefully the same, environment as ours ?

     

    Probably, comes to the think off it, it was our/ my mistake to upgrade to a just released version.

      Back to testing for me, ciao for now.

    cheers

    werner

    Updated on 2013-05-31T00:44:05Z at 2013-05-31T00:44:05Z by wernerK
  • Dragos.Cojocari
    Dragos.Cojocari
    1654 Posts

    Re: RPE process not finishing off

    ‏2013-05-31T07:42:39Z  
    • wernerK
    • ‏2013-05-31T00:25:17Z

    Hi Dragos,

    affirmative, yes, we are using a similar command line indeed.

    I have now downloaded the next version of RPE and am in progress to uninstall Installation manager, RPE and then re-install Installation manager and install the patch. I find it quite annoying that I have to download a new version of installation manager to install a patch.

    Rather time consuming really. Because you have to uninstall ALL installed Products you have installed with Installation Manager 1.6.0

    in order to:

    download  Installation Manager 1.6.2 - which is luckily accumulative and does contain/ include Installation Manager 1.6.1

    download RPE 1.2.0.1

    install Installation Manager 1.6.2 - reinstall ALL products again, including RPE 1.2.0.1

    test it on a test server - fingers crossed

    and then apply to all our servers - which we have to raise Change Requests, obtain approvals for etc etc etc....

    --- very time consuming indeed ---

    I checked the date when the patch 1.2.0.1 was released to the IBM website - April 2013 - I find -

    I checked the date when we downloaded RPE 1.2 - and it shows a date of December 2012

    Now then, why on earth were we ( all IBM RPE customers ) not informed of this bug ??? Or was there an announcement I missed ?

    Can I ask whether you have tested this patch, RPE 1.2.0.1, thouroughly on a similar, hopefully the same, environment as ours ?

     

    Probably, comes to the think off it, it was our/ my mistake to upgrade to a just released version.

      Back to testing for me, ciao for now.

    cheers

    werner

    Hey Werner,

     

    >>> Rather time consuming really. Because you have to uninstall ALL installed Products you have installed with Installation Manager 1.6.0

    I am not aware of this being required. I'll double check with my colleagues on this but I do not think you need to remove installed products in order to install a new IM.

    >>> Now then, why on earth were we ( all IBM RPE customers ) not informed of this bug ??? Or was there an announcement I missed ?

    As far as I know announcements are not made for every defect discovered. So when you run into a problem you should contact support as that ensures you will get the fastest and most up to date information on that problem and possible solutions to it.

     

    Regards,

       Dragos

  • wernerK
    wernerK
    34 Posts

    Re: RPE process not finishing off

    ‏2013-06-03T01:48:34Z  

    Hey Werner,

     

    >>> Rather time consuming really. Because you have to uninstall ALL installed Products you have installed with Installation Manager 1.6.0

    I am not aware of this being required. I'll double check with my colleagues on this but I do not think you need to remove installed products in order to install a new IM.

    >>> Now then, why on earth were we ( all IBM RPE customers ) not informed of this bug ??? Or was there an announcement I missed ?

    As far as I know announcements are not made for every defect discovered. So when you run into a problem you should contact support as that ensures you will get the fastest and most up to date information on that problem and possible solutions to it.

     

    Regards,

       Dragos

    Hello Dragos -

    with IM - my mistake - I ve attached a document which shows a screenshot which made me think that you can not update IM and uninstall all previous installed product. sorry.

    But when uninstalling an earlier version of RPE and you forget to delete the Desktop icon before then you can not delete the desktop icons after, at least I dont know yet how to delete the icons for the launcher and studio. :(

    with regard to the second issue, all I want to place here is that I did open a PMR on the 28 may 2013, number 34717, which I will close later today, because you pointed out the fix for it.

    cheers

    Werner

  • Horia
    Horia
    89 Posts

    Re: RPE process not finishing off

    ‏2013-06-03T11:45:05Z  
    • wernerK
    • ‏2013-06-03T01:48:34Z

    Hello Dragos -

    with IM - my mistake - I ve attached a document which shows a screenshot which made me think that you can not update IM and uninstall all previous installed product. sorry.

    But when uninstalling an earlier version of RPE and you forget to delete the Desktop icon before then you can not delete the desktop icons after, at least I dont know yet how to delete the icons for the launcher and studio. :(

    with regard to the second issue, all I want to place here is that I did open a PMR on the 28 may 2013, number 34717, which I will close later today, because you pointed out the fix for it.

    cheers

    Werner

    Hi Werner,

    You don't need to uninstall IM (nor any programs installer by it) to upgrade to a newer IM version.

    As for the issue regarding desktop shortcuts I believe it is simply a refresh problem. If you notice older shortcuts still present, try to see if pressing F5 on your desktop helps in getting rid of the old icons.

     

    Regards / Horia

  • wernerK
    wernerK
    34 Posts

    Re: RPE process not finishing off

    ‏2013-06-03T23:33:07Z  
    • Horia
    • ‏2013-06-03T11:45:05Z

    Hi Werner,

    You don't need to uninstall IM (nor any programs installer by it) to upgrade to a newer IM version.

    As for the issue regarding desktop shortcuts I believe it is simply a refresh problem. If you notice older shortcuts still present, try to see if pressing F5 on your desktop helps in getting rid of the old icons.

     

    Regards / Horia

    Hello Horia -

    The IM program was a bit confusing to actually report that it needs to uninstall all other programs. That's why I decided to go the long way rather than getting stuck later. It would be nice if that appear in the manual of IM.

    I did restart my PC yesterday and surprisingly enough the 'old' desktop icons dissapeared, so a refresh would do the same I suppose.

    thankyou for your response

    regards

    werner