IC SunsetThe developerWorks Connections platform will be sunset on December 31, 2019. On January 1, 2020, this community and its apps will no longer be available. More details available on our FAQ.
Topic
  • 4 replies
  • Latest Post - ‏2019-08-13T09:19:54Z by szymonz
mszleminski@IBM-PL
mszleminski@IBM-PL
23 Posts

Pinned topic Cannot connect Integration Designer to Process Center

‏2014-08-26T12:57:48Z |

Hi everyone

I'm on 8.5.5 and I'm getting the following message in the IID log in workspace metadata when I try to connect to a server. I am getting this both on attempts made via http and via https. Both work from the browser, however. If anybody could please shed some light on this, I would really appreciate it!

Thank you

Maciej

 

!ENTRY com.ibm.wbit.ui 4 0 2014-08-26 14:53:18.647
!MESSAGE The connection was not successful, probably because of a server error or an incorrect path. For more information, see the Error Log.
!STACK 0
com.ibm.wbit.ui.internal.processcenterview.ConnectionIOException: Http connection failed.
com.ibm.wbit.ui.internal.processcenterview.ConnectionIOException@b90df40c ErrorCode: ERROR_PATH Uri: https://ibmbpm:9443/ProcessCenter/ Method: GET HttpResponseCode: -1 ServerResponse: null Authentication: true ErrorMessage: null
    at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeHttpMethod(ConnectionTester.java:395)
    at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeMethod(ConnectionTester.java:437)
    at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.access$0(ConnectionTester.java:424)
    at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester$1.run(ConnectionTester.java:99)
    at com.ibm.wbit.lombardi.core.utils.AsyncThread.run(AsyncThread.java:50)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: com.ibm.wbit.ui.internal.processcenterview.ConnectionIOException: Http connection failed.
com.ibm.wbit.ui.internal.processcenterview.ConnectionIOException@c3e33d6d ErrorCode: ERROR_PATH Uri: https://ibmbpm:9443/ProcessCenter/ Method: GET HttpResponseCode: 302 ServerResponse:  Authentication: false ErrorMessage: null
    at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.createException(ConnectionTester.java:514)
    at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeHttpMethod(ConnectionTester.java:414)
    at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeMethod(ConnectionTester.java:437)
    at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeHttpMethod(ConnectionTester.java:393)
    ... 5 more

  • Gilles 39
    Gilles 39
    33 Posts

    Re: Cannot connect Integration Designer to Process Center

    ‏2014-08-27T13:14:51Z  

    Maybe check what's in Process Center log (AppClr)  and also in WAS Deployment Manager log. IID tries to connect both to PC in order to access to PC artefact but also to WAS Dmgr in order to deploy things on WAS directly. Check credentials, in security properties of the servers visible in IID server pane.

  • mszleminski@IBM-PL
    mszleminski@IBM-PL
    23 Posts

    Re: Cannot connect Integration Designer to Process Center

    ‏2014-08-28T06:14:02Z  

    Maybe check what's in Process Center log (AppClr)  and also in WAS Deployment Manager log. IID tries to connect both to PC in order to access to PC artefact but also to WAS Dmgr in order to deploy things on WAS directly. Check credentials, in security properties of the servers visible in IID server pane.

    Hi

    I was trying to use IID 8.5 to connect to a 8.5.5 PC. The message could have been more clear (I simply didn't know the customer's environment didn't have IID upgraded as well), but in the end the solution was quite simple, upgrading IID. :)

     

    Have a great day,
    Maciek

  • szymonz
    szymonz
    2 Posts

    Re: Cannot connect Integration Designer to Process Center

    ‏2019-08-12T11:30:08Z  

    Hello,

    I have simillar problem, the same message in IID logs, different thing is that it is happening in BAW, I cannot login in Workflow Center and cannot publish to WC, but I see server as [Started, Synchronized] in Servers tab and can do Refresh from WC... (v 18.0.0.2)

    WC works fine from the browser... same as websphere console,

    Do you have any idea why?

     

    [12-aug-2019 13:15:57.990 CEST] 00000001 bpmHist       E [com.ibm.wbit.ui.GeneralUITracing$6:logging(GeneralUITracing.java:270)] FROM_ECLIPSE_ERROR_LOG The connection was not successful, probably because of a server error or an incorrect path. For more information, see the Error Log. ConnectionIOException(Http connection failed.) Details...
    com.ibm.wbit.ui.internal.processcenterview.ConnectionIOException: Http connection failed.
    com.ibm.wbit.ui.internal.processcenterview.ConnectionIOException@5c98ad43 ErrorCode: ERROR_PATH Uri: [hostname] Method: GET HttpResponseCode: -1 ServerResponse: null Authentication: true ErrorMessage: null
        at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeHttpMethod(ConnectionTester.java:637)
        at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeMethod(ConnectionTester.java:704)
        at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.access$0(ConnectionTester.java:694)
        at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester$1.run(ConnectionTester.java:210)
        at com.ibm.wbit.lombardi.core.utils.AsyncThread.run(AsyncThread.java:50)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
    Caused by: com.ibm.wbit.ui.internal.processcenterview.ConnectionIOException: Http connection failed.
    com.ibm.wbit.ui.internal.processcenterview.ConnectionIOException@faf7e3a3 ErrorCode: ERROR_PATH Uri: [hostname] Method: GET HttpResponseCode: -1 ServerResponse: null Authentication: true ErrorMessage: null
        at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeHttpMethod(ConnectionTester.java:637)
        at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeMethod(ConnectionTester.java:704)
        at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeHttpMethod(ConnectionTester.java:635)
        ... 5 more
    Caused by: com.ibm.wbit.ui.internal.processcenterview.ConnectionIOException: Http connection failed.
    com.ibm.wbit.ui.internal.processcenterview.ConnectionIOException@b7cc06ca ErrorCode: ERROR_PATH Uri: [hostname] Method: GET HttpResponseCode: 302 ServerResponse:  Authentication: false ErrorMessage: null
        at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.createException(ConnectionTester.java:780)
        at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeHttpMethod(ConnectionTester.java:682)
        at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeMethod(ConnectionTester.java:704)
        at com.ibm.wbit.ui.internal.processcenterview.ConnectionTester.invokeHttpMethod(ConnectionTester.java:635)
        ... 7 more

    Updated on 2019-08-12T11:43:12Z at 2019-08-12T11:43:12Z by szymonz
  • szymonz
    szymonz
    2 Posts

    Re: Cannot connect Integration Designer to Process Center

    ‏2019-08-13T09:19:54Z  

    I found workaround solution, if I swich to new workspace it is working again... but every time when I close and open ID I have to switch...