Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
2 replies Latest Post - ‏2013-09-18T13:31:46Z by KISHOREINGERSAL
Damy
Damy
1 Post
ACCEPTED ANSWER

Pinned topic HTTP service won't start in Window

‏2013-04-22T23:14:14Z |

Tried to config HTTPD.CONF to point my Websphere. There is one line cause the HTTP service not be able to start -

it got "Service-specific error code 1".

System event viewer show "The IBM Thhp Server V8.5 service terminated with service-specific error Incorrect Function" - event ID 7024.

This is run under Window server 2008 R2 standard.

The line in the HTTPD.cong is

WebSpherePluginConfig "C:/Program Files (x86)/IBM/WebSphere/AppServer/profiles/Dmgr01/config/cells/plugin-cfg.xml"
 

Any advice please ? Thanks.

 

 

 

 

 

  • Sunit
    Sunit
    194 Posts
    ACCEPTED ANSWER

    Re: HTTP service won't start in Window

    ‏2013-04-24T19:11:41Z  in response to Damy

    Do you have a line like:

    LoadModule was_ap22_module 
    "C:\Program Files\IBM\HTTPServer\Plugins\bin\mod_was_ap22_http.dll"
    

    just before the above line? Also plugin-cfg.xml should be loaded from the plugins config directory.

     

    --Sunit

     

    • KISHOREINGERSAL
      KISHOREINGERSAL
      3 Posts
      ACCEPTED ANSWER

      Re: HTTP service won't start in Window

      ‏2013-09-18T13:31:46Z  in response to Sunit

      Check the below configuration entries are placed in correct location as it is mentioned in your http.conf. This will lead to startup failure

      LoadModule was_ap20_module "D:\WebSphere\Plugins\bin\mod_was_ap20_http.dll"
      WebSpherePluginConfig "D:\WebSphere\Plugins\config\webserver1\plugin-cfg_combo.xml"

      - Kishore Kumar Ingersal