Topic
  • 1 reply
  • Latest Post - ‏2017-01-20T16:38:41Z by Casey Cantwell
jwcb008
jwcb008
6 Posts

Pinned topic iPad Compatibility

‏2017-01-20T13:30:07Z |
What is the compatibility with iPads?  

 

I believe the supported OSes list does not include iOS officially.  With the advent of iPad Pros, the line between iPhone-like devices and computers gets further blurred.  After all an iPad Pro begins to feel a lot like a MacBook Air.  I know there is support for Safari on a computer as well and generally the move is to become device agnostic.  I need to put forth some guidance about iPads Pros and TRIRIGA.  My initial observation is that some basic functions don't work correctly - perhaps HTML5 related?  For example, rendering the portal.  The page starts loading correctly but then the screen jiggers a bit and then seems to stabilize, but scroll bars never appear and  the user cannot move up or down.  I've tested in both Safari and Chrome.
  • Casey Cantwell
    Casey Cantwell
    177 Posts
    ACCEPTED ANSWER

    Re: iPad Compatibility

    ‏2017-01-20T16:38:41Z  

    Official Support of IBM TRIRIGA on iPads is limited to the IBM TRIRIGA UX Framework and Perceptive Applications.  

    Traditional TRIRIGA, Portal, and non UX Applications are only supported on Windows and Mac OS X operating systems when running Safari, Chrome, Edge, Firefox,or IE 11.  Although a lot of non UX TRIRIGA will load on an iPad, you will run into some limitations as you have noted above.

     

     

    IBM TRIRIGA UX Framework and Perceptive Applications

    Operating Systems / Browsers

    Minimum Version Supported

    Notes

     
     

    Apple iOS (Safari, Chrome)

    10.2, 9.3

    Applications that are built on the IBM TRIRIGA UX Framework, including IBM TRIRIGA Perceptive Applications, support the minimum versions of the operating systems shown.  For desktop support requirements, see the Desktop Client Compatibility section.

     

    IBM TRIRIGA supports the UX Framework components that TRIRIGA delivers and documents on the component documentation page.  Code added around components supplied by TRIRIGA, such as HTML, JavaScript, or third-party code, is the responsibility of the developer.

     

    IBM TRIRIGA will support future versions of a vendor's operating system or browser if the vendor does not remove, or explicitly or inadvertently disable, functionality that IBM TRIRIGA products rely on.  Although future device operating system and browser versions are supported, any issue that is introduced as a result of an upgrade to those areas might require an IBM TRIRIGA fix pack or IBM TRIRIGA Platform upgrade to be fully supported.

     

    For requirements specific to delivered Perceptive Applications built on the UX Framework, including page orientation and resolution, see the documentation for that application.

     

    The IBM TRIRIGA UX Applications are rendered with Polymer version 1.6.1. Elements and components from the Polymer Catalog, such as iron, paper, gold, and platinum, are the most current versions as of October 20, 2016. Applications that are written on the IBM TRIRIGA UX Framework, including Perceptive Applications, might need to be updated to support the version of Polymer delivered with the IBM TRIRIGA Application Platform.

     

    Google Android (Chrome)

    7, 6

     

    Microsoft Windows (Edge, Chrome)

    10

     

    Microsoft Edge

    38

    These versions are the minimum versions that are supported for each browser.  IBM TRIRIGA will support future versions of a vendor's browser if the vendor does not remove, or explicitly or inadvertently disable, functionality that IBM TRIRIGA products rely on. Although future versions are supported, any issue that is introduced as a result of a browser upgrade might require an IBM TRIRIGA Platform fix pack or IBM TRIRIGA Platform upgrade to be fully supported.

     

    IBM TRIRIGA Perceptive Applications require the support of modern web specifications to function optimally. Only evergreen browsers (Chrome, Firefox, Edge, and Safari) are supported when using Perceptive Applications or creating custom views in the IBM TRIRIGA UX Framework. Internet Explorer 11 is not supported.

     
  • Casey Cantwell
    Casey Cantwell
    177 Posts

    Re: iPad Compatibility

    ‏2017-01-20T16:38:41Z  

    Official Support of IBM TRIRIGA on iPads is limited to the IBM TRIRIGA UX Framework and Perceptive Applications.  

    Traditional TRIRIGA, Portal, and non UX Applications are only supported on Windows and Mac OS X operating systems when running Safari, Chrome, Edge, Firefox,or IE 11.  Although a lot of non UX TRIRIGA will load on an iPad, you will run into some limitations as you have noted above.

     

     

    IBM TRIRIGA UX Framework and Perceptive Applications

    Operating Systems / Browsers

    Minimum Version Supported

    Notes

     
     

    Apple iOS (Safari, Chrome)

    10.2, 9.3

    Applications that are built on the IBM TRIRIGA UX Framework, including IBM TRIRIGA Perceptive Applications, support the minimum versions of the operating systems shown.  For desktop support requirements, see the Desktop Client Compatibility section.

     

    IBM TRIRIGA supports the UX Framework components that TRIRIGA delivers and documents on the component documentation page.  Code added around components supplied by TRIRIGA, such as HTML, JavaScript, or third-party code, is the responsibility of the developer.

     

    IBM TRIRIGA will support future versions of a vendor's operating system or browser if the vendor does not remove, or explicitly or inadvertently disable, functionality that IBM TRIRIGA products rely on.  Although future device operating system and browser versions are supported, any issue that is introduced as a result of an upgrade to those areas might require an IBM TRIRIGA fix pack or IBM TRIRIGA Platform upgrade to be fully supported.

     

    For requirements specific to delivered Perceptive Applications built on the UX Framework, including page orientation and resolution, see the documentation for that application.

     

    The IBM TRIRIGA UX Applications are rendered with Polymer version 1.6.1. Elements and components from the Polymer Catalog, such as iron, paper, gold, and platinum, are the most current versions as of October 20, 2016. Applications that are written on the IBM TRIRIGA UX Framework, including Perceptive Applications, might need to be updated to support the version of Polymer delivered with the IBM TRIRIGA Application Platform.

     

    Google Android (Chrome)

    7, 6

     

    Microsoft Windows (Edge, Chrome)

    10

     

    Microsoft Edge

    38

    These versions are the minimum versions that are supported for each browser.  IBM TRIRIGA will support future versions of a vendor's browser if the vendor does not remove, or explicitly or inadvertently disable, functionality that IBM TRIRIGA products rely on. Although future versions are supported, any issue that is introduced as a result of a browser upgrade might require an IBM TRIRIGA Platform fix pack or IBM TRIRIGA Platform upgrade to be fully supported.

     

    IBM TRIRIGA Perceptive Applications require the support of modern web specifications to function optimally. Only evergreen browsers (Chrome, Firefox, Edge, and Safari) are supported when using Perceptive Applications or creating custom views in the IBM TRIRIGA UX Framework. Internet Explorer 11 is not supported.