Topic
  • 3 replies
  • Latest Post - ‏2018-11-16T23:45:55Z by LNovida
mjc61
mjc61
3 Posts

Pinned topic Lease Record Stuck in "Processing" Status When Activating

‏2017-08-24T20:00:08Z | contract estate lease payments processing re real

Some of our lease records are getting stuck in "Processing" status once we try to activate the record. Since it is processing, we have no buttons at the top to revise, save, etc. This only happens sometimes, and only to ones that have payment schedules. From the looks of it, all the payment line items do get created. A couple questions:

1) Is there a fix to this to keep it from happening again?

2) Can these records that are stuck in processing be pushed to active or do they have to be re-entered?

We are running version 10.5.2/3.5.2.2.

Here's what we have tried with no luck: toggling off/on the WFAgent, checking workflows executing (none), check server log for errors (none), restart the service, searching for a broken workflow (none so far), & saving the draft quite frequently to make sure there is no time out while working on large form pages.

Thank you!

  • BillieH
    BillieH
    3 Posts

    Re: Lease Record Stuck in "Processing" Status When Activating

    ‏2017-10-11T20:19:15Z  

    This happens to us on occasion.  I had to develop a editable query to allow the lease to be copied and then deleted or retired.  I find that most of the time when this process is followed the lease will process successfully.

  • mjc61
    mjc61
    3 Posts

    Re: Lease Record Stuck in "Processing" Status When Activating

    ‏2017-10-11T20:29:15Z  
    • BillieH
    • ‏2017-10-11T20:19:15Z

    This happens to us on occasion.  I had to develop a editable query to allow the lease to be copied and then deleted or retired.  I find that most of the time when this process is followed the lease will process successfully.

    Thanks for the response BillieH. I was actually able to apply a workflow fix provided by IBM so that this will not happen going forward. So far it has been working as planned. I have attached the document on this.

    With regards to getting the leases "unstuck", I did essentially what you suggested and created an editable query, imported State Transition Actions (on the advanced tab in the query form), and ran the report to select & process the stuck leases. This worked with no issues and I did not have to delete or retire the leases. They were functioning properly after getting them out of the "Processing" state.

    Attachments

  • LNovida
    LNovida
    1 Post

    Re: Lease Record Stuck in "Processing" Status When Activating

    ‏2018-11-16T23:45:55Z  
    • BillieH
    • ‏2017-10-11T20:19:15Z

    This happens to us on occasion.  I had to develop a editable query to allow the lease to be copied and then deleted or retired.  I find that most of the time when this process is followed the lease will process successfully.

    Maybe Related:  I have a lease that was previously Active.  Revised one of the payment schedules by splitting it into two schedules.  Record is stuck in Processing status (has been for days now).  Followed the instructions in the stuck_leases_solution.doc document and determined the workflow is already setup with the changes described in the doc. 

    So I'm interested in pursuing the editable query option.  Just for my own clarification, you're making a copy of the original lease, then deleting or retiring it and working with the copied lease going forward.  Is that correct, or, are you deleting the copied lease?

    Curious:  With this editable query method, what do you do with the payment schedules and accounting schedules in the leases, if anything?

    Updated on 2018-11-16T23:50:59Z at 2018-11-16T23:50:59Z by LNovida