Topic
  • 2 replies
  • Latest Post - ‏2013-12-07T21:03:32Z by Macalb
Albion
Albion
1 Post

Pinned topic Can't update my ds3200 firmware.

‏2013-11-14T17:41:51Z |

I am trying to update my SAS attached DS3200 (1726) firmware from 06.70.69.00 to 07.35.73.00.  The machine is out of warranty so a call to IBM support is not available to me.  I was hoping someone here might be able to help me.

I start Storage Manager 10.86.0G05.0035.  Both of my storage systems are found with Auto Discovery and show Optimal Status.  I right click on the ds3200 and select "Upgrade Controller Firmware".  A window appears listing both of my storage system with an Error under status for my ds3200.  The error log reads:

[Nov 14, 2013 11:33:24 AM] [GalacticEmpire] [pre-upgrade tests] [pre-upgrade tests start]
Pre-upgrade tests started
 
[Nov 14, 2013 11:33:25 AM] [GalacticEmpire] [pre-upgrade tests] [check controller state]
Test passed - controller A
 
[Nov 14, 2013 11:33:25 AM] [GalacticEmpire] [pre-upgrade tests] [check controller state]
Test passed - controller B
 
[Nov 14, 2013 11:33:26 AM] [GalacticEmpire] [pre-upgrade tests] [check spm database]
An error occurred while checking the spm database on controller A.
 

Thanks

-Craig

  • sdenham
    sdenham
    53 Posts

    Re: Can't update my ds3200 firmware.

    ‏2013-11-17T23:41:38Z  

    With the ds3[2,3,4]00 you used to need to use a different tool for upgrading from 6.X to 7.X than the one embedded in SM.  I don't have access to a system, but let me see if I can remember this.  If I remember correctly,  there is a firmware update on the main menu that is different from the update firmware option you get once you select a specific ds3x00 unit.  The latter is used from updating from one 7.x release to another.

  • Macalb
    Macalb
    2 Posts

    Re: Can't update my ds3200 firmware.

    ‏2013-12-07T21:03:32Z  
    • sdenham
    • ‏2013-11-17T23:41:38Z

    With the ds3[2,3,4]00 you used to need to use a different tool for upgrading from 6.X to 7.X than the one embedded in SM.  I don't have access to a system, but let me see if I can remember this.  If I remember correctly,  there is a firmware update on the main menu that is different from the update firmware option you get once you select a specific ds3x00 unit.  The latter is used from updating from one 7.x release to another.

    I got same error, the option from main menu give the same error:

    " [pre-upgrade tests] [check spm database]

    An error occurred while checking the spm database on controller A."