Topic
  • 3 replies
  • Latest Post - ‏2013-08-08T18:43:10Z by peachy
SwethaRai
SwethaRai
3 Posts

Pinned topic High GC Activity on WMC

‏2013-07-25T13:05:47Z |

Hi,

The resource utilization shows High GC Activity even after the below mentioned settings have been done on the Cast Iron orchestrations 

GC Activity = 100

  1. Total running jobs <=1
  2. % Memory used <=15
  3. % Disk used = 9

Settings:

  1. Cleared the 'Enable Persistence option'.
  2. Checked the 'Process Orchestration jobs sequentially'
  3. Removed all the unused variables in the orchestration
  4. Set Logging to 'None'.
  5. Max Simulataneous jobs = 1

Please suggest what is missed here inorder to reduce high GC Activity?

 

 

Thanks,

Swetha Rai

  • YPS1_guybrush_guybrush
    14 Posts

    Re: High GC Activity on WMC

    ‏2013-08-02T05:18:36Z  

    It could be your design then, or you might be processing a very huge file and loading it to the memory in one shot. Not too sure your case, but you should check your design.

  • Katherine Sanders
    Katherine Sanders
    11 Posts

    Re: High GC Activity on WMC

    ‏2013-08-06T09:59:46Z  

    You should select the enable persistence option so that variables will be written to disk.  Otherwise Cast Iron has to store everything in memory.

    More details are available in the information center: Best Practices For Memory Management

    Also what version of Cast Iron are you using?  There are known memory issues that were fixed in 6.1.0.12 and later.

  • peachy
    peachy
    5 Posts

    Re: High GC Activity on WMC

    ‏2013-08-08T18:43:10Z  

    If you are basing this on the graph, it is a plotting "error" that results from a divide by zero. I have noticed these "spiky" graphs are prevalent on mostly idle systems.