Topic
  • No replies
SandipanC
SandipanC
2 Posts

Pinned topic WS-RM Implementation in IIBv9

‏2013-10-31T15:11:15Z |

Hi,

I am trying to implement WS-RM in IIBv9. This is what I have done

1. Created a flow with SoapInput & SoapReply Node. Its a Simple Flow 

2. Create Bar file & set WSRMDefault PolicySet in MessageFlow

3. Trying to test using SoapUI (Enabling WS-RM option). I have also truned on TCPMonitor to check req/resp msgs.

What I noticed in TCPMonitor is that SequenceCreation is getting refused. Here is snippet from the Fault Msgs

<?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Header xmlns:wsa="http://www.w3.org/2005/08/addressing"><wsrm:SequenceFault xmlns:wsrm="http://docs.oasis-open.org/ws-rx/wsrm/200702"><wsrm:FaultCode>wsrm:CreateSequenceRefused</wsrm:FaultCode><wsrm:Detail>java.lang.NullPointerException&#xD;

My Request Message In SOAPUI look like this

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:s="http://TestService.org/types" xmlns:wsa="http://www.w3.org/2005/08/addressing">
   <soapenv:Header/>
   <soapenv:Body>
      <s:TestIn>
         <s:docName1>s:docName1</s:docName1>
         <s:docName2>s:docName2</s:docName2>
         <s:docName3>s:docName3</s:docName3>
         <s:docName4>s:docName4</s:docName4>
        </s:TestIn>
   </soapenv:Body>
</soapenv:Envelope>

I also tried putting in following elements but no Luck... 

      <wsa:To>http://localhost:7800/mtom/test</wsa:To>
      <wsa:Action>http://schemas.xmlsoap.org/ws/2005/02/rm/CreateSequence</wsa:Action>
      <wsa:MessageID>331ba9f7-06dd-487b-9a5b-bc424769b77b</wsa:MessageID>

I have followed various links in DeveloperWork they seem to suggest same step but somehow its not working for me.

Let me know if you guys have any suggestion ?

Thanks

Sandi