• No replies
1 Post

Pinned topic Ds3400 array and lun disapperared

‏2014-03-12T18:05:12Z |


DS3400+EXP3000, 2 array one on the ds3400 another one on the expansion.

After a black-out the array on the expansion disappeared and the three associated luns became ghost.

We tried to power off all the stuff, powering on the exp3000 and then the ds3400, but the situation remained the same.

After that we tried recover of the last lun on the exp with the following command (reading the parameter from recovery profile):

recover logicalDrive drives=(0,1 0,2 0,3 0,5 0,6 0,7 0,9 0,10) userLabel="lunname" capacity=536870912000 offset=186047744 raidLevel=5 segmentSize=128 owner=a readAheadMultiplier=1;

After the command the ghost that lun becomes visible again and even the array (previously completely disappered), but only by the storage manager gui. The lun is not mountable by the host.

The problems now are:

- launching the same command for the other luns, we receive an error that says that disks are already in use

- the lun recovered is not mountable.

- the lun recovered and the array have another identifier

I wanna try to delete the lun recovered e repeat the command starting recovering from the first lun to the last, using the logicaldriveWWN parameter instead userLabel.

Someone can point me how to begin again, deleteing the lun which is not working, and recovering all the three luns on the exp3000?

Basically the question is, if i delete the lun the data remains in place on the disks? So i can recover the lun with the recover command?


Please Help