Topic
  • 2 replies
  • Latest Post - ‏2013-04-30T20:55:35Z by sagar.kar
sagar.kar
sagar.kar
2 Posts

Pinned topic Message broker 8.0 with Oracle XE ODBC

‏2013-04-24T23:51:14Z |

I am very new to Message broker. I just started to play around with it.

I was trying to setup odbc connection with oracle xe and test record and replay functionality of message broker 8.0.

Oracle Database 11g Express Edition Release 11.2.0.2.0

I was reading the article from http://www.ibm.com/developerworks/websphere/tutorials/1212_storey/

This article talks about DB2 but I have oracle xe on my laptop hence was trying out with oracle.

My laptop is running on Windows 7 professional edition 64 bit version.

Websphere Message broker 8 is also 64 bit version.

When I run the following command.

 

mqsisetdbparms MB8BROKER -n odbc::MBRECORD -u xyzabc -p xyzabc

it says "BIP8071I: Successful command completion."

However mqsicvp doesn't run successfully.

 

C:\IBM\MQSI\8.0.0.1>mqsicvp MB8BROKER -n MBRECORD
BIP8272E: Datasource 'MBRECORD' has not been associated with broker 'MB8BROKER'.
 
This invocation of the mqsicvp command requires that the datasource name has bee
n associated with the broker, using the mqsisetdbparms command.
Check that this datasource has been associated with the broker.

However if I prefix the datasource name with odbc:: then it gives me another error. When I tested the odbc data source in the windows Data Source dialog by clicking on the Test connection it works fine.

 

C:\IBM\MQSI\8.0.0.1>mqsicvp MB8BROKER -n odbc::MBRECORD
 
BIP2393E: Database error: ODBC return code '-1' from data source ''odbc::MBRECOR
D'' using ODBC driver manager ''odbc32.dll''.
The broker received an error when processing a database operation. The ODBC retu
rn code was '-1'. See the following messages for information obtained from the d
atabase about this error.
Use the following messages to determine the cause of the error. Typical problems
 are an incorrect data source, or table names. Correct either the database or th
e broker configuration.
BIP2322E: Database error: SQL State ''IM002''; Native Error Code '0'; Error Text
 ''[Microsoft][ODBC Driver Manager] Data source name not found and no default dr
iver specified''.
The error has the following diagnostic information:     SQL State             ''
IM002''     SQL Native Error Code '0'     SQL Error Text        ''[Microsoft][OD
BC Driver Manager] Data source name not found and no default driver specified''
 

If I try the mqsicvp command by providing a -u and -p option then it doesn't recognize the u flag and says 

 

BIP8001E: Unknown flag 'u' selected.
When using this command interface the user should only select the supported flag
s.
Correct and reissue the command.

Any help is appreciated. If message broker doesn't support oracle xe 11 then I can try to install DB2, but is there a way to know which version of DB2 is supported? Has anyone tried with a particular version and got it to work.

  • KY0J_Simbu_Selvarasu
    40 Posts

    Re: Message broker 8.0 with Oracle XE ODBC

    ‏2013-04-26T04:11:20Z  
    mqsisetdbparms MB8BROKER -n MBRECORD -u xyzabc -p xyzabc
    

    mqsicvp MB8BROKER -n MBRECORD

     

    Please try this.

  • sagar.kar
    sagar.kar
    2 Posts

    Re: Message broker 8.0 with Oracle XE ODBC

    ‏2013-04-30T20:55:35Z  
    <pre class="displaycode" dir="ltr" style="width: 694px; margin-top: 0px; margin-bottom: 0px; font-family: 'Andale Mono', 'Lucida Console', Monaco, Liberation, fixed, monospace; font-size: 11px; overflow: auto; color: rgb(0, 0, 0); background-color: rgb(247, 247, 247);">mqsisetdbparms MB8BROKER -n MBRECORD -u xyzabc -p xyzabc </pre>

    mqsicvp MB8BROKER -n MBRECORD

     

    Please try this.

    Thank you very much Simbu, you suggestion worked. I have seen in some articles that use odbc:: or jdbc:: prefix. Do you know when we prefix and when we shouldn't?