Topic
  • 4 replies
  • Latest Post - ‏2014-01-03T10:07:37Z by IanR2974
RadekChan
RadekChan
8 Posts

Pinned topic SSL not working

‏2013-12-18T07:25:04Z |

I am trying to configure my web report to use SSL.

When I set _WebReports_HTTPServer_UseSSLFlag = 1, and restart it.

The BESReport is up, but It is no longer to listen to port 52312.

I checked the log, and found this error.

HTTPServer error: No such file or directory; system lib; system lib (class OpenSSLError)

When I change back to 0. It is able to use https://server-name:52312. And it ask for cert exception as I am using self-signed cert. So I assume it is working.

But when I click on "Administration" -> "User Management" -> "Active Directory Permissions". It still showing the message below.

Because SSL is not enabled, Active Directory user credentials will be sent to Web Reports in the clear. Learn how to enable SSL.

I am not sure what happen and is SSL working or not....

  • IanR2974
    IanR2974
    5 Posts

    Re: SSL not working

    ‏2014-01-03T08:42:29Z  

    Hi,

    When you enable SSL check the value of HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\BigFix\EnterpriseClient\Settings\Client\_WebReports_HTTPServer_PortNumber on your server as this will indicate which port needs to be used in the web address. I may be wrong but i have a sneaky suspision this automatically changed to 443 when i did it on our infrastructure.

    If you havent already have a look at this site which helps you through the process of enabling SSL for Web Reports:
    http://www-01.ibm.com/support/docview.wss?uid=swg21505848

    I hope this helps,

    Ian

  • IanR2974
    IanR2974
    5 Posts

    Re: SSL not working

    ‏2014-01-03T08:44:34Z  
    • IanR2974
    • ‏2014-01-03T08:42:29Z

    Hi,

    When you enable SSL check the value of HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\BigFix\EnterpriseClient\Settings\Client\_WebReports_HTTPServer_PortNumber on your server as this will indicate which port needs to be used in the web address. I may be wrong but i have a sneaky suspision this automatically changed to 443 when i did it on our infrastructure.

    If you havent already have a look at this site which helps you through the process of enabling SSL for Web Reports:
    http://www-01.ibm.com/support/docview.wss?uid=swg21505848

    I hope this helps,

    Ian

    I shoould mention just in case that the registry path is for a 64 bit machine if you are using a 32 bit one it will be HKLM\Software\BigFix\EnterpriseClient\Settings\Client\_WebReports_HTTPServer_PortNumber

  • RadekChan
    RadekChan
    8 Posts

    Re: SSL not working

    ‏2014-01-03T09:04:25Z  
    • IanR2974
    • ‏2014-01-03T08:44:34Z

    I shoould mention just in case that the registry path is for a 64 bit machine if you are using a 32 bit one it will be HKLM\Software\BigFix\EnterpriseClient\Settings\Client\_WebReports_HTTPServer_PortNumber

    Yes, I configured the port number. But not working. I tried to use port 443, but still bad.

  • IanR2974
    IanR2974
    5 Posts

    Re: SSL not working

    ‏2014-01-03T10:07:37Z  
    • RadekChan
    • ‏2014-01-03T09:04:25Z

    Yes, I configured the port number. But not working. I tried to use port 443, but still bad.

    Just to confirm when you changed the port in the regisrty to 443 using the above key. Did you use the address https://server-name or https://server-name:443