Topic
  • 2 replies
  • Latest Post - ‏2014-01-09T23:21:02Z by Betty2
Betty2
Betty2
6 Posts

Pinned topic "Save JCL Parameters" DSN name corrupted

‏2013-10-25T22:03:52Z |

In the "Save JCL Parameters" panel, the "DSN to Save JCL to" field has become corrupt and greyed-out, so I can't correct it.

This panel had been working until recently, when I happened to have CANCELed a process when I was in this window. (Basically changed my mind about cutting a job - wanted to go back and fix something first.) Since then, when the panel opens, the field contains garbage (i.e. unprintable chars), and is greyed-out so I can't replace the garbage with the correct dataset name. (It should be a PDS, if that matters)

Have looked through the 0 Options menus looking for somewhere to override this, and scanned the manuals, but can't find anything for this.

Error has continued for last few days, despite exiting/re-entering Optim, logging off my session, etc.

Suggestions? thanks!

Updated on 2013-10-25T22:04:48Z at 2013-10-25T22:04:48Z by Betty2
  • Edward.D.
    Edward.D.
    4 Posts

    Re: "Save JCL Parameters" DSN name corrupted

    ‏2014-01-07T08:14:44Z  

    Have you tried to use EXPAND or EXP command and point the cursor on that field?

  • Betty2
    Betty2
    6 Posts

    Re: "Save JCL Parameters" DSN name corrupted

    ‏2014-01-09T23:21:02Z  
    • Edward.D.
    • ‏2014-01-07T08:14:44Z

    Have you tried to use EXPAND or EXP command and point the cursor on that field?

    Thanks Edward,

    I'll make a note of this suggestion to try if it happens again.

    I opened a PMR for this; the solution I got from Support was to rename (i.e. delete it, effectively) one of the control files, PDS member [userid].ISPPROF(FOPPROF). That had the effect of wiping out all my personal Optim settings. It fixed the problem, but was a bit of a sledge-hammer approach that we'd rather not use if there's something better.