Topic
  • 9 replies
  • Latest Post - ‏2013-05-16T22:54:04Z by Pathogen67
robmorning
robmorning
5 Posts

Pinned topic HATS / Geronimo

‏2013-04-29T08:09:18Z | / geronimo hats

I've installed HATS and Eclipse plugin and can start / end / log into them from web view in RAD(8.04)  without a problem ..  I tried to create a new HATS project targeted at Geronimo BUT that environment doesn't appear in my drop down box of available target servers  .. I've seen the notes relating to v8.5 of Hats and i'm assuming the targeting of Geronimo in the create project is the same .. Anyone any suggestions  ?  ..  Thanks  ..

  • tmparker
    tmparker
    534 Posts

    Re: HATS / Geronimo

    ‏2013-04-29T19:39:41Z  

    Creating Geronimo projects is very simple.  If you follow the directions we explain in the HATS InfoCenter in the section entitled "Developing HATS applications for the Apache Geronimo server" here, http://pic.dhe.ibm.com/infocenter/hatshelp/v85/topic/com.ibm.hats.doc/doc/ugcreorg.htm, you will be able to create your project.

    Thanks

    Tim

  • robmorning
    robmorning
    5 Posts

    Re: HATS / Geronimo

    ‏2013-05-07T18:34:52Z  
    • tmparker
    • ‏2013-04-29T19:39:41Z

    Creating Geronimo projects is very simple.  If you follow the directions we explain in the HATS InfoCenter in the section entitled "Developing HATS applications for the Apache Geronimo server" here, http://pic.dhe.ibm.com/infocenter/hatshelp/v85/topic/com.ibm.hats.doc/doc/ugcreorg.htm, you will be able to create your project.

    Thanks

    Tim

    I've bee thru this numerous times and don't seem to be able to get this to work as indicated in the reference ..  I've installed Geronimo and GEP and they seem to be working fine .. I create a new HATS project - in the target server I ONLY have Websphere options - no Geronimo ones .. I'm using Geronimo 2.1 so I then tried creating an app targeted at WebSphere 7 as it supports web 2.5 as opposed to WebSphere 8 supporting web 3.0 .. I create a simple app with a couple of macros  .. I select project / properties and targeted runtimes .. I select Geronimo and also tick 'uninstall facets' removing both WebSphere facets (WebSphere and WebSphere co-existance) from the list  .. I click apply then okay .. I right click the project and select 'run on server ..' at which point i get a message telling me 'project facet WebSphere Application (Co-Existance) version 7.0 is not supported' though i'd actually removed this earlier ..  I'm using RAD 8.0.4 ..

  • tmparker
    tmparker
    534 Posts

    Re: HATS / Geronimo

    ‏2013-05-07T18:41:29Z  

    I've bee thru this numerous times and don't seem to be able to get this to work as indicated in the reference ..  I've installed Geronimo and GEP and they seem to be working fine .. I create a new HATS project - in the target server I ONLY have Websphere options - no Geronimo ones .. I'm using Geronimo 2.1 so I then tried creating an app targeted at WebSphere 7 as it supports web 2.5 as opposed to WebSphere 8 supporting web 3.0 .. I create a simple app with a couple of macros  .. I select project / properties and targeted runtimes .. I select Geronimo and also tick 'uninstall facets' removing both WebSphere facets (WebSphere and WebSphere co-existance) from the list  .. I click apply then okay .. I right click the project and select 'run on server ..' at which point i get a message telling me 'project facet WebSphere Application (Co-Existance) version 7.0 is not supported' though i'd actually removed this earlier ..  I'm using RAD 8.0.4 ..

    What version of HATS do you have installed?  Geronimo support was introduced in HATS 8.0.0.2, but I would make sure you are on the latest and greatest which is HATS 8.0.0.3.

    If you have the GEP plugin and an instance of the server created, as we explained in the InfoCenter, then you should be fine and the server should show up in the target server list.

  • robmorning
    robmorning
    5 Posts

    Re: HATS / Geronimo

    ‏2013-05-08T08:07:10Z  
    • tmparker
    • ‏2013-05-07T18:41:29Z

    What version of HATS do you have installed?  Geronimo support was introduced in HATS 8.0.0.2, but I would make sure you are on the latest and greatest which is HATS 8.0.0.3.

    If you have the GEP plugin and an instance of the server created, as we explained in the InfoCenter, then you should be fine and the server should show up in the target server list.

    The version i have is 8.0.0.201106191333 .. from the installed software menu ..  So i'm assuming thats okay ..  I've attached screen snaps of server running in RAD and also HATS create project screen showing ONLY WebSphere targets available   ..

  • tmparker
    tmparker
    534 Posts

    Re: HATS / Geronimo

    ‏2013-05-08T16:54:55Z  

    The version i have is 8.0.0.201106191333 .. from the installed software menu ..  So i'm assuming thats okay ..  I've attached screen snaps of server running in RAD and also HATS create project screen showing ONLY WebSphere targets available   ..

    No, the version you have there is the 8.0.0 GM version.  The numbers after the version are just the build date, 6/19/2011.  The 8.0.0.3 version would show this:

    IBM® Rational® HATS
    Version 8.0.0.3 (8.0.300.201208031206)

    You can check this in Installation Manager.  Also, you can do the update right from Installation Manager as well.  Just choose the update option and select the package that has HATS and it should show you the latest version right there.

    Thanks

    Tim

  • robmorning
    robmorning
    5 Posts

    Re: HATS / Geronimo

    ‏2013-05-09T09:16:22Z  
    • tmparker
    • ‏2013-05-08T16:54:55Z

    No, the version you have there is the 8.0.0 GM version.  The numbers after the version are just the build date, 6/19/2011.  The 8.0.0.3 version would show this:

    IBM® Rational® HATS
    Version 8.0.0.3 (8.0.300.201208031206)

    You can check this in Installation Manager.  Also, you can do the update right from Installation Manager as well.  Just choose the update option and select the package that has HATS and it should show you the latest version right there.

    Thanks

    Tim

    Thanks .. I'll get the later version  .. 

  • Pathogen67
    Pathogen67
    27 Posts

    Re: HATS / Geronimo

    ‏2013-05-16T14:46:10Z  

    The version i have is 8.0.0.201106191333 .. from the installed software menu ..  So i'm assuming thats okay ..  I've attached screen snaps of server running in RAD and also HATS create project screen showing ONLY WebSphere targets available   ..

    I'll tell you what worked for me. I skipped GEP and went to the server tab, create a new server. I then selected download a new server adaptor and Geronimo was one of them. I was never able to get GEP working without issues. Ultimately it borked my RAD install and I had to reinstall it, but your mileage may vary...

    Attachments

  • robmorning
    robmorning
    5 Posts

    Re: HATS / Geronimo

    ‏2013-05-16T15:25:02Z  

    I'll tell you what worked for me. I skipped GEP and went to the server tab, create a new server. I then selected download a new server adaptor and Geronimo was one of them. I was never able to get GEP working without issues. Ultimately it borked my RAD install and I had to reinstall it, but your mileage may vary...

    No .. I updated to 8.0.0.3 and everything works fine .. Including GEP ..

  • Pathogen67
    Pathogen67
    27 Posts

    Re: HATS / Geronimo

    ‏2013-05-16T22:54:04Z  

    No .. I updated to 8.0.0.3 and everything works fine .. Including GEP ..

    Great!