Topic
  • 1 reply
  • Latest Post - ‏2016-12-12T14:49:31Z by fjb_saper
Andy901
Andy901
2 Posts

Pinned topic How Java 1.4 will connect with MQ 7.5 ?

‏2016-11-23T06:18:58Z | 1.4 7.5 ? connect how java mq will with

Hi 

As per MQ 7.5 client, minimum requirement is jdk 1.5 client to connect with MQ. But my application is written in jdk 1.4 and client don't want to migrate application from 1.4 to 1.5. they are upgrading MQ client from 7.0.0 to 7.5. Please suggest if we have any alternate solution for this.

 

Thanks

 

  • fjb_saper
    fjb_saper
    240 Posts

    Re: How Java 1.4 will connect with MQ 7.5 ?

    ‏2016-12-12T14:49:31Z  

    Like the MQ server, the MQ Client has a minimum level of Java version for the jar files.

    So if you upgrade the client you will have to migrate to Java 1.5 as the minimum java level required...

    If your connection is a "bindings" connection you have to run the client at the same level as the server.