Topic
1 reply Latest Post - ‏2013-05-22T10:19:25Z by Dave_Ward
45BU_Mike_Prentice
45BU_Mike_Prentice
1 Post
ACCEPTED ANSWER

Pinned topic Help with removing a Widget

‏2013-05-20T19:59:33Z |

In the case manager client, is there any way to manually remove an iWidget that has an error. Basically I have a test widget that was deployed and there is a 404 error, which seems to prevent all the other widgets from loading. Now, when I view the page all the iWidgets are gone and when I click the Edit Page link, I can't click the offending iWidget to remove it. Is there a workaround for this? I've attached a screenshot of what I see. I am using IE9 and I have already tried clearing my browser cache and restarting IE several times.

I also tried the widget removal instructions located here: http://www-01.ibm.com/support/docview.wss?uid=swg21412525. I have restarted WebSphere and my entire VM. My next step is to blow away the entire space, but that seems a bit drastic and I'd like to avoid it.

Thank you.

 

  • Dave_Ward
    Dave_Ward
    33 Posts
    ACCEPTED ANSWER

    Re: Help with removing a Widget

    ‏2013-05-22T10:19:25Z  in response to 45BU_Mike_Prentice

    Hi,

    Here are a couple of suggestions...

    1. Have you tried loading the offending page via both the "Go To Spaces" and "Manage Spaces" menu options in Business Space? Sometimes pages load from Manage Spaces even if errors occur loading within a Case / Task context.

    2. How did you install the widget? I normally use something like:
    wsadmin.bat -conntype NONE
    $AdminTask installBusinessSpaceWidgets {-nodeName ecmdemo1Node01 -serverName server1 -widgets c:/InstallDir/MyWidget.zip}
    $AdminConfig save
    exit
    {Restart WAS}

    2.1. If you used the above method, have you tried replacing the "installBusinessSpaceWidgets" command with either:
    --> "updateBusinessSpaceWidgets" (if you now have a working version of the widget)
    --> "uninstallBusinessSpaceWidgets"(to remove the widget)
    Take a look here for help with the syntax http://pic.dhe.ibm.com/infocenter/dmndhelp/v7r0mx/index.jsp?topic=%2Fcom.ibm.websphere.wbpm.bspace.config.doc%2Fdoc%2Frref_installbusinessspacewidgets.html

    3. Have you tried loading the page when logged in as a different user? I've had occasions where Business Space has corrupted the config for a page at the user level.

    4. If the page in question is a copy of one of the default pages, have you tried deleting just that page from the Space?

    Good luck!