Topic
3 replies Latest Post - ‏2013-08-20T07:40:22Z by matt362
matt362
matt362
2 Posts
ACCEPTED ANSWER

Pinned topic Software Analyser ruleset for WebSphere Version Migration Not Visible

‏2013-08-19T11:32:59Z |

Dear All,

I am using Spring Tool Suite 3.3.0

I have installed Application Migration Tool - WebSphere Version to Version    3.5.2.v20130608_1226 from the Eclipse Market Place.

When creating a new Software Analyzer Configuration I cannot see the 'WebSphere Application Server version migration' rule set in the drop down list.

Any ideas please would be appreciated.

  • c.high
    c.high
    18 Posts
    ACCEPTED ANSWER

    Re: Software Analyser ruleset for WebSphere Version Migration Not Visible

    ‏2013-08-19T16:40:17Z  in response to matt362

    Hi,

    Spring Tool Suite is not a platform support since we don't test on it. It looks like the 3.3.0 version is based on Eclipse 4.3.  We have tested up to Eclipse 4.2.  I am wondering if it is missing the prerequisites that are normally installed with Eclipse for Java EE developers.  Is Business Intelligence, Reporting and Charting (BIRT) installed?  What about the Web, XML, and Java EE Development tools?  These are available from the Eclipse release download site.

    Did you see any errors during installation?  Can you paste the names of the features that show up in the installed features list?  What are the high level rule categories that are available in the configuration dialog?

    Cindy

    • c.high
      c.high
      18 Posts
      ACCEPTED ANSWER

      Re: Software Analyser ruleset for WebSphere Version Migration Not Visible

      ‏2013-08-19T20:04:53Z  in response to c.high

      If installing the prerequisites does not help or if they are already installed, the Eclipse error log might contain errors that indicate a missing dependency.  Can you check or attach the log?

      • matt362
        matt362
        2 Posts
        ACCEPTED ANSWER

        Re: Software Analyser ruleset for WebSphere Version Migration Not Visible

        ‏2013-08-20T07:40:22Z  in response to c.high

        Hi Cindy,

        Thanks for the help.

        Due to lack of official support for Spring Tools Suite and a number of unusual behaviours with it I decided to move to the supported Eclipse Juno 4.2, which looks to be working fine so far.

        Matt