Topic
  • 3 replies
  • Latest Post - ‏2015-07-03T06:32:18Z by K9EH_Thiyagarajan_Shankar
keviny
keviny
1 Post

Pinned topic Analysis Connector Settings in IA 9.1

‏2013-11-25T19:43:17Z |

Hi,

i am getting an error message on all data when i do a column analysis in IA 9.1. I checked the ANALYSIS CONNECTOR SETTINGS under Analysis database and tried to validate it but i get the error message "invalid settings: Error executing DS job:"

i have validated the Datastage connection in analysis engine and it connected without any problems.

1. wondering if my column analysis errors generated is connected to the invalid connection i am getting in analysis connector settings.

2. how do i fix this all column analysis coming back with errors (if it is not related).

thanks,

Kevin

  • smithha
    smithha
    162 Posts

    Re: Analysis Connector Settings in IA 9.1

    ‏2013-11-26T13:23:49Z  

    Hi Kevin,

    Since you are seeing errors both when trying to validate the Analysis Database setting and when trying to run a column analysis, that suggests there is an issue connecting to the IADB database.

    Steps to check:

    1. ensure that an ODBC DSN exists on the engine (DataStage) server that points to the IADB
    2. ensure that the credentials (userid/password) are valid for the IADB - if it worked before and now doesn't, it's possible the password expired
    3. ensure that the right db type (e.g. DB2, Oracle) is selected and that the server name and port used are correct
    4. once those are confirmed, retry the validation in the Analysis Database settings

    If you continue to experience issues after that, I'd recommend contacting Technical Support.

    Harald

     

  • ArthurLynch
    ArthurLynch
    1 Post

    Re: Analysis Connector Settings in IA 9.1

    ‏2013-11-28T16:04:24Z  

    Kevin,

     

    I had the same issue and after much trial and error, established that it was an NLS issue on the ANALYZERPROJECT. I established this by using the consolve to open a custom log (Operate-- View logs) and filter on IBM-IA-HANDLE.

    The fix ifor me was to ensure ANALYZERPROJECT uses UTF-8 for Server and Parallel Maps and 'DEFAULT' for Server Locales instead of US-English. One webpage I found indicated this might have been caused by the corruption of the installation files i.e. unpacking Linux installation files in Windows. The installation happened before my time, so I can say if that is true. The NLS changes resolved the problem for me.

     

    Arthur.

    Updated on 2013-11-28T16:04:48Z at 2013-11-28T16:04:48Z by ArthurLynch
  • K9EH_Thiyagarajan_Shankar
    3 Posts

    Re: Analysis Connector Settings in IA 9.1

    ‏2015-07-03T06:32:18Z  

    Kevin / Arthur,

     

    Am facing the same issue. I have made changes to the NLS as mentioned above, NLS -> UTF8 & Server Locales to DEFAULT.

     

    Any idea why this is causing this problem ?