Topic
  • 8 replies
  • Latest Post - ‏2013-10-08T23:03:12Z by tallurisri
Senthil_Kannan
Senthil_Kannan
4 Posts

Pinned topic XB62 - Connection Hangup issue on back interface

‏2013-07-05T16:38:33Z |

Hi,

Did anyone come across a situation where DataPower is generating 1000's of mail alerts saying

Event:   Network Error (Connection hangup) on Back interface (URL: https://XXXXXXXXXX) when processing the error rule.

This event is occuring for couple of seconds and then appliance returning normal. But the transaction which got initiated at this moment is getting failed. Also the data traffic from DataPower is not even moving to our Network Firewall.

Our stack for your reference, XB 62 - Firmware Version 5.0.0.3

Thanks for your support.

Cheers - Senthil

 

 

 

 

 

 

  • minim
    minim
    27 Posts

    Re: XB62 - Connection Hangup issue on back interface

    ‏2013-08-22T13:02:16Z  

    HI,

    Please provide if you see any solution for this.

     

    Regards.

  • Senthil_Kannan
    Senthil_Kannan
    4 Posts

    Re: XB62 - Connection Hangup issue on back interface

    ‏2013-08-22T13:35:53Z  
    • minim
    • ‏2013-08-22T13:02:16Z

    HI,

    Please provide if you see any solution for this.

     

    Regards.

    Hi,

    We have been told by IBM support to raise the version to 5.0.0.8, we did but still no positive results.

    Only change we have done is to suppress the identical events which is now filtering all the 1000+ alerts and notifying with a single mail. We are happy with this at the moment but still the issue persist.

    Waiting for IBM to provide an answer.

    Cheers - Senthil

  • kkts
    kkts
    5 Posts

    Re: XB62 - Connection Hangup issue on back interface

    ‏2013-10-04T14:16:45Z  

    Hi,

    We have been told by IBM support to raise the version to 5.0.0.8, we did but still no positive results.

    Only change we have done is to suppress the identical events which is now filtering all the 1000+ alerts and notifying with a single mail. We are happy with this at the moment but still the issue persist.

    Waiting for IBM to provide an answer.

    Cheers - Senthil

    Hi,

    Is there any news or any progress in this issue?

    Thanks

  • Senthil_Kannan
    Senthil_Kannan
    4 Posts

    Re: XB62 - Connection Hangup issue on back interface

    ‏2013-10-04T16:17:35Z  
    • kkts
    • ‏2013-10-04T14:16:45Z

    Hi,

    Is there any news or any progress in this issue?

    Thanks

    Hi,

    With our thorough analysis and findings we concluded that the external servers are sending a RST flag in the ssl connection which makes an abnormal closure in the established connection.

    Due to this issue on the third party server connection, DataPower alerting with Connection Hangup error codes.

    If the issue on the Third Party server connection is solved, this issue will be resolved.

    Cheers - Senthil

  • tallurisri
    tallurisri
    105 Posts

    Re: XB62 - Connection Hangup issue on back interface

    ‏2013-10-04T17:10:36Z  

    We have opened a PMR for similar kind of hangups issue, during AAA authentication-authorization check against LDAP active directory requests become unresponsive, logs showing request process entering into hung state with out making any attempt for authorization after successful authentication against same LDAP directory. clients getting time out errors, no errors reporting in to DP logs.

    Even though all clients sends requests to same service on same DP box, 1 out of 6 clients encountering this issue. 

    Please share your thoughts.

  • kkts
    kkts
    5 Posts

    Re: XB62 - Connection Hangup issue on back interface

    ‏2013-10-07T06:59:06Z  

    Hi,

    With our thorough analysis and findings we concluded that the external servers are sending a RST flag in the ssl connection which makes an abnormal closure in the established connection.

    Due to this issue on the third party server connection, DataPower alerting with Connection Hangup error codes.

    If the issue on the Third Party server connection is solved, this issue will be resolved.

    Cheers - Senthil

    Hi Senthil,

    Thanks for your answer, looks reasonable.

    Cheers

     

     

  • Senthil_Kannan
    Senthil_Kannan
    4 Posts

    Re: XB62 - Connection Hangup issue on back interface

    ‏2013-10-07T08:39:38Z  

    We have opened a PMR for similar kind of hangups issue, during AAA authentication-authorization check against LDAP active directory requests become unresponsive, logs showing request process entering into hung state with out making any attempt for authorization after successful authentication against same LDAP directory. clients getting time out errors, no errors reporting in to DP logs.

    Even though all clients sends requests to same service on same DP box, 1 out of 6 clients encountering this issue. 

    Please share your thoughts.

    Hi,

    Not sure but needs to be checked, whether the LDAP services are not releasing the control back to DP. Try to verify whether you are encountering the same scenario after restart of LDAP, if happenning sooner after restart, try to increase the bandwidth of your LDAP since I don't think DP will have any issue on your problem scenario.

    Cheers - Senthil.

  • tallurisri
    tallurisri
    105 Posts

    Re: XB62 - Connection Hangup issue on back interface

    ‏2013-10-08T23:03:12Z  

    Hi,

    Not sure but needs to be checked, whether the LDAP services are not releasing the control back to DP. Try to verify whether you are encountering the same scenario after restart of LDAP, if happenning sooner after restart, try to increase the bandwidth of your LDAP since I don't think DP will have any issue on your problem scenario.

    Cheers - Senthil.

    Hi Senthil,

     

    Thanks for your response.

    Our Issue was resolved after we cleared cache(AAA and Style sheet), we informed this to IBM and waiting for their comments.

    We had this issue for two services in different domains, both get fixed with clear cache in both domains.

    Thanks,

    Sri.