Topic
  • 8 replies
  • Latest Post - ‏2013-10-15T17:39:08Z by BarryJ.Silliman
Thambirajan
Thambirajan
11 Posts

Pinned topic Unable to install openstack on Firstbox - IBM SCO

‏2013-10-08T13:19:53Z |

Hi,

I'm installing IBM Smartcloud Orchestrator 2.2.

I have successfully installed firstbox.

Now, I'm installing openstack. However I am getting the following error.

-------------------------------------------------------------------------------------------------------------------------------------------

Error: Package: 1:libguestfs-tools-1.16.19-1.el6.x86_64 (LocalMedia)
           Requires: libguestfs = 1:1.16.19-1.el6
           Installed: 1:libguestfs-1.16.34-2.el6.x86_64 (@rhel-x86_64-server-6)
               libguestfs = 1:1.16.34-2.el6
Error: Package: 1:libguestfs-tools-c-1.16.19-1.el6.x86_64 (LocalMedia)
           Requires: libguestfs = 1:1.16.19-1.el6
           Installed: 1:libguestfs-1.16.34-2.el6.x86_64 (@rhel-x86_64-server-6)
               libguestfs = 1:1.16.34-2.el6

ERROR: libguestfs-tools-c-1.16.19-1.el6.x86_64 is not installed and it is necessary to make Proxy work
ERROR: python-libguestfs-1.16.19-1.el6.x86_64 is not installed and it is necessary to make Proxy work

Tue Oct  8 15:16:44 IST 2013: ERROR: Failed check of libguestfs libraries.
Tue Oct  8 15:16:44 IST 2013: COPINS100I The script exit code is 118.
 

-------------------------------------------------------------------------------------------------------------------------------------------------

Since it's looking for libguestfs = 1:1.16.19-1.el6, I manually tried to install this package, but i'm getting krb5-libs dependecy error.

So, I don't know what to do.

For the reference, i've attached the log file.

Could anyone help me to sort out this problem ?

Thanks,

Thambirajan. A

Attachments

  • BarryJ.Silliman
    BarryJ.Silliman
    4 Posts
    ACCEPTED ANSWER

    Re: Unable to install openstack on Firstbox - IBM SCO

    ‏2013-10-10T14:35:41Z  

    Hi Barry,

    I tried by installing RHEL 6.3 Basic Server Edition.

    But, i'm getting the same error.

    When I analyse this problem, I got to know that It tries to install libguestfs-1.16.19-1.el6 package.

    But, It ends up by installing libguestfs-1.16.34-2.el6 since libguestfs-1.16.19 has dependency of  krb5-libs-1.9-9.el6.x86_64 which is not installed in RHEL.

    The actual krb5-lib version which got installed was krb5-libs-1.10.3-10.el6_4.6.x86_64. So that it throws an error over here.

    Even I tried to downgrade this version using yum, but  it says only upgrade is enabled for this package.

    We followed the same steps which is given in the document. We don't know what went wrong.

    Kindly help us to resolve this dependency problem.

     

    Thanks,

    Thambirajan. A

     

     

    Hi Thambirajan,

    I am not on the SCO development team- I am an end-user of the product like yourself, so I may not have the definitive answers, I'm just trying to help....

    I have a line that says yum -y update in my  <install_media>/IBM_SmartCloud_Installer_and_OpenStack-2.2.0.0-201305010142/deploy-scripts/allinone directory, and it is not commented out.

    Did you disable your existing yum repositories in /etc/yum/repos.d prior to performing the installation as suggested in the documentation?  I have a hunch you didn't, otherwise how could the yum update have upgraded you from RHEL 6.3 to 6.4?   Perhaps this is what is tripping you up.

    I am not at all expert with yum, so if these suggestions don't help you, hopefully someone else can help.

    This is what my firstbox looks like post-install...

    # yum list libguestfs
    Loaded plugins: product-id, security, subscription-manager
    Updating certificate-based repositories.
    Unable to read consumer identity
    Installed Packages
    libguestfs.x86_64                  1:1.16.19-1.el6                   @LocalMedia

    # yum list krb5-libs
    Loaded plugins: product-id, security, subscription-manager
    Updating certificate-based repositories.
    Unable to read consumer identity
    Installed Packages
    krb5-libs.x86_64 1.9-33.el6 @anaconda-RedHatEnterpriseLinux-201206132210.x86_64/6.3
    Available Packages
    krb5-libs.i686   1.9-33.el6 LocalMedia            

    # yum repolist
    Loaded plugins: product-id, security, subscription-manager
    Updating certificate-based repositories.
    Unable to read consumer identity
    repo id                              repo name                            status
    LocalMedia                           LocalMedia                           3,585
    scp                                  SCP                                    167
    repolist: 3,752

     

     

  • AndrewYu
    AndrewYu
    12 Posts

    Re: Unable to install openstack on Firstbox - IBM SCO

    ‏2013-10-09T02:13:31Z  

    Hi Thambirajan,

    Is your firstbox using RHEL 6.4? SCO 2.2 supports 6.3 only for the firstbox.

  • Thambirajan
    Thambirajan
    11 Posts

    Re: Unable to install openstack on Firstbox - IBM SCO

    ‏2013-10-09T04:38:05Z  
    • AndrewYu
    • ‏2013-10-09T02:13:31Z

    Hi Thambirajan,

    Is your firstbox using RHEL 6.4? SCO 2.2 supports 6.3 only for the firstbox.

    Hi Andrew,

    Thanks for your kind reply.

    I'm using RHEL 6.3 (Santiago) only.

    I confirmed this by executing following command.

    less /etc/redhat-release.

    Previously while installing openstack by running install.sh file, RHEL Version got updated from 6.3 into 6.4 and finally it showed an error as "RHEL 6.4 OS is not supported". So that I deleted "yum update" line in install.sh file, hence the OS version is not getting updated. But I'm facing the above libguestfs problem.

     

    Thanks,

    Thambirajan. A

     

     

     

     

     

     

     

  • BarryJ.Silliman
    BarryJ.Silliman
    4 Posts

    Re: Unable to install openstack on Firstbox - IBM SCO

    ‏2013-10-09T15:38:22Z  

    Hi Andrew,

    Thanks for your kind reply.

    I'm using RHEL 6.3 (Santiago) only.

    I confirmed this by executing following command.

    less /etc/redhat-release.

    Previously while installing openstack by running install.sh file, RHEL Version got updated from 6.3 into 6.4 and finally it showed an error as "RHEL 6.4 OS is not supported". So that I deleted "yum update" line in install.sh file, hence the OS version is not getting updated. But I'm facing the above libguestfs problem.

     

    Thanks,

    Thambirajan. A

     

     

     

     

     

     

     

    Hi Thrambirajan,

    This may not apply to your situation, but I had some package dependency issues as well (don't recall the exact package names) when I tried to install SCO 2.2. on a RHEL 6.3 that I had installed with the 'Full' install option during the RHEL 6.3. graphical install.  Starting over and  using the 'Basic Server' install option for RHEL 6.3 eliminated that problem for me.

    Regards,

    Barry

  • Thambirajan
    Thambirajan
    11 Posts

    Re: Unable to install openstack on Firstbox - IBM SCO

    ‏2013-10-10T05:08:13Z  

    Hi Thrambirajan,

    This may not apply to your situation, but I had some package dependency issues as well (don't recall the exact package names) when I tried to install SCO 2.2. on a RHEL 6.3 that I had installed with the 'Full' install option during the RHEL 6.3. graphical install.  Starting over and  using the 'Basic Server' install option for RHEL 6.3 eliminated that problem for me.

    Regards,

    Barry

    Hi Barry,

    Thanks for your kind reply.

    We will try with basic server version (Till now we have been trying with RHEL 6.3 Desktop Version).

    And we have one more doubt.

    While installing openstack component on firstbox, do we have to comment out "yum update" line in install.sh file ?

    Since it's updating RHEL OS version also.

     

    Thanks,

    Thambirajan. A

     

     

  • Thambirajan
    Thambirajan
    11 Posts

    Re: Unable to install openstack on Firstbox - IBM SCO

    ‏2013-10-10T13:30:43Z  

    Hi Thrambirajan,

    This may not apply to your situation, but I had some package dependency issues as well (don't recall the exact package names) when I tried to install SCO 2.2. on a RHEL 6.3 that I had installed with the 'Full' install option during the RHEL 6.3. graphical install.  Starting over and  using the 'Basic Server' install option for RHEL 6.3 eliminated that problem for me.

    Regards,

    Barry

    Hi Barry,

    I tried by installing RHEL 6.3 Basic Server Edition.

    But, i'm getting the same error.

    When I analyse this problem, I got to know that It tries to install libguestfs-1.16.19-1.el6 package.

    But, It ends up by installing libguestfs-1.16.34-2.el6 since libguestfs-1.16.19 has dependency of  krb5-libs-1.9-9.el6.x86_64 which is not installed in RHEL.

    The actual krb5-lib version which got installed was krb5-libs-1.10.3-10.el6_4.6.x86_64. So that it throws an error over here.

    Even I tried to downgrade this version using yum, but  it says only upgrade is enabled for this package.

    We followed the same steps which is given in the document. We don't know what went wrong.

    Kindly help us to resolve this dependency problem.

     

    Thanks,

    Thambirajan. A

     

     

  • BarryJ.Silliman
    BarryJ.Silliman
    4 Posts

    Re: Unable to install openstack on Firstbox - IBM SCO

    ‏2013-10-10T14:35:41Z  

    Hi Barry,

    I tried by installing RHEL 6.3 Basic Server Edition.

    But, i'm getting the same error.

    When I analyse this problem, I got to know that It tries to install libguestfs-1.16.19-1.el6 package.

    But, It ends up by installing libguestfs-1.16.34-2.el6 since libguestfs-1.16.19 has dependency of  krb5-libs-1.9-9.el6.x86_64 which is not installed in RHEL.

    The actual krb5-lib version which got installed was krb5-libs-1.10.3-10.el6_4.6.x86_64. So that it throws an error over here.

    Even I tried to downgrade this version using yum, but  it says only upgrade is enabled for this package.

    We followed the same steps which is given in the document. We don't know what went wrong.

    Kindly help us to resolve this dependency problem.

     

    Thanks,

    Thambirajan. A

     

     

    Hi Thambirajan,

    I am not on the SCO development team- I am an end-user of the product like yourself, so I may not have the definitive answers, I'm just trying to help....

    I have a line that says yum -y update in my  <install_media>/IBM_SmartCloud_Installer_and_OpenStack-2.2.0.0-201305010142/deploy-scripts/allinone directory, and it is not commented out.

    Did you disable your existing yum repositories in /etc/yum/repos.d prior to performing the installation as suggested in the documentation?  I have a hunch you didn't, otherwise how could the yum update have upgraded you from RHEL 6.3 to 6.4?   Perhaps this is what is tripping you up.

    I am not at all expert with yum, so if these suggestions don't help you, hopefully someone else can help.

    This is what my firstbox looks like post-install...

    # yum list libguestfs
    Loaded plugins: product-id, security, subscription-manager
    Updating certificate-based repositories.
    Unable to read consumer identity
    Installed Packages
    libguestfs.x86_64                  1:1.16.19-1.el6                   @LocalMedia

    # yum list krb5-libs
    Loaded plugins: product-id, security, subscription-manager
    Updating certificate-based repositories.
    Unable to read consumer identity
    Installed Packages
    krb5-libs.x86_64 1.9-33.el6 @anaconda-RedHatEnterpriseLinux-201206132210.x86_64/6.3
    Available Packages
    krb5-libs.i686   1.9-33.el6 LocalMedia            

    # yum repolist
    Loaded plugins: product-id, security, subscription-manager
    Updating certificate-based repositories.
    Unable to read consumer identity
    repo id                              repo name                            status
    LocalMedia                           LocalMedia                           3,585
    scp                                  SCP                                    167
    repolist: 3,752

     

     

  • Thambirajan
    Thambirajan
    11 Posts

    Re: Unable to install openstack on Firstbox - IBM SCO

    ‏2013-10-11T13:46:42Z  

    Hi Thambirajan,

    I am not on the SCO development team- I am an end-user of the product like yourself, so I may not have the definitive answers, I'm just trying to help....

    I have a line that says yum -y update in my  <install_media>/IBM_SmartCloud_Installer_and_OpenStack-2.2.0.0-201305010142/deploy-scripts/allinone directory, and it is not commented out.

    Did you disable your existing yum repositories in /etc/yum/repos.d prior to performing the installation as suggested in the documentation?  I have a hunch you didn't, otherwise how could the yum update have upgraded you from RHEL 6.3 to 6.4?   Perhaps this is what is tripping you up.

    I am not at all expert with yum, so if these suggestions don't help you, hopefully someone else can help.

    This is what my firstbox looks like post-install...

    # yum list libguestfs
    Loaded plugins: product-id, security, subscription-manager
    Updating certificate-based repositories.
    Unable to read consumer identity
    Installed Packages
    libguestfs.x86_64                  1:1.16.19-1.el6                   @LocalMedia

    # yum list krb5-libs
    Loaded plugins: product-id, security, subscription-manager
    Updating certificate-based repositories.
    Unable to read consumer identity
    Installed Packages
    krb5-libs.x86_64 1.9-33.el6 @anaconda-RedHatEnterpriseLinux-201206132210.x86_64/6.3
    Available Packages
    krb5-libs.i686   1.9-33.el6 LocalMedia            

    # yum repolist
    Loaded plugins: product-id, security, subscription-manager
    Updating certificate-based repositories.
    Unable to read consumer identity
    repo id                              repo name                            status
    LocalMedia                           LocalMedia                           3,585
    scp                                  SCP                                    167
    repolist: 3,752

     

     

    Hi Barry,

    Many thanks for your timely help and suggestion

    As you said RHEL repo was the problem.

    Though I disabled RHEL repo, It was downloading and updating all the latest packages.

    The reason was I had registered my RHEL OS before starting IBM SCO Installation.

    So that, without registering OS I tried the installation and all the components got installed successfully.

    I really appreciate your help.

     

    Thanks,

    Thambirajan. A

     

     

     

     

  • BarryJ.Silliman
    BarryJ.Silliman
    4 Posts

    Re: Unable to install openstack on Firstbox - IBM SCO

    ‏2013-10-15T17:39:08Z  

    Hi Barry,

    Many thanks for your timely help and suggestion

    As you said RHEL repo was the problem.

    Though I disabled RHEL repo, It was downloading and updating all the latest packages.

    The reason was I had registered my RHEL OS before starting IBM SCO Installation.

    So that, without registering OS I tried the installation and all the components got installed successfully.

    I really appreciate your help.

     

    Thanks,

    Thambirajan. A

     

     

     

     

    Hi Thambirajan,

    that's great news!  Glad I could help, and thanks for reporting back that you got it resolved.

    Regards,
    Barry