Topic
  • 6 replies
  • Latest Post - ‏2013-11-28T07:29:29Z by paul.brett
Sidhumohan
Sidhumohan
34 Posts

Pinned topic Importent - Issue with special characters while fetching from DB

‏2013-05-21T13:30:56Z |

Hi All,

Using DBLOOKUP i am fetching a CLOB data from database. This CLOB data contains some special characters which, after fetching from DB gettign converted to some other characters. The field where i am fetching is set as data language UTF-8 but when i am trying with certain special characters its coming along with some other invalid characters.

For eg:- If i am the clob data containing special charater  © this is gettng converted to Ã'©.

similarly these charaters ýöÅôÉ€óò&  are gettign converted to Ã½Ã¶Ã…ôÉâ'¬Ã³Ã²

Any help appreciated..

regards,

Sidhu

Updated on 2013-05-21T13:41:00Z at 2013-05-21T13:41:00Z by Sidhumohan
  • Bhoju
    Bhoju
    37 Posts

    Re: Importent - Issue with special characters while fetching from DB

    ‏2013-09-10T13:49:51Z  

    apply leaveprint() function

  • Sidhumohan
    Sidhumohan
    34 Posts

    Re: Importent - Issue with special characters while fetching from DB

    ‏2013-10-23T13:08:59Z  
    • Bhoju
    • ‏2013-09-10T13:49:51Z

    apply leaveprint() function

    The LEAVEPRINT function removes all non-printable characters from a text item.

    But i want excat these characters and dont want to remove those.

  • pcp
    pcp
    14 Posts

    Re: Importent - Issue with special characters while fetching from DB

    ‏2013-10-23T18:15:59Z  

    The LEAVEPRINT function removes all non-printable characters from a text item.

    But i want excat these characters and dont want to remove those.

    Try changing the data language to UTF-16 or LATIN-1 in the field where you are fetching the CLOB data.

    Thanks, Phil

  • Sidhumohan
    Sidhumohan
    34 Posts

    Re: Importent - Issue with special characters while fetching from DB

    ‏2013-10-23T19:23:30Z  
    • pcp
    • ‏2013-10-23T18:15:59Z

    Try changing the data language to UTF-16 or LATIN-1 in the field where you are fetching the CLOB data.

    Thanks, Phil

    UTF-16 not workign..have to try with latin-1...I have this same issue while inserting these characters to the database too....the encoding used in the type tree is UTF-8...Still not working...Any one please suggest..

  • DJ2610
    DJ2610
    2 Posts

    Re: Importent - Issue with special characters while fetching from DB

    ‏2013-11-21T23:02:02Z  

    UTF-16 not workign..have to try with latin-1...I have this same issue while inserting these characters to the database too....the encoding used in the type tree is UTF-8...Still not working...Any one please suggest..

    You can use iso-8859-1 it supports all the special characters

     

    Thanks,

    Dilip

  • paul.brett
    paul.brett
    753 Posts

    Re: Importent - Issue with special characters while fetching from DB

    ‏2013-11-28T07:29:29Z  

    Turn on the input card backup.  This will give you a 'raw' version of the input data from the adapter before any changes are applied by the input Typetree.  If this data is correct, then it is your Typetree at fault.

     

    If the input backup data is wrong, then you need to look at adjusting your NLS_LANG variable to match that used by the DB server.