Topic
  • 2 replies
  • Latest Post - ‏2013-05-27T03:39:41Z by arzetry
dingHendry
dingHendry
2 Posts

Pinned topic Failed to install in eclipse JUNO

‏2013-05-24T06:47:13Z |

Failed with the following exception:

Cannot complete the install because of a conflicting dependency.
  Software being installed: ICAP Mobile 1.0.0.techpreview...
  Software currently installed: Eclipse for RCP and RAP Developers 1.4.1.20110909-1818 (epp.package.rcp 1.4.1.20110909-1818)
  Only one of the following can be installed at once:
    Eclipse Preferences Mechanism 3.5.0.v20120522-1841 (org.eclipse.equinox.preferences 3.5.0.v20120522-1841)
    Eclipse Preferences Mechanism 3.4.1.R37x_v20110725 (org.eclipse.equinox.preferences 3.4.1.R37x_v20110725)
    Eclipse Preferences Mechanism 3.5.1.v20121031-182809 (org.eclipse.equinox.preferences 3.5.1.v20121031-182809)
  Cannot satisfy dependency:
 

  • 觉后参禅
    觉后参禅
    5 Posts

    Re: Failed to install in eclipse JUNO

    ‏2013-05-24T07:41:15Z  

     

    In the document, it says that:

    Note: The only Eclipse version that ICAP supports is Eclipse 3.7.2 for Java EE.
     

    I guess you are running with Eclipse for RCP and RAP Developers. The error is that only one version of a component "Eclipse Preferences Mechanism" can be installed but there are three versions be selected. 

    Try to install the component first, if you still prefer using Eclipse for RCP and RAP Developers.

  • arzetry
    arzetry
    11 Posts

    Re: Failed to install in eclipse JUNO

    ‏2013-05-27T03:39:41Z  

    Hi Yang,

    At this point, advise you to switch your eclipse to indigo SR2 for Java EE edition, this is the only version we official support of Tech Preview.  Thank you.