Topic
6 replies Latest Post - ‏2013-05-22T14:24:37Z by J-kub
J-kub
J-kub
6 Posts
ACCEPTED ANSWER

Pinned topic DB2 10.1 ZigZag join problem - ASSERT ZZJN DIM TEMP TAOB HAS A DUMMY RESID

‏2013-05-21T17:42:08Z |

Hi everyone,

In Windows 64bit DB2 10.1.0 / 10.1.2 I am experiencing the following error while doing some simple joins with a where clause:

Query:

SELECT *
FROM
TABLE_1 JOIN TABLE_2 ON TABLE_1.TABLE_2_ID = TABLE_2.ID JOIN TABLE_3 ON TABLE_1.TABLE_3_ID = TABLE_3.ID
WHERE (TABLE_2.NAME = 'name2' OR TABLE_2.NAME = 'name4') AND (TABLE_3.TABLE_3_ID = 'name6')


Error:

ASSERT ZZJN DIM TEMP TAOB HAS A DUMMY RESID

It looks like something is going astray in the ZigZag join.  For now the ZigZag support got turned off:

db2set DB2_REDUCED_OPTIMIZATION=ZZJN OFF

but this doesn't feel like the right solution.

 

There is an article that addresses the issue, alas I cannot view it without paid support:

http://www-01.ibm.com/support/docview.wss?crawler=1&uid=swg1IC86835

Does anyone know of a solution or what the article suggests?  Is this a know issue that will be addressed?

Updated on 2013-05-21T19:37:39Z at 2013-05-21T19:37:39Z by J-kub
  • nivanov1
    nivanov1
    53 Posts
    ACCEPTED ANSWER

    Re: DB2 10.1 ZigZag join problem - ASSERT ZZJN DIM TEMP TAOB HAS A DUMMY RESID

    ‏2013-05-21T19:04:58Z  in response to J-kub

    You don't need "paid support" to create an IBM ID, it's  free. Once you have the ID, you can log in to see the page.

    • J-kub
      J-kub
      6 Posts
      ACCEPTED ANSWER

      Re: DB2 10.1 ZigZag join problem - ASSERT ZZJN DIM TEMP TAOB HAS A DUMMY RESID

      ‏2013-05-21T19:26:49Z  in response to nivanov1

      I have an IBM ID, that's why I am able to post here.

      After entering the ID, I am prompted for my customer ID or IBM enployee user name.  None of which I have.

      • KayKanekowski
        KayKanekowski
        3 Posts
        ACCEPTED ANSWER

        Re: DB2 10.1 ZigZag join problem - ASSERT ZZJN DIM TEMP TAOB HAS A DUMMY RESID

        ‏2013-05-22T06:19:10Z  in response to J-kub

        Hi J-kub,

        i followed your link and was prompted for my IBM ID and passwort. And it worked with the same IBM ID/password that i used to post here.

        regards
        Kay

        • J-kub
          J-kub
          6 Posts
          ACCEPTED ANSWER

          Re: DB2 10.1 ZigZag join problem - ASSERT ZZJN DIM TEMP TAOB HAS A DUMMY RESID

          ‏2013-05-22T13:56:39Z  in response to KayKanekowski

          Interesting, perhaps somehting is wrong with my quite old IBM ID, all I get is:

          "The IBM business units and support programs listed below can grant access to the document or resource you have requested*. If you have credentials for any of the programs listed below, please enter them now. Otherwise, use the entitlement help links in each section below to join the support program that meets your needs."

          Am I missing something?

          Since everyone else appears to have access to the resource, can someone please post the solution?

          • KayKanekowski
            KayKanekowski
            3 Posts
            ACCEPTED ANSWER

            Re: DB2 10.1 ZigZag join problem - ASSERT ZZJN DIM TEMP TAOB HAS A DUMMY RESID

            ‏2013-05-22T14:09:01Z  in response to J-kub

            Hi Jakub,

            do you see these link ?

            link to actual document
            http://www.ibm.com/support/docview.wss?uid=swg1IC86835

            This leads you the open APAR. It is opened at 2012-09-26 and this is also the last modified date ;-(

            Perhaps this mentioned workaround helps you:

            Local fix

            Disable the use of automatic statistics profiling by setting the
            AUTO_STATS_PROF db config parameter to OFF.
            

             

            regards
            Kay

             

            • J-kub
              J-kub
              6 Posts
              ACCEPTED ANSWER

              Re: DB2 10.1 ZigZag join problem - ASSERT ZZJN DIM TEMP TAOB HAS A DUMMY RESID

              ‏2013-05-22T14:24:37Z  in response to KayKanekowski

              Thanks Kay.

               

              I did see the link.  When I click it, I get prompted for my IBM ID, which I enter.  Then I get the message from my previous reply stating that someone needs to grant access to the document for me.  I have contacted IBM Technical support regarding the issue.

               

              I will try the fix you provided.  Thanks again.