Topic
  • 1 reply
  • Latest Post - ‏2014-10-17T18:46:52Z by llanopa
brembo
brembo
5 Posts

Pinned topic IBM Storewise V3700 Multipath error in RHL 6.4

‏2013-12-08T21:49:22Z |

I have an IBM Storewize v3700 External  Storage connected to a PureFlex chassis with 4 nodes x240 all running Red Hat Linux 6.4 Enterprise Edition. two of the nodes are going to be configured for High Availability. i have created some volumes which i mapped to my servers , when i open the disk utilities in Linux i see four copies of the same volume which i think is ok since i have two LUNs on each server coming from my storage. My problem is that i am getting the this error '' Warning : Several paths to this drive has been detected but no corresponding multipath was found.your OS may be misconfigured.'' with this error i cannot do anything to these volumes neither format them or create a partitions , when trying to do this i am getting  a device busy error.

i have edited the /etc/multipath.conf file accordingly as prescribed in this document from IBM http://pic.dhe.ibm.com/infocenter/storwize/v3700_ic/index.jsp?topic=%2Fcom.ibm.storwize.v3700.641.doc%2Fsvc_dmmpsetuplinux431_3yd13v.html   but nothing has changed.

does anyone have an idea on this?

 

 

 

 

  • llanopa
    llanopa
    1 Post

    Re: IBM Storewise V3700 Multipath error in RHL 6.4

    ‏2014-10-17T18:46:52Z  

    Did you find a solution to this?  I was able to create the multipath device but I still get the same error in disk utility.  I'm using a V3700 connected to to SAS HBAs on an x3550M4.  Here's what I did to configure it:

    # Setup multipath service for dual controller array
    mpathconf --enable --with_multipathd y
    chkconfig multipathd on
    service multipathd restart

    # Then I got /dev/mapper/mpathbp1 showing up when I run 'blkid'


    # I'm then able to install package for XFS support
    yum install xfsprogs -y
    # Then make xfs filesystem
    #mkfs.xfs -L DATA1 /dev/mapperpathb

    # copy current fstab file to fstab backup
    #cp /etc/fstab /etc/fstab.orig
    # Find UUID of new /dev/mapper/mpathbp1
    #mapper=$(blkid -s UUID -o value /dev/mapper/mpathbp1)
    # Create mount path
    mkdir -p /usr/local/data

    # Edit fstab
    #sed -i "\$a# Mount of DATA1" /etc/fstab
    #sed -i "\$aUUID=$mapper /usr/local/data XFS defaults 0 0"
    #mount -a

    # Added data directory to /etc/exports for sharing and set permissions
    echo "/usr/local/data *(rw)" > /etc/exports
    # Apply changes
    exportfs -a