Topic
  • No replies
TLSM
TLSM
8 Posts

Pinned topic Failed to gather with error message: NotASignedMessage

‏2013-09-16T04:30:20Z |

Hi All,

 

Need help on this issue.

I had setup a IEM server in end user site and found when during gathering occur error:

Id: 2 Date: Mon, 16 Sep 2013 03:58:13 +0000
Error Message: 2: class NotASignedMessage

From the GatherDB log

Mon, 16 Sep 2013 08:09:33 +0800 -- Unexpected exception during gather of site BES Support: Unexpected HTTP response: 404 
Mon, 16 Sep 2013 09:09:44 +0800 -- Unexpected exception during gather of site BES Support: Unexpected HTTP response: 404 
Mon, 16 Sep 2013 10:09:55 +0800 -- Unexpected exception during gather of site BES Support: Unexpected HTTP response: 404 
Mon, 16 Sep 2013 11:10:06 +0800 -- Unexpected exception during gather of site BES Support: Unexpected HTTP response: 404 

From BESRelay log:

Mon, 16 Sep 2013 04:08:50 +0800 - 2592 - 2: class NotASignedMessage
Mon, 16 Sep 2013 05:09:01 +0800 - 868 - 2: class NotASignedMessage
Mon, 16 Sep 2013 06:09:12 +0800 - 3152 - 2: class NotASignedMessage
Mon, 16 Sep 2013 07:09:23 +0800 - 1876 - 2: class NotASignedMessage
Mon, 16 Sep 2013 08:09:34 +0800 - 3696 - 2: class NotASignedMessage
Mon, 16 Sep 2013 09:09:44 +0800 - 768 - 2: class NotASignedMessage
Mon, 16 Sep 2013 10:09:55 +0800 - 3824 - 2: class NotASignedMessage
Mon, 16 Sep 2013 11:10:06 +0800 - 1416 - 2: class NotASignedMessage
 

This environment is using Squid proxy and web authentication.

The username and password is not tide with AD authentication but when do browsing need to insert the username and password.

I had follow the proxy setting for :

Configuring Proxy Settings for an IEM version 9 Server

1. Launch C:\Program Files (x86)\BigFix Enterprise\BES Server>BESAdmin /setproxy /user:AAAA /pass:AAAA and then manually modify the following registry key:

  • HKLM\SOFTWARE\BigFix\ Enterprise Server\Proxy 
    "Proxy"="" 
    "ProxyUser"="AAAA" 
    "ProxyPass"="ecrypted(AAAA)"

to our enterprise proxy values, where proxy is " http://OUR_PROXY_IP:OUR_ PROXY_PORT/

2. Set the following client settings on the IEM server machine via the IEM Console. Right click on the server machine in the list of computers and select "Edit Computer Settings..." . 

  • _BESGather_Comm_UseUrlMoniker = 1 
    _BESGather_Comm_ UseDownloadService = 0 
    _Enterprise Server_ClientRegister_ ProxyServer = OUR_PROXY_IP 
    _Enterprise Server_ClientRegister_ ProxyPort = OUR_PROXY_PORT

I am do read the article for the Error Message: NotASignedMessage

https://www.ibm.com/developerworks/community/forums/html/topic?id=77777777-0000-0000-0000-000014855477

https://www.ibm.com/developerworks/community/forums/html/topic?id=77777777-0000-0000-0000-000014972541

http://www-01.ibm.com/support/docview.wss?uid=swg21506081

Most of the article is talking about the licensing issue.

To double confirm the licensing issue, I had built-up another VM server and using the same license.crt.

And from this VM server everything working well.

Can anyone help me in this issue?

Initially I am suspect the Squid proxy but I had follow the exactly proxy setting for Version 9.X.

Or anyones here running IEM system behind Squid proxy as well?

Mind to do some sharing for this?

Need it badly. Appreciate~ 

Thanks