Topic
  • 3 replies
  • Latest Post - ‏2013-11-08T06:09:56Z by 9RYQ_Kiran_mk
amccarl
amccarl
73 Posts

Pinned topic Error SQL5005C on Windows Vista, Windows 7 and Windows 2008

‏2013-06-12T14:35:14Z |

Running any DB2 command in Windows Vista, Windows 7 and Windows 2008 causes the following error: 

C:\Program Files\IBM\SQLLIB\BIN>db2 list db directory 
SQL5005C System Error.

The cause of this error is because you may not have picked "Run as Administrator" when installing DB2. If you right click on any icon you will have an option to "Run as Administrator".  You can either do this every time you want to open a DB2 Command Window or you can uninstall and reinstall DB2. Before installing DB2 right click on db2setup.exe and select "Run as Administrator",

 

This is also covered by the technical article 1430172, http://www.ibm.com/support/docview.wss?uid=swg21430172

Updated on 2013-06-14T14:43:42Z at 2013-06-14T14:43:42Z by amccarl
  • amccarl
    amccarl
    73 Posts

    Re: Error SQL5005C on Windows Vista, Windows 7 and Windows 2008

    ‏2013-06-14T14:30:15Z  
    Hello!  We've had a number of clients respond through feedback to our technical documents indicating that they have further questions or comments that require additional dialogue.  Unfortunately, our feedback is anonymous, so unless an email address or other contact information is included, we have no way to get back in touch with you.
     
    Within DB2 support, the management team asked if we could somehow link our documents to the forums so that we could invite more discussion - like this!   As a start, we chose a small set of  technical articles and "seeded" the forum with initial entries so that we could have a starting place for conversation.  The documents have now been updated with links to the forums as well.  
     
    Hopefully, we will make DB2 support better by providing more interaction around our technical information!
  • Rob_Strong
    Rob_Strong
    1 Post

    Re: Error SQL5005C on Windows Vista, Windows 7 and Windows 2008

    ‏2013-11-06T20:35:52Z  

    At least with EXP-C 10.5 64-bit on Win 7, playing with the "Run as Administrator" before executing db2setup.exe DOES NOT fix this problem.

    What fixed the problem for me was to add my personal ID and the db2admin id into the Windows "group" DB2ADMNS.  All the various DB2 command windows including the start/stop DB2 icon in the taskbar function correctly, no longer throwing the SQL5005C authorization message.

    To do this, on the windows START menu, select Administrative Tools/ Computer Management, then select (in the left portion of the window) Local Users and Groups/Groups and then select from the list of groups DB2ADMNS. Add the IDs you use to administer your DB2 instance.

  • 9RYQ_Kiran_mk
    9RYQ_Kiran_mk
    78 Posts

    Re: Error SQL5005C on Windows Vista, Windows 7 and Windows 2008

    ‏2013-11-08T06:09:56Z  

    At least with EXP-C 10.5 64-bit on Win 7, playing with the "Run as Administrator" before executing db2setup.exe DOES NOT fix this problem.

    What fixed the problem for me was to add my personal ID and the db2admin id into the Windows "group" DB2ADMNS.  All the various DB2 command windows including the start/stop DB2 icon in the taskbar function correctly, no longer throwing the SQL5005C authorization message.

    To do this, on the windows START menu, select Administrative Tools/ Computer Management, then select (in the left portion of the window) Local Users and Groups/Groups and then select from the list of groups DB2ADMNS. Add the IDs you use to administer your DB2 instance.

    Even I come across this error SQL5005C.  Whenever I login system after every reboot.  It  will through me an error as above.

    I will try with the above options and will let you know.   Do we need to change the owner of DB2 Service in Services.msc as well ?

    There was no such restrictions as such in earlier versions but I dnt knw why such this new things is implemented ? Because even after installing with OS level Admin user we will get this kind of error.  Any specific reason for that.

    Best Regards,

    Kiran.M.K.