Topic
  • 4 replies
  • Latest Post - ‏2014-01-28T14:00:01Z by ErasmusTapera
PangSMS
PangSMS
23 Posts

Pinned topic how to turn on display terminal

‏2013-08-07T14:50:45Z |

I deployed HATS project to WAS 8.5 on iSeries.

i would like to open display terminal for each host connection like i did on debuging mode.

i keep facing message Unable to toggle the display terminal for the connection(s).

also, i already enable display terminal on Trace setting but it still didn't work. 

 

 

 

 

Updated on 2013-08-07T14:52:22Z at 2013-08-07T14:52:22Z by PangSMS
  • tmparker
    tmparker
    532 Posts

    Re: how to turn on display terminal

    ‏2013-08-07T16:22:21Z  

    There could be a few reasons you are having the problem you described.  Where are you trying to view the display terminal?  It will be displayed on the server machine itself, not the client workstation.  Since you are trying to do this on an iSeries there are notes documented in the InfoCenter regarding this.  Take a look at the section entitled "Display terminal functions" on this page, http://pic.dhe.ibm.com/infocenter/hatshelp/v85/topic/com.ibm.hats.doc/doc/ugadmin.htm?path=4_17_4#advtop

    Thanks

    Tim

  • ErasmusTapera
    ErasmusTapera
    11 Posts

    Re: how to turn on display terminal

    ‏2014-01-23T22:41:03Z  

    Tim,

    I have HATS 9 going against iSeries.  App runs fine, I went to the HATS admin, turned on console and enabled the WAS service to interact with desktop.  I rebooted.  Now, when I launch the session, Windows gives me a warning.  When I allow the other session, it goes into some sort of protect mode an only allows me to see the terminal or go back.

    I am still running Windows 7.  What can I do to see both at the same time?

     

    Thanks.

  • tmparker
    tmparker
    532 Posts

    Re: how to turn on display terminal

    ‏2014-01-27T01:12:28Z  

    Tim,

    I have HATS 9 going against iSeries.  App runs fine, I went to the HATS admin, turned on console and enabled the WAS service to interact with desktop.  I rebooted.  Now, when I launch the session, Windows gives me a warning.  When I allow the other session, it goes into some sort of protect mode an only allows me to see the terminal or go back.

    I am still running Windows 7.  What can I do to see both at the same time?

     

    Thanks.

    Hi Erasmus,

    I remember seeing behavior like that a few years back when I first went to Windows 7. All I can tell you is that I don't ever run my WAS servers as system services. I think that is what I had found to get around the problem you are having. Go into the Windows Services and set the WAS server to manual start. then start the server from the studio and see if that works for you.

    Thanks
    Tim

  • ErasmusTapera
    ErasmusTapera
    11 Posts

    Re: how to turn on display terminal

    ‏2014-01-28T14:00:01Z  
    • tmparker
    • ‏2014-01-27T01:12:28Z

    Hi Erasmus,

    I remember seeing behavior like that a few years back when I first went to Windows 7. All I can tell you is that I don't ever run my WAS servers as system services. I think that is what I had found to get around the problem you are having. Go into the Windows Services and set the WAS server to manual start. then start the server from the studio and see if that works for you.

    Thanks
    Tim

    Tim,

    That did the trick.  I stopped the WAS service, changed it to Manual, restarted, and then launched it from within RAD.  Works great.

    Thanks again!