Topic
  • 5 replies
  • Latest Post - ‏2018-12-05T17:11:15Z by Vikas Shrivastav
Ramesh-WCS8
Ramesh-WCS8
20 Posts

Pinned topic Command Context Issue

‏2017-06-28T16:33:46Z | command commandcontext context issue

Hello.

My store enabled for French and English. in home page I used databeans using wcs:usebean. So my problem is when change langId (-2 for French) from url, everything displaying in French but when I gone through databean which is include. in that databean commandcontext having previous langId (-1 for English). and I refresh the page double time it works.

So Please help me to solve this issue with in detail will help me to better understanding.

Thanks in advance.

Updated on 2017-06-30T16:48:16Z at 2017-06-30T16:48:16Z by Ramesh-WCS8
  • Raj.S
    Raj.S
    561 Posts

    Re: Command Context Issue

    ‏2017-07-02T20:22:16Z  

    Might be some cache or stale context causing the issue. Enable the below trace to nail down the issue.

    com.ibm.websphere.commerce.WC_SERVER=all

     

    Rgds, Raj.S

  • Ramesh-WCS8
    Ramesh-WCS8
    20 Posts

    Re: Command Context Issue

    ‏2017-07-03T08:45:45Z  
    • Raj.S
    • ‏2017-07-02T20:22:16Z

    Might be some cache or stale context causing the issue. Enable the below trace to nail down the issue.

    com.ibm.websphere.commerce.WC_SERVER=all

     

    Rgds, Raj.S

    Hello.

    Thanks for reply.

    I'll go through your suggestion. if any doubt I will contact you.

  • Furahm
    Furahm
    1 Post

    Re: Command Context Issue

    ‏2018-10-26T16:41:42Z  

    Hi Ramesh,

    Were you able to resolve your issue ? Please can you mention how did you resolve it 

    Thanks

  • rickysingh
    rickysingh
    1 Post

    Re: Command Context Issue

    ‏2018-11-03T15:56:08Z  

    Command.Mine and Context.invoke / In the future, I think it's deliberate, but it's hard to find a simple way to persuade yourself.

     

  • Vikas Shrivastav
    Vikas Shrivastav
    4 Posts

    Re: Command Context Issue

    ‏2018-12-05T17:11:15Z  

    This seems to be an issue with BaseContext.Just check the CTXDATA table for com.ibm.commerce.context.base.BaseContext .