Topic
  • 2 replies
  • Latest Post - ‏2014-09-07T13:25:03Z by tangqian
tangqian
tangqian
2 Posts

Pinned topic Install Biginsight 3.0 occur error

‏2014-08-26T05:09:41Z |

Hi expert,

I encountered a problem when I run bi-requirement as following description.It reported that I need a volid hostname,but I had configured /etc/hosts as following files.I didn't how to fixed the issue.Would you help me fixed it ,many many thanks for your help.

 

[root@tangqian6 bin]# ./bi-prechecker.sh -u root

================================================
BigInsights Pre-Installation Check Script v1.2.2
================================================
Machine: tangqian6.localdomain
Architecture: xSeries
OS: Red Hat v6.5
================================================

[INFO] (CDYIN0011I) No cluster hostname list passed in; using localhost.
[INFO] (CDYIN0014I) Verifying for single-node cluster.
[INFO] (CDYIN0017I) Running in QUICK_START mode.

=========== PASSWORDLESS SSH/SUDO ==========
Verify passwordless SSH works for account root  [  OK  ]
Verify no extraneous output from ssh  [  OK  ]
Verify requiretty unset and NOPASSWD set in /etc/sudoers  [  OK  ]
Verify there is no install process in the background  [  OK  ]
Verify install ports not in use  [  OK  ]

=========== LOCAL ENVIRONMENT CHECKS ==========
Verify network exists  [  OK  ]
Verify local hostname resolves  [  OK  ]
Verify that Expect is installed  [  OK  ]

=========== CLUSTER ENVIRONMENT CHECKS ==========
Verify SSH using port 22  [  OK  ]
Verify OSs/Archs consistent and supported  [  OK  ]
Verify enough /tmp free space  [  OK  ]
-----------------------------------
Verify service user root
  Shell = bash  [  OK  ]
  Correct ulimits in /etc/security/limits.conf  [  OK  ]
  Consistent uid/gid  [  OK  ]
  Home dir owner = root:root  [  OK  ]
  Java shared classes writable  [  OK  ]
  nonzero .bashrc  [  OK  ]
  nonzero .bash_profile  [  OK  ]
Verify system uid for the Big SQL administrator  [  OK  ]

-----------------------------------
Verify that zip unzip tar ssh scp bash are installed  [  OK  ]
Verify that Ksh is installed  [  OK  ]
Verify that lsof is installed  [  OK  ]
Verify /etc/profile.d variables are set  [  OK  ]
Verify same time zone on all nodes.  [  OK  ]
Verify clock drift <= 30 sec.  [  OK  ]
Verify connectivity to time server  [FAILED]
Verify all cluster entries are valid IPs  [  OK  ]
Verify all host names are RFC-1123 valid  [  OK  ]
Verify all host names are RFC-1035 valid  [FAILED]
Verify localhost is defined in etc/hosts  [  OK  ]
Verify cluster hostname list is all FQDN or short name  [  OK  ]
Verify cluster hostname list is all FQDN for SSO  [  OK  ]
Verify loopback is defined in ifconfig  [  OK  ]
Verify firewall stopped  [  OK  ]
Verify SeLinux not in enforcing mode  [  OK  ]
Verify /etc/fstab uses UUID for data disk  [  OK  ]
Verify IPv6 disabled  [  OK  ]
Verify boottime kernel.pid_max and port range  [  OK  ]
Verify runtime kernel.pid_max and port range  [  OK  ]


[ERROR] (CDYIN0023E) One or more cluster prerequisite checks failed. See the file /home/test/biginsight/biginsight-3.0/installer/hdm/bin/bi-prechecker.20140826_125333.log for more information.

 

I checked the  /home/test/biginsight/biginsight-3.0/installer/hdm/bin/bi-prechecker.20140826_125333.log file and found following error.But I had configure the /etc/hosts files,and point to hostname and IP para.

--- Verify all host names are RFC-1035 valid ---
[ERROR] (CDYIN0122E) localhost is not a valid full host name according to RFC-1035. Specify a valid fully qualified domain name and run the utility again

 

============/etc/hosts=================

[root@tangqian6 bin]# more /etc/hosts
#
# hosts         This file describes a number of hostname-to-address
#               mappings for the TCP/IP subsystem.  It is mostly
#               used at boot time, when no name servers are running.
#               On small systems, this file can be used instead of a
#               "named" name server.
# Syntax:
#   
# IP-Address  Full-Qualified-Hostname  Short-Hostname
#

127.0.0.1       localhost.localdomain    localhost

# special IPv6 addresses
::1             localhost ipv6-localhost ipv6-loopback

fe00::0         ipv6-localnet

ff00::0         ipv6-mcastprefix
ff02::1         ipv6-allnodes
ff02::2         ipv6-allrouters
ff02::3         ipv6-allhosts
192.168.44.150   tangqian6.localdomain tangqian6

 

 

  • DigitalMeister2010
    DigitalMeister2010
    3 Posts

    Re: Install Biginsight 3.0 occur error

    ‏2014-08-27T15:40:50Z  

    Your issues sound similar to what I was experiencing a few days ago.  You'll want to follow the pre-installation instructions (http://www-01.ibm.com/support/knowledgecenter/SSPT3X_3.0.0/com.ibm.swg.im.infosphere.biginsights.install.doc/doc/install_prepare.html%23install_prepare) and setup the connectivity for the NTP server.  

    Also, I found that I had to use a nodeList.txt file.  This link (http://www-01.ibm.com/support/docview.wss?uid=swg21680006) gives information on how to get around that issue.

     

    Hope that helps.

  • 7PJN_Martin_Mašek
    7PJN_Martin_Mašek
    17 Posts

    Re: Install Biginsight 3.0 occur error

    ‏2014-08-31T19:45:19Z  

    See https://developer.ibm.com/answers/questions/19611/biginsights-30-bi-prechecksh-error-cdyin0122e-verify-all-host-names-are-rfc-1035-valid/ I think you can ignore this error but don't forget to fill full names for your nodes during installation. So e.g 

    NOT

    master

    child1

    child2

    BUT

    master.bivm.com

    child1.bivm.com

    child2.bivm.com

  • tangqian
    tangqian
    2 Posts

    Re: Install Biginsight 3.0 occur error

    ‏2014-09-07T13:25:03Z  

    See https://developer.ibm.com/answers/questions/19611/biginsights-30-bi-prechecksh-error-cdyin0122e-verify-all-host-names-are-rfc-1035-valid/ I think you can ignore this error but don't forget to fill full names for your nodes during installation. So e.g 

    NOT

    master

    child1

    child2

    BUT

    master.bivm.com

    child1.bivm.com

    child2.bivm.com

    Hi ,

    Thanks for your tips,it lookes like hit same issue,but I had changed my /etc/hosts file as following description.It also occur same issue,I didn't how how to folow RFC-1035.

    [biadmin@tangqian bin]$ more /etc/hosts
    192.168.44.150   tangqian.xnct.abc.com       tangqian
    127.0.0.1               localhost.localdomain       localhost

     

    error message:

    --- Verify all host names are RFC-1035 valid ---
    [ERROR] (CDYIN0122E) localhost is not a valid full host name according to RFC-1035. Specify a valid fully qualified domain name and run the utility again