Topic
2 replies Latest Post - ‏2013-06-28T08:29:01Z by GoranM
GoranM
GoranM
2 Posts
ACCEPTED ANSWER

Pinned topic Issue with the IBM Data Studio routine debugger

‏2013-06-20T13:37:58Z |

Hi,

I have an issue with the IBM Studio's routine debugger.

The routine debugger worked fine for about a month and a half, but now it started to cause problems with some of the more complex stored procedures. When I deploy any stored procedure for debugging and then try to edit the IBM.RoutineDebugger configuration, I always get the error message:

"Unable to locate routine "StoredProcedureName". The routine might have been deleted from the workspace."

Despite of this error message I can then still debug some of the simpler/smaller stored procedures. The problem occurs with bigger and more complex stored procedures. Only few seconds after running a large stored procedure debug session, the Routine Debugger gets terminated, without any error or warning messages. The problematic procedure then stays locked and can be re-deployed only after the restart of the IBM Data Studio.

I've tried many different things to solve the problem, like changing the workspace directory, reinstalling the Data Studio or changing the Routine Debug Session Manager settings, but with no luck so far.

 
I'm using IBM Data Studio 4.1 and DB2 version 9.7.
All procedures can be run without any problems, the problem occurs only when trying to debug.
 
 
 
I would be very thankful for any help.
Thanks in advance,
 
Goran M.
 
  • David.Zhu
    David.Zhu
    66 Posts
    ACCEPTED ANSWER

    Re: Issue with the IBM Data Studio routine debugger

    ‏2013-06-26T16:47:44Z  in response to GoranM

    Hi,Goran,

    could you give me following information.

    1.The picture of the  IBM.RoutineDebugger configuration when the error happen.

    2.Enable the client trace as following guide and paste the .log
    http://pic.dhe.ibm.com/infocenter/dstudio/v4r1/topic/com.ibm.debug.spd.plsql.doc/topics/tbtrcplsqlcli.html?resultof=%22%65%6e%61%62%6c%65%22%20%22%65%6e%61%62%6c%22%20%22%64%65%62%75%67%22%20%22%74%72%61%63%65%22%20

    3.When it reports routine not found, you can change the project and then select the routine as the picture and try again.

    You can also try to select the complex routine which have problem as you described through edit "IBM.RoutineDebugger" from Data Source explore or Data Project explore and then launch debug session through context menu and check whether the problem still exist.

    Thanks.

    Attachments

    • GoranM
      GoranM
      2 Posts
      ACCEPTED ANSWER

      Re: Issue with the IBM Data Studio routine debugger

      ‏2013-06-28T08:29:01Z  in response to David.Zhu

      Hi,

      Sorry for my late reply, I had some issues with my working environment.

      1. This error occurs immediately after I initialize the debug session and open the routine debugger configuration (even for the stored procedures that can be debugged subsequently).

      2. Unfortunately I am not able to provide the client trace at the moment. Trace enabling slows my working environment drastically, to the point where I'm unable to work even on other projects.

      3. I am not able to change the project or routine, in fact the routine debugger project browser cannot find any projects at all.

      I've also tried to launch the debug session through context menu, but it did not help to solve my problem.

       

      Thank you very much for the reply, any help is appreciated.