Topic
5 replies Latest Post - ‏2013-04-30T14:29:27Z by David.Zhu
roland.westphal
roland.westphal
3 Posts
ACCEPTED ANSWER

Pinned topic No columns in Datasource Explorer

‏2013-04-26T10:23:13Z |

Hi there,

when i add a new datasource to the datasource explorer i can browse all schemas and tables, but when i try to browse the column list i only get an empty list. This is only occuring on a clients iseries, the same system on our side (same OS Release) works fine.

System: System i V6R1

Database: DB2 for i V6R1

Driver: AS/400 Toolbox for Java (jt400.jar)

Any clues anybody? :-)

 

  • David.Zhu
    David.Zhu
    66 Posts
    ACCEPTED ANSWER

    Re: No columns in Datasource Explorer

    ‏2013-04-27T04:14:51Z  in response to roland.westphal

    Hi,Roland,

    Since it's only related special client and I can't repeat in my side either. Could you provide following information?

    1. What's the version Data Studio clients used?

    2. Only special table can't look the column or all tables can't look the column list?

    3.If only special table, could you get  the DDL of this table?

    4.Does any error happen when click the the column list and could you send the log at the <workspace>/.metadta/.log* when do the operations?

    if this information can't paste here, you can send it to zhuzhih@cn.ibm.com

    Thanks.

  • roland.westphal
    roland.westphal
    3 Posts
    ACCEPTED ANSWER

    Re: No columns in Datasource Explorer

    ‏2013-04-29T08:45:40Z  in response to roland.westphal

    Hi David,

    here are the informations:

    1. IBM Data Studio 3.2.0.0 (Windows)

    2. all Tables in all Schemas

    3. see 2

    4. SQL 0443 occurs (see Log)

    Log:

     

    !ENTRY org.eclipse.ui 4 4 2013-04-29 09:30:15.668
    !MESSAGE Invalid preference page path: Advisorfunktion für Workloadzugriffspfade
     
    !ENTRY com.ibm.datatools.core.http 1 0 2013-04-29 09:30:15.726
    !MESSAGE Eingebetteter Server gestartet: [HTTP-Port: 56788, HTTPS-Port: 56789]
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:25.916
    !MESSAGE NLS unused message: UPGRADE_LABEL in: com.ibm.datatools.core.ui.l10n.datatoolsCoreUI
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.328
    !MESSAGE NLS unused message: MigrateDataWizard_PageTitle in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.330
    !MESSAGE NLS unused message: MigrateDataWizard_SaveFile in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.331
    !MESSAGE NLS unused message: MigrateDataWizard_SelectConnectionMessage in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.332
    !MESSAGE NLS unused message: MigrateDataWizard_GEN_DATA_MIG_CMDS_STATUS_MSG in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.334
    !MESSAGE NLS unused message: MigrateObjectsProcessFlow_ProcessFlowDescription in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.335
    !MESSAGE NLS unused message: MigrateObjectsProcessFlow_PROCESS_OPTIONS_DESC in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.336
    !MESSAGE NLS unused message: MigrateDataProcessFlowProcessFlowDescription in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.337
    !MESSAGE NLS unused message: MigrateDataWizard_WindowTitle in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.339
    !MESSAGE NLS unused message: MigrateDataWizard_DATA_MIG_PAGE_STR in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.340
    !MESSAGE NLS unused message: MigrateDataWizard_MIG_DATA_OPTS_STR in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.341
    !MESSAGE NLS unused message: MigrateDataWizard_CommitFileProgress in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.342
    !MESSAGE NLS unused message: MigrateDataWizard_DATA_MIG_MSG_01 in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.343
    !MESSAGE NLS unused message: MigrateDataPage_PageTitle in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.345
    !MESSAGE NLS unused message: MigrateDataPage_PageDescription in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.346
    !MESSAGE NLS unused message: MigrateDataPage_HostName in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.347
    !MESSAGE NLS unused message: MigrateDataPage_Port in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.348
    !MESSAGE NLS unused message: MigrateDataPage_Instance in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:28.349
    !MESSAGE NLS unused message: MigrateDataPage_DatabaseName in: com.ibm.datatools.uom.ui.internal.i18n.messages
     
    !ENTRY org.eclipse.osgi 2 1 2013-04-29 09:30:36.899
    !MESSAGE NLS missing message: DATATOOLS_DB2_ZSERIES_EXPLORER_CONSTRAINTS in: com.ibm.datatools.db2.zseries.ui.l10n.db2zSeriesUI
     
    !ENTRY com.ibm.datatools.dimensional.ui 1 0 2013-04-29 09:30:43.069
    !MESSAGE The Dimensional Model Service is available.
     
    !ENTRY org.eclipse.datatools.connectivity.sqm.core 4 4 2013-04-29 09:30:49.614
    !MESSAGE java.sql.SQLException
    !STACK 0
    java.sql.SQLException: [SQL0443] ŸŸ
    at com.ibm.as400.access.JDError.throwSQLException(Unknown Source)
    at com.ibm.as400.access.JDError.throwSQLException(Unknown Source)
    at com.ibm.as400.access.AS400JDBCStatement.commonExecute(Unknown Source)
    at com.ibm.as400.access.AS400JDBCStatement.executeQuery(Unknown Source)
    at org.eclipse.datatools.connectivity.sqm.internal.core.connection.StatementAdapter.executeQuery(Unknown Source)
    at com.ibm.datatools.db2.iseries.catalog.ISeriesCatalogTable.loadColumns(Unknown Source)
    at com.ibm.datatools.db2.iseries.catalog.ISeriesCatalogTable.loadColumns(Unknown Source)
    at com.ibm.datatools.db2.iseries.catalog.ISeriesCatalogTable.getColumns(Unknown Source)
    at org.eclipse.datatools.connectivity.sqm.server.internal.ui.explorer.providers.content.layout.vnode.ServerExplorerVNodeContentProviderNav.displayColumnNodeChildren(Unknown Source)
    at org.eclipse.datatools.connectivity.sqm.server.internal.ui.explorer.providers.content.layout.AbstractOnDemandContentProviderNav.getChildren(Unknown Source)
    at org.eclipse.datatools.connectivity.sqm.server.internal.ui.explorer.providers.content.layout.AbstractOnDemandContentProviderNav.getChildren(Unknown Source)
    at org.eclipse.datatools.connectivity.sqm.server.internal.ui.explorer.providers.content.layout.AbstractLayoutProviderNav.getChildren(Unknown Source)
    at org.eclipse.datatools.connectivity.sqm.server.internal.ui.explorer.providers.content.impl.ServerExplorerContentProviderNav.load(Unknown Source)
    at org.eclipse.datatools.connectivity.sqm.server.internal.ui.explorer.loading.LoadingJob.run(Unknown Source)
    at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)
     

    best regards,

    Roland

    • David.Zhu
      David.Zhu
      66 Posts
      ACCEPTED ANSWER

      Re: No columns in Datasource Explorer

      ‏2013-04-30T13:40:35Z  in response to roland.westphal

      Hi,Roland,

      From current information, it's possible related to server end problem, I already contact server team and check what's the next step to resolve this problem. If any update, I'll let you know.

      Thanks.

  • roland.westphal
    roland.westphal
    3 Posts
    ACCEPTED ANSWER

    Re: No columns in Datasource Explorer

    ‏2013-04-30T14:05:18Z  in response to roland.westphal

    Hi David,

    i already figured out that the problem occured while accessing the QSYS2/SYSCOLUMNS2 View on the iSeries.

     

    Folowing Commands saved my day:
    CALL QSYS2/QSQXRLF (DLT QSYS2)
    CALL QSYS2/QSQXRLF (CRT QSYS2)
    

    These commands recreated the views and procedures and now i can access the column lists.

    regards

    Roland

    Updated on 2013-04-30T14:05:47Z at 2013-04-30T14:05:47Z by roland.westphal
    • David.Zhu
      David.Zhu
      66 Posts
      ACCEPTED ANSWER

      Re: No columns in Datasource Explorer

      ‏2013-04-30T14:29:27Z  in response to roland.westphal

      Hi,Roland,

      Very glad to hear the problem resolved, thanks for you let me know.