Topic
  • 3 replies
  • Latest Post - ‏2014-02-05T11:30:15Z by mylap
mylap
mylap
9 Posts

Pinned topic Advanced ToolChain 7 problems

‏2014-02-04T17:04:15Z |

Hi

I have the Advanced Toolchain 6.0.5 and the SDK 1.4 installed ok on my  Sles 11 sp2 LPar

But when I try to install the Advanced Toolchain v7.0.3 I get:


Preparing...                ########################################### [100%]
1:advance-toolchain-at7.0########################################### [100%]
/var/tmp/rpm-tmp.81490: line 9:  3262 Illegal instruction     /opt/at7.0/sbin/ldconfig

 

I get a similar error about an illegal instruction in ldconfig for the advance-toolchain-at7.0-devel-7.0-3.ppc64
and  advance-toolchain-at7.0-perf-7.0-3.ppc64 rpm's as well.

I presume this isn't expected ?

Thanls

Andy

 

  • tuliom
    tuliom
    15 Posts
    ACCEPTED ANSWER

    Re: Advanced ToolChain 7 problems

    ‏2014-02-05T11:03:56Z  

    Hi Andy and Rafael,

    This issue usually happens when installing AT 7.0 on a non-supported processor.
    Since version 7.0-0, the Advance Toolchain supports only POWER7 and POWER8.

    Are both of you using one of these processors?

    If you're using POWER6 I recommend to continue using AT 6.0-5.

    Regards

  • RafaelSene
    RafaelSene
    11 Posts

    Re: Advanced ToolChain 7 problems

    ‏2014-02-05T01:11:06Z  

    Hi mylap, I reproduced the installation using SLES 11.1 and I got a similar problem . I already talked to Advance Toolchain team about this issue.

    # zypper install ./advance-toolchain-at7.0-runtime-7.0-3.ppc64.rpm

    Retrieving repository 'Advance Toolchain' metadata [done]
    Building repository 'Advance Toolchain' cache [done]
    Retrieving repository 'IBM Power Tools' metadata [done]
    Building repository 'IBM Power Tools' cache [done]
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    The following NEW package is going to be installed:
      advance-toolchain-at7.0-runtime

    The following package is not supported by its vendor:
      advance-toolchain-at7.0-runtime

    1 new package to install.
    Overall download size: 179.7 MiB. After the operation, additional 911.4 MiB
    will be used.
    Continue? [y/n/?] (y): Retrieving package advance-toolchain-at7.0-runtime-7.0-3.ppc64 (1/1), 179.7 MiB (911.4 MiB unpacked)
    Retrieving: advance-toolchain-at7.0-runtime-7.0-3.ppc64.rpm [done (25.6 MiB/s)]
    Installing: advance-toolchain-at7.0-runtime-7.0-3 [done]
     #

    The package runtime installs without any problems. The problem shows up when trying to install devel package:

    # zypper install ./advance-toolchain-at7.0-devel-7.0-3.ppc64.rpm
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    The following NEW package is going to be installed:
      advance-toolchain-at7.0-devel

    The following package is not supported by its vendor:
      advance-toolchain-at7.0-devel

    1 new package to install.
    Overall download size: 66.8 MiB. After the operation, additional 400.6 MiB will
    be used.
    Continue? [y/n/?] (y): y
    Retrieving package advance-toolchain-at7.0-devel-7.0-3.ppc64 (1/1), 66.8 MiB (400.6 MiB unpacked)
    Retrieving: advance-toolchain-at7.0-devel-7.0-3.ppc64.rpm [done (21.5 MiB/s)]
    Installing: advance-toolchain-at7.0-devel-7.0-3 [error]
    Installation of advance-toolchain-at7.0-devel-7.0-3 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: Testing for optional IBM XL compilers installation...
    This will check for XLC/XLF availability and create config files for them in /opt/at7.0/scripts
    IBM XL compilers not found in its default location at /opt/ibmcmp
    If it is installed somewhere else, please re-run:
    xl_base=<your-install-dir> /opt/at7.0/scripts/at-create-ibmcmp-cfg.sh
    /var/tmp/rpm-tmp.79785: line 8:  4522 Illegal instruction     /opt/at7.0/sbin/ldconfig
    error: %post(advance-toolchain-at7.0-devel-7.0-3.ppc64) scriptlet failed, exit status 132

  • tuliom
    tuliom
    15 Posts

    Re: Advanced ToolChain 7 problems

    ‏2014-02-05T11:03:56Z  

    Hi Andy and Rafael,

    This issue usually happens when installing AT 7.0 on a non-supported processor.
    Since version 7.0-0, the Advance Toolchain supports only POWER7 and POWER8.

    Are both of you using one of these processors?

    If you're using POWER6 I recommend to continue using AT 6.0-5.

    Regards

  • mylap
    mylap
    9 Posts

    Re: Advanced ToolChain 7 problems

    ‏2014-02-05T11:30:15Z  
    • tuliom
    • ‏2014-02-05T11:03:56Z

    Hi Andy and Rafael,

    This issue usually happens when installing AT 7.0 on a non-supported processor.
    Since version 7.0-0, the Advance Toolchain supports only POWER7 and POWER8.

    Are both of you using one of these processors?

    If you're using POWER6 I recommend to continue using AT 6.0-5.

    Regards

    Hi

     

    Yes that was the problem

    Although I was using a POWER7 server - the LPar was in POWER6 processor mode (having being moved with Live Partition Mobility from a POWER6 server previously)

    Thanks for the help ...

    Andy