• 3 replies
  • Latest Post - ‏2013-11-19T05:08:25Z by CatherineWu
26 Posts

Pinned topic New SQL Script button doesn't work

‏2013-09-03T16:48:56Z |

In 3.2 I used to use the New SQL Script button / menu option to create a quick SQL script window for testing (I generally don't use projects as my work is done in Visual Studio). Since installing 4.1 I can no longer create new SQL script windows this way and it's very frustrating. I have tried via the Admin view, which is my normal perspective and the Data view and it fails from every location. When I click the button nothing happens. Is this a known issue, or do I have a configuration problem.




  • DavidWAdler
    7 Posts

    Re: New SQL Script button doesn't work


    I have the same problem after installing 4.1.

    The new script button/context menu worked fine for a while and then suddenly stopped.  Creating a new project, the new script operation is working fine for now.

    Very strange.

  • donkeyhotay
    1 Post

    Re: New SQL Script button doesn't work


    Just chiming in that I've had the same problem.  My workaround is to copy and paste an existing file, but you have to be sure to put the .sql extension on the file name, otherwise it won't show up in the navigator pane.

    I get the feeling that some sort of error is happening that is not being caught -- or rather it is being caught, but ignored, leaving the user with no idea what the problem might me.


  • CatherineWu
    11 Posts

    Re: New SQL Script button doesn't work


    Hi - I just try it using Data Studio 4.1. I am in admin perspective. Click Table in admin explorer. Choose one table, right click and choose Data -> New SQL script. The SQL window shows up. Please see the screenshots as below.

    Did you go through the same path to create SQL window?