Topic
1 reply Latest Post - ‏2013-07-18T12:44:16Z by Sunil George
DevMichael
DevMichael
1 Post
ACCEPTED ANSWER

Pinned topic LDAP user registry Authentication Debug

‏2013-07-09T14:26:10Z |

Hi all,

I'm having issues with trying to connect an LDAP user registry server using liberty profile 8.5.5. I'm trying to authenticate using FORM and have a basic login page setup to test this. This is the error I get every time I input a valid username and password.

[AUDIT   ] CWWKS1100A: Authentication did not succeed for user ID ts2user2. An invalid user ID or password was specified.
 

This is what I have tried so far to debug this issue.

-I have looked at http://pic.dhe.ibm.com/infocenter/wasinfo/v8r5/index.jsp?topic=%2Fcom.ibm.websphere.wlp.nd.doc%2Fae%2Ftwlp_sec_ldap.html.

-I have used a colleague's LDAP configuration in the server.xml, but she was using a different version of liberty (8.5.0.3).

-I have created a basic user registry and that works perfectly.

I'm wondering if there's a way to debug in liberty profile besides looking at the trace and logs as those aren't that helpful. I want to step through and see if it's even establishing a connection with the LDAP server and if so what it's trying to do. Any tips on how to go about in doing this would be greatly appreciated!

Thanks!

  • Sunil George
    Sunil George
    3 Posts
    ACCEPTED ANSWER

    Re: LDAP user registry Authentication Debug

    ‏2013-07-18T12:44:16Z  in response to DevMichael

    Hi,

       Can you paste the <ldapRegistry/> snippet from the server.xml and upload the trace file.

       In the trace.log, you should see something like   

       "createContextPool Active Provider URL: ldap://ldap.server.com:ldap_port

       createContextPool ContextPool: total=1, poolSize=1"    when the LDAP connection is successful.

    To enable trace -> http://www-01.ibm.com/support/docview.wss?uid=swg21596714 and include packages com.ibm.ws.wim.*=all:com.ibm.ws.security.*=all::com.ibm.ws.webcontainer.security.*=all 

     

    Thanks.