Topic
  • 6 replies
  • Latest Post - ‏2012-08-13T19:18:14Z by jerberstark
cravenr
cravenr
3 Posts

Pinned topic IBM Service and Productivity Tools - iSeries/Redhat/HMC

‏2012-08-09T14:01:57Z |
 From the following link -I'm trying to install the tools used by the HMC controlling a iSeries partition hosting a Linux system. -Red Hat Enterprise Linux Server release 5.8 (Tikanga)
 
I'm upto the libservicelog and find I need

rpm -Uvh libservicelog-1.1.11-7.el6.ppc64.rpm

warning: libservicelog-1.1.11-7.el6.ppc64.rpm: Header V3 DSA signature: NOKEY, key ID 3e6e42be

error: Failed dependencies:

        libc.so.6(GLIBC_2.7)(64bit) is needed by libservicelog-1.1.11-7.el6.ppc64

        rpmlib(FileDigests) <= 4.6.0-1 is needed by libservicelog-1.1.11-7.el6.ppc64

        rpmlib(PayloadIsXz) <= 5.2-1 is needed by libservicelog-1.1.11-7.el6.ppc64

I've found libc.so.6 but the internet has failed to come up with rpmlib - I've even tried to yum rpmdev.
Should I -force it? What am I doing wrong!  
Updated on 2012-08-13T19:18:14Z at 2012-08-13T19:18:14Z by Bill_Buros
  • willschm
    willschm
    47 Posts

    Re: IBM Service and Productivity Tools - iSeries/Redhat/HMC

    ‏2012-08-09T17:42:59Z  
    It looks like you are trying to cross a rhel5/rhel6 boundary.  (i.e.  .el6  in the rpm name).
     
    Look for a rhel5 version of libservicelog, the rpm requirements should match libc/rpmlib versions you have on the rhel5.8 system.   i.e. libservicelog-1.1.11-9.el5
  • Bill_Buros
    Bill_Buros
    168 Posts

    Re: IBM Service and Productivity Tools - iSeries/Redhat/HMC

    ‏2012-08-09T19:19:39Z  
    • willschm
    • ‏2012-08-09T17:42:59Z
    It looks like you are trying to cross a rhel5/rhel6 boundary.  (i.e.  .el6  in the rpm name).
     
    Look for a rhel5 version of libservicelog, the rpm requirements should match libc/rpmlib versions you have on the rhel5.8 system.   i.e. libservicelog-1.1.11-9.el5
    Just curious, if you use the yum repo, would the right version be selected automatically?
     
  • willschm
    willschm
    47 Posts

    Re: IBM Service and Productivity Tools - iSeries/Redhat/HMC

    ‏2012-08-09T20:34:16Z  
    Just curious, if you use the yum repo, would the right version be selected automatically?
     
     
    >  Just curious, if you use the yum repo, would the right version be selected automatically?
     
     I would expect so.    The page that Mr. Craven (cravenr) started at ( https://www14.software.ibm.com/webapp/set2/sas/f/lopdiags/redhat/hmcmanaged/rhel5.html  ) does eventually point one at the individual RPMS, so can fairly easily see how we got into this situation.   Probably a todo for whoever owns those pages to add a pointer to the yum repos.  :-)
  • cravenr
    cravenr
    3 Posts

    Re: IBM Service and Productivity Tools - iSeries/Redhat/HMC

    ‏2012-08-10T09:40:27Z  
     Yep - el6 is the wrong rpm for Release 5.  Thats now installed fine.
     
    I'm going to use the repo supplied above, just waiting for Firewall changes.
    This will make it a lot easier and more idiot proof.
     
    Thanks chaps.
      
     
     
  • cravenr
    cravenr
    3 Posts

    Re: IBM Service and Productivity Tools - iSeries/Redhat/HMC

    ‏2012-08-10T10:02:42Z  
    • cravenr
    • ‏2012-08-10T09:40:27Z
     Yep - el6 is the wrong rpm for Release 5.  Thats now installed fine.
     
    I'm going to use the repo supplied above, just waiting for Firewall changes.
    This will make it a lot easier and more idiot proof.
     
    Thanks chaps.
      
     
     
     If your putting up a link - can we have one for the doucmentation - configuration - as well.
  • jerberstark
    jerberstark
    31 Posts

    Re: IBM Service and Productivity Tools - iSeries/Redhat/HMC

    ‏2012-08-13T19:18:14Z  
    • cravenr
    • ‏2012-08-10T10:02:42Z
     If your putting up a link - can we have one for the doucmentation - configuration - as well.
     Cravenr, here is the documentation for the service and productivity tools:
    http://publib.boulder.ibm.com/infocenter/lnxinfo/v3r0m0/index.jsp?topic=%2Fliaau%2Fliaau-installing.htm
    Updated on 2012-08-13T19:18:14Z at 2012-08-13T19:18:14Z by Bill_Buros