Topic
4 replies Latest Post - ‏2013-09-02T06:46:14Z by yang.eric
yang.eric
yang.eric
3 Posts
ACCEPTED ANSWER

Pinned topic Can't start Websphere Portal v6.1 on WAS 7

‏2013-08-15T03:14:30Z |

Hello, 

When i tried to start portal server "Websphere Portal v6.1 on WAS 7" in RAD, it would always prompt an error: 
An internal error occurred during: "Starting WebSphere Portal v6.1 Server on WAS 7 at localhost".
After close the prompt, the portal server state kept STARTING until time out. But in the backend, it's found the server were actually started, which
can be verified by server's SystemOut log.
 
As the server state kept STARTING, any publish operation is not allowed, which is a big trouble to me. 
Any comments are appreciated, thanks a lot. 
 
OS: WIN 7
RAD Info: IBM Rational Application Developer for WebSphere Software
Version: 7.5.5.3
Build ID: 20101203_0655
 
Error details as follows
 
Message: An internal error occurred during: "Starting WebSphere Portal v6.1 Server on WAS 7 at localhost".
 
Exception Stack Trace
java.lang.NullPointerException
at com.ibm.ws.ast.st.common.core.internal.AbstractWASServerBehaviour.addOutputStreamListener(Unknown Source)
at com.ibm.ws.ast.st.common.core.internal.AbstractWASServerBehaviour.setProcess(Unknown Source)
at com.ibm.ws.ast.st.v7.core.internal.WASLaunchConfigurationDelegate.launch(Unknown Source)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(Unknown Source)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(Unknown Source)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(Unknown Source)
at org.eclipse.wst.server.core.internal.Server.startImpl2(Unknown Source)
at org.eclipse.wst.server.core.internal.Server.startImpl(Unknown Source)
at org.eclipse.wst.server.core.internal.Server$StartJob.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)
    
Session Data
eclipse.buildId=unknown
java.fullversion=JRE 1.6.0 IBM J9 2.4 Windows 7 x86-32 jvmwi3260sr8-20100401_55940 (JIT enabled, AOT enabled)
J9VM - 20100401_055940
JIT  - r9_20100401_15339
GC   - 20100308_AA
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product com.ibm.rational.rad.product.v75.ide
Command-line arguments:  -os win32 -ws win32 -arch x86 -product com.ibm.rational.rad.product.v75.ide
 
  • ROTTNEST
    ROTTNEST
    4 Posts
    ACCEPTED ANSWER

    Re: Can't start Websphere Portal v6.1 on WAS 7

    ‏2013-08-19T02:47:49Z  in response to yang.eric

    If your environment is clear, I'd like to you to check your network configuration:

    1) Make sure 127.0.0.1 is pointing to localhost

    2) IP_Address is pointing to you machine hostname ( with both full name and short name)

    3) disable IPv6 could get lucky by -Djava.net.preferIPv4Stack=true

    4) try to start from stand alone WPS or WAS instead from RAD

    ...

    I can not image more for this moment, hope you lucky...

    • yang.eric
      yang.eric
      3 Posts
      ACCEPTED ANSWER

      Re: Can't start Websphere Portal v6.1 on WAS 7

      ‏2013-08-23T02:31:08Z  in response to ROTTNEST

      Thanks ROTTNEST, I tried your suggestions, but seems in vain. When i tried to start WPS standalone (outside RAD), it worked fine. But when i tried to start the WPS in RAD, the server state always STARTING, even the WPS was really started. The server state can't change to started. 

      • ROTTNEST
        ROTTNEST
        4 Posts
        ACCEPTED ANSWER

        Re: Can't start Websphere Portal v6.1 on WAS 7

        ‏2013-08-23T04:20:26Z  in response to yang.eric

        Function is OK? As long as it works, let it be. Perhaps the status is  not synchronized because of timeout?

        -- Did you try to reload the view or perspective?

         

        • yang.eric
          yang.eric
          3 Posts
          ACCEPTED ANSWER

          Re: Can't start Websphere Portal v6.1 on WAS 7

          ‏2013-09-02T06:46:14Z  in response to ROTTNEST

          Yes, the function is OK. I tried to close and show server view. The server state could not reflect. Anyway, let it be for the moment. Thanks a lot for your helpful comments. :P