Topic
  • 1 reply
  • Latest Post - ‏2014-05-15T14:10:00Z by kksingh
MS2
MS2
1 Post

Pinned topic Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started

‏2014-05-14T11:13:03Z |

I am on RAD 8 with websphere 8.5. RAD is not starting up. I tried to download the maven plugin for eclipse m2e ever since I am not able to bring up my RAD. I replaced my eclipse.ini, config.ini and plugins in the SDPshared folder to what they were before. I still get this below error. eclipse.ini and config.ini are below after the error.

!SESSION 2014-05-13 17:39:27.338 ----------------------------------------------- eclipse.buildId=unknown java.fullversion=JRE 1.7.0 IBM J9 2.6 Windows 7 x86-32 20120322_106209 (JIT enabled, AOT enabled) J9VM - R26_Java726_SR1_20120322_1720_B106209 JIT - r11_20120322_22976 GC - R26_Java726_SR1_20120322_1720_B106209 J9CL - 20120322_106209 BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US Command-line arguments: -os win32 -ws win32 -arch x86 -clean

!ENTRY org.eclipse.osgi 2 0 2014-05-13 17:39:29.366 !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:

!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-13 17:39:29.366 !MESSAGE Bundle initial@reference:file:../SDPShared/plugins/org.eclipse.core.runtime_3.6.0.v20100505.jar/ was not resolved.

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0). !SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.3.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).

!ENTRY org.eclipse.osgi 2 0 2014-05-13 17:39:29.366 !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:

!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-13 17:39:29.366 !MESSAGE Bundle org.eclipse.core.runtime_3.6.0.v20100505 [4] was not resolved. !SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.3.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2014-05-13 17:39:29.366 !MESSAGE Missing dynamically imported package org.eclipse.core.internal.runtime.auth_0.0.0.

!ENTRY org.eclipse.osgi 4 0 2014-05-13 17:39:29.382 !MESSAGE Application error !STACK 1 java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini). at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(Unknown Source) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(Unknown Source) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(Unknown Source) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.equinox.launcher.Main.invokeFramework(Unknown Source) at org.eclipse.equinox.launcher.Main.basicRun(Unknown Source) at org.eclipse.equinox.launcher.Main.run(Unknown Source) at org.eclipse.equinox.launcher.Main.main(Unknown Source)

eclipse.ini

-vm jdk/jre/bin/javaw.exe -startup plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar -install C:/Program Files (x86)/IBM/SDP85 --launcher.library plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.2.R36x_v20101222 -vmargs -Dsdp.driver=RADO85-I20120529_2348 -Xquickstart -Xms40m -Xmx1024m -Xmnx64m -Xgcpolicy:gencon -Xscmx48m -Xshareclasses:name=IBMSDP_%u -Xnolinenumbers -XX:MaxPermSize=128M -Dcom.ibm.ws.management.event.max_polling_interval=1000 -Djava.util.Arrays.useLegacyMergeSort=true -Dosgi.bundles=org.eclipse.equinox.common@2:start,org.eclipse.update.configurator@3:start,org.eclipse.core.runtime@

config.ini

# Wed Oct 03 13:08:28 EDT 2012

help.war=C\:\Program Files (x86)\IBM\SDP85\help\help.war rad.internal.version=RADO85-I20120529_2348 osgi.framework.override.user=true com.ibm.SSL.ConfigURL=file\:C\:\Program Files (x86)\IBM\SDP85/runtimes/base_stub/properties/ssl.client.props osgi.bundles=reference\:file\:/C\:/Program Files (x86)/IBM/SDPShared/plugins/org.eclipse.equinox.simpleconfigurator_1.0.200.v20100503.jar@1\:start org.eclipse.equinox.p2.reconciler.dropins.directory=C\:\Program Files (x86)\IBM\SDP85\configuration\org.eclipse.update\com.ibm.cic.bootstrap.repository eclipse.p2.profile=bootProfile cic.appDataLocation=C\:\ProgramData\IBM\Installation Manager help.type.default=remote osgi.framework.extensions.override.user=true osgi.framework.extensions=com.ibm.cds_2.1.0.201009130929.jar org.eclipse.update.reconcile=false osgi.bundles.defaultStartLevel=4 eclipse.p2.verifyPlan=false osgi.framework=file\:/C\:/Program Files (x86)/IBM/SDPShared/plugins/org.eclipse.osgi_3.6.50.R36x_v20120315-1500.jar osgi.bundles.override.user=true eclipse.product=com.ibm.rational.rad.product.v85.ide was.runtime=C\:\Program Files (x86)\IBM\SDP85/runtimes security.overrideProperties=true osgi.launcherIni=eclipse osgi.instance.area.default=@user.home/IBM/rationalsdp/workspace org.eclipse.equinox.simpleconfigurator.exclusiveInstallation=false com.ibm.CORBA.ConfigURL=file\:C\:\Program Files (x86)\IBM\SDP85/runtimes/base_stub/properties/sas.client.props osgi.bundlefile.limit=100 osgi.splashPath=file\:C\:\Program Files (x86)\IBM\SDPShared/plugins/com.ibm.rational.rad.product.v85,file\:C\:\Program Files (x86)\IBM\SDPShared/plugins/com.ibm.rational.rad.product.v85.nl1,file\:C\:\Program Files (x86)\IBM\SDPShared/plugins/com.ibm.rational.rad.product.v85.nl2,file\:C\:\Program Files (x86)\IBM\SDPShared/plugins/com.ibm.rational.rad.product.v85.nl2bidi osgi.ws=win32 org.eclipse.uml2.common.util.CacheAdapter.INSTANCE=com.ibm.xtools.uml.internal.cacheadapter.UMLCacheAdapter osgi.bundles.extraData=file\:/C\:/Program Files (x86)/IBM/SDPShared/plugins/org.eclipse.equinox.simpleconfigurator_1.0.200.v20100503.jar,org.eclipse.equinox.simpleconfigurator,1.0.200.v20100503 java.security.properties=file\:C\:\Program Files (x86)\IBM\SDP85/runtimes/base_stub/properties/java.security help.URL.default= osgi.launcherPath=C\:\Program Files (x86)\IBM\SDP85 com.ibm.xtools.emf.collections.HashedCollectionFactory=true

 

  • kksingh
    kksingh
    32 Posts

    Re: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started

    ‏2014-05-15T14:10:00Z  

    Hi,

     

    Could you try using the -clean option to start RAD and verify the behavior:

     

    http://www.eclipsezone.com/eclipse/forums/t61566.html

     

    Also I see you have installed Maven plugin. Is that Plugin compatible with Eclispe 3.6.2? since RAD 8.x is built on Eclipse 3.6.

     

    Regards,