Topic
3 replies Latest Post - ‏2014-05-27T18:52:02Z by Tan
mtark
mtark
2 Posts
ACCEPTED ANSWER

Pinned topic Cannot Install WebSphere server 8.5

‏2014-02-04T20:27:50Z |

Trying to install WebSphere app server 8.5 using the GUI installer and am receiving errors.

Downloaded installer in Zip and unzipped the file.

Installer config.ini settings

osgi.bundles=org.eclipse.equinox.common@2\:start, org.eclipse.update.configurator@3\:start, org.eclipse.core.runtime@start, org.eclipse.equinox.ds@start
osgi.bundles.defaultStartLevel=5
eclipse.product=com.ibm.cic.agent.ui.product
osgi.splashPath=platform\:/base/plugins/com.ibm.cic.agent.ui
 
osgi.os=linux
osgi.ws=gtk
osgi.arch=x86_64
osgi.instance.area=@noDefault
osgi.nls.warnings=ignore
           
im.version=1.6.2
im.internal.version=1.6.2000.20130301_2248
 
im.installer.version=1.6.2
im.installer.internal.version=1.6.2000.20130301_2248
 
im.installer.jre.version=6.0.0.sr9_20110208_03
sun.nio.ch.disableSystemWideOverlappingFileLockCheck=true

 

############# below are the errors received when trying to run the installer with non-root

The com.ibm.websphere.DEVELOPERSILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
The com.ibm.websphere.IBMJAVA.v70 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
The com.ibm.websphere.liberty.IBMJAVA.v70 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
The com.ibm.websphere.IHSILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
The com.ibm.websphere.APPCLIENTILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
The com.ibm.websphere.PLGILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
The com.ibm.websphere.PLUGCLIENTILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
The com.ibm.websphere.WCTILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
The com.ibm.websphere.W2MTKILAN.v11 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
The com.ibm.websphere.liberty.DEVELOPERSILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
 
  The com.ibm.websphere.DEVELOPERSILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
 
  The com.ibm.websphere.IBMJAVA.v70 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
 
  The com.ibm.websphere.liberty.IBMJAVA.v70 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
 
  The com.ibm.websphere.IHSILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
 
  The com.ibm.websphere.APPCLIENTILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
 
  The com.ibm.websphere.PLGILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
 
  The com.ibm.websphere.PLUGCLIENTILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
 
  The com.ibm.websphere.WCTILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
 
  The com.ibm.websphere.W2MTKILAN.v11 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.
 
  The com.ibm.websphere.liberty.DEVELOPERSILAN.v85 package specified in the /local/home/push4laura/WebsphereDownloadDirector/install.xml file cannot be found.

 

 

############# below are the different errors received when trying to run the installer with root

BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -toolId install -accessRights admin input @osgi.install.area/install.xml
Command-line arguments:  -os linux -ws gtk -arch x86_64 -toolId install -accessRights admin input @osgi.install.area/install.xml
 
!ENTRY org.eclipse.osgi 4 0 2014-02-04 15:17:54.598
!MESSAGE Application error
!STACK 1
org.eclipse.swt.SWTError: No more handles [gtk_init_check() failed]
at org.eclipse.swt.SWT.error(SWT.java:4387)
at org.eclipse.swt.widgets.Display.createDisplay(Display.java:913)
at org.eclipse.swt.widgets.Display.create(Display.java:899)
at org.eclipse.swt.graphics.Device.<init>(Device.java:156)
at org.eclipse.swt.widgets.Display.<init>(Display.java:497)
at org.eclipse.swt.widgets.Display.<init>(Display.java:488)
at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:669)
at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
at com.ibm.cic.agent.internal.ui.AgentUIApplication.initDisplay(AgentUIApplication.java:140)
at com.ibm.cic.agent.internal.ui.AgentUIApplication.launch(AgentUIApplication.java:162)
at com.ibm.cic.agent.internal.ui.AgentUIApplication.start(AgentUIApplication.java:64)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
at java.lang.reflect.Method.invoke(Method.java:611)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)
 

 

Any help would be greatly appreciated.

  • mtark
    mtark
    2 Posts
    ACCEPTED ANSWER

    Re: Cannot Install WebSphere server 8.5

    ‏2014-02-05T02:02:21Z  in response to mtark

    Turns out my issue was the DNS lookup settings were removed from resolv.conf when I added an external IP to the server by the hosting companies management server.  This caused all URL's to IBM within the IBM Installation Manager to not get resolved. 

    IBM Installation Manager works fine now. 

     

     

    • Scott Johnston
      Scott Johnston
      76 Posts
      ACCEPTED ANSWER

      Re: Cannot Install WebSphere server 8.5

      ‏2014-02-05T15:59:04Z  in response to mtark


      Thank you for the update. I am glad to hear you worked out the issue.


      Regards,
      Scott Johnston
      WebSphere Application Server
      Install & Configuration User Experience Lead

      • Tan
        Tan
        1 Post
        ACCEPTED ANSWER

        Troubleshooting hooks in WAS Installation Mgr

        ‏2014-05-27T18:52:02Z  in response to Scott Johnston

        Does IM have an API for troubleshooting? Reading crash dumps like the above report or even install logs is not fun. 

        It's understandable to reduce instrumenting calls in run-time process -for performance reasons-, but for one-time processes like installation or app deployment those calls can be useful, I think. It's also understandable to build some back doors to enable other services, however making install and deployment easier would make for a broader appeal of the platform.

        Thanks,