Topic
5 replies Latest Post - ‏2013-10-02T09:56:09Z by chriscanto
Vijaykumarsaini
Vijaykumarsaini
3 Posts
ACCEPTED ANSWER

Pinned topic SVC Performance Stats Issue?

‏2013-10-01T11:27:41Z |

Hi All,

I am trying to get the Performance stats via SMIS as mentioned in link. However I am getting CIM_ERROR while calling IBMTSSVC_PerformanceStatisticsService.GetStatisticsCollection(). After analyzing the SMIS class instance, I found that IBMTSSVC_PerformanceStatisticsService.OperationalStatus is blank.

<IBMTSSVC_PerformanceStatisticsService><Caption></Caption><Description></Description><ElementName></ElementName><InstallDate></InstallDate><OperationalStatus></OperationalStatus><StatusDescriptions></StatusDescriptions><Status></Status><HealthState></HealthState><EnabledState>5</EnabledState><OtherEnabledState></OtherEnabledState><RequestedState>12</RequestedState><EnabledDefault>2</EnabledDefault><TimeOfLastStateChange></TimeOfLastStateChange><PrimaryOwnerName></PrimaryOwnerName><PrimaryOwnerContact></PrimaryOwnerContact><StartMode></StartMode><Started></Started><SystemCreationClassName>IBMTSSVC_Cluster</SystemCreationClassName><SystemName>00000200648020EC:00000200648020EC</SystemName><CreationClassName>IBMTSSVC_PerformanceStatisticsService</CreationClassName><Name>00000200648020EC</Name></IBMTSSVC_PerformanceStatisticsService>

Please find below my questions

1: Is IBMTSSVC_PerformanceStatisticsService instance(property dump provided above) indicates its not running?

2: If yes, then how i can start it.

3: When i call IBMTSSVC_PerformanceStatisticsService.StartService() then i getting response value as 1. The method StartService() returns an integer value of 0 if the Service was successfully started, 1 if the request is not supported.

4: Can we configure the IBMTSSVC_PerformanceStatisticsService to start on CIM server startup?

5: Can i start IBMTSSVC_PerformanceStatisticsService via Command line utility?

 

Can anyone help me on this

 

Thanks in advance...

 

Note: I am using SBLIM API for communication with CIM server.

Updated on 2013-10-01T13:50:49Z at 2013-10-01T13:50:49Z by Vijaykumarsaini
  • TMasteen
    TMasteen
    260 Posts
    ACCEPTED ANSWER

    Re: SVC Performance Stats Issue?

    ‏2013-10-01T15:00:22Z  in response to Vijaykumarsaini

    Maybe the SVCCLI startstats command can help..

    • Vijaykumarsaini
      Vijaykumarsaini
      3 Posts
      ACCEPTED ANSWER

      Re: SVC Performance Stats Issue?

      ‏2013-10-02T09:23:53Z  in response to TMasteen

      Thanks for you quick response,

      I forgot to tell you that statistics collection is turned on. To checked this, i used the lssystem command

      svcinfo lssystem

      About 15 lines down i found the following:

      statistics_status on
      statistics_frequency 15
      

       

       

  • chriscanto
    chriscanto
    230 Posts
    ACCEPTED ANSWER

    Re: SVC Performance Stats Issue?

    ‏2013-10-01T16:45:03Z  in response to Vijaykumarsaini

    I'd suggest contacting IBM Support and opening a software PMR to ask for help from the SVC CIMOM team.

    • Vijaykumarsaini
      Vijaykumarsaini
      3 Posts
      ACCEPTED ANSWER

      Re: SVC Performance Stats Issue?

      ‏2013-10-02T09:25:56Z  in response to chriscanto

      @chriscanto, Can you please help me with the IBM support link, where i can open a software PMR.

      Updated on 2013-10-02T09:28:37Z at 2013-10-02T09:28:37Z by Vijaykumarsaini
  • chriscanto
    chriscanto
    230 Posts
    ACCEPTED ANSWER

    Re: SVC Performance Stats Issue?

    ‏2013-10-02T09:56:09Z  in response to Vijaykumarsaini

    I'd suggest starting here to find your local contact information:

    http://www.ibm.com/planetwide/

    Hope that helps