Topic
  • 4 replies
  • Latest Post - ‏2013-05-04T02:58:50Z by waldstein
waldstein
waldstein
33 Posts

Pinned topic Failed to SSH configuration after installation

‏2013-05-02T09:04:40Z |

Hi all,

after I install the Streams 3.0 successfully, I run FirstStep (by user "streamsadmin") to finish necessary confurations. However, I encounter problem in the first item: Configure the SSH environment.

It says:

Check: Public Key SSH    Status:Failed

    details: Permission denied (publickey, gssapi-with-mic, password)

XXX failed.

Attach is the snap picture for the error

Would you please help me?

Thank you in advance....

 

Attachments

  • Stan
    Stan
    76 Posts

    Re: Failed to SSH configuration after installation

    ‏2013-05-02T16:27:39Z  

    Try rerunning First Steps SSH setup (item 1 on the TASKS list) then rerun Generate Public and Private Keys (Itme 3).  Note any error / messages as these are the step that, if successful, should have setup SSH.  Besure your started FirstSteps.sh as streamsadmin.  

    If you still get a failure when you run 'Verify'  test SSH from the command line level.
    Login to the 'njprj' as streamsadmin and enter the command:
       ssh njprj
    If ssh and the keys are setup properly you will get a command prompt.  If you get a message like the following respond:  'yes' and the keys will be setup.  
    The authenticity of host 'biginsights1.svl.ibm.com (9.30.61.81)' can't be established.
    RSA key fingerprint is f7:2b:7b:ba:9c:2c:0c:47:64:c2:d6:7a:86:9f:34:da.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added 'biginsights1.svl.ibm.com' (RSA) to the list of known hosts.
    To verify that he default name for the system is correct run the command:
       uname -n
    If this returns anything but 'njprj' (example 'njprj.<somedomain>.com') then rerun the above SSH command using that host string as well.
    Restart First Steps and see if the system now verifies.

    Let me know if ths works.

  • waldstein
    waldstein
    33 Posts

    Re: Failed to SSH configuration after installation

    ‏2013-05-03T01:15:43Z  
    • Stan
    • ‏2013-05-02T16:27:39Z

    Try rerunning First Steps SSH setup (item 1 on the TASKS list) then rerun Generate Public and Private Keys (Itme 3).  Note any error / messages as these are the step that, if successful, should have setup SSH.  Besure your started FirstSteps.sh as streamsadmin.  

    If you still get a failure when you run 'Verify'  test SSH from the command line level.
    Login to the 'njprj' as streamsadmin and enter the command:
       ssh njprj
    If ssh and the keys are setup properly you will get a command prompt.  If you get a message like the following respond:  'yes' and the keys will be setup.  
    The authenticity of host 'biginsights1.svl.ibm.com (9.30.61.81)' can't be established.
    RSA key fingerprint is f7:2b:7b:ba:9c:2c:0c:47:64:c2:d6:7a:86:9f:34:da.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added 'biginsights1.svl.ibm.com' (RSA) to the list of known hosts.
    To verify that he default name for the system is correct run the command:
       uname -n
    If this returns anything but 'njprj' (example 'njprj.<somedomain>.com') then rerun the above SSH command using that host string as well.
    Restart First Steps and see if the system now verifies.

    Let me know if ths works.

    Stan,

    thank you.

    I have rerun the item1 and item3 as your suggestion. The result is the same with my post above.

    I tried "ssh njpri" also but the console wanted me to input password:

    [streamsadmin@njprj InfoSphereStreams] $ ssh njprj

    streamsadmin@njprj's password:

    The problem is: I did not input any password when installing! Is there default password for this? I have same problem when login to streams console....

     

  • kjerick
    kjerick
    227 Posts

    Re: Failed to SSH configuration after installation

    ‏2013-05-03T16:41:57Z  

    Can you try the manual procedure for setting this up that can be found in the InfoCenter documents here Configuring SSH to see if that works in place of First Steps?

  • waldstein
    waldstein
    33 Posts

    Re: Failed to SSH configuration after installation

    ‏2013-05-04T02:58:50Z  
    • kjerick
    • ‏2013-05-03T16:41:57Z

    Can you try the manual procedure for setting this up that can be found in the InfoCenter documents here Configuring SSH to see if that works in place of First Steps?

    Hi,

    Thank you! I have finish the SSH cofiguration. :)

    The reason is relating the user "streamsadmin", as my another question saying.

    Unfortunately, I deleted the folder /home/streamsadmin by incorrect operation. I supposed installation of Streams will create a folder "streamsadmin" under home directly. But it did not.....

    After reconfiguration the user "streamsadmin", all errors gone.