Topic
  • No replies
K_T
K_T
1 Post

Pinned topic User ID Associated With an Optim .BAT Job is not the ID Passed to DBMS

‏2013-07-16T22:16:21Z |

We recently installed Optim Data Growth v8.1 and we came across an issue when running a .bat job against the Optim Server. We frequently use service ID's (Z-ID) for Optim jobs, but we got an error where the ID being passed into the target DBMS was not  the Z-ID used to start the batch job. The ID being passed into the DBMS was the overriding User ID associated with the Optim Security settings, and that ID did not have privileges against the DB being archived.

We got around this by removing the server name from the .bat file, so it ran Optim as 'local' and then used the Z-ID to access the DB to archive. But when you run locally, you can't use Storage Profiles (which we need), so we want to figure out how to use a Z-ID to launch the .bat file on the Optim server and then also have that ID be used within Optim to access the target DB. 

I'm thinking there may be some way to pass in an override or a command of some sort that can be added into the .bat file to let Optim know to use the Z-ID associated with the job and to not use the overriding User Id defined in the security settings.

Has anyone else run into this, and if so, how did you resolve it?

Thanks for the help...

-Keith

 

Updated on 2013-07-16T22:17:27Z at 2013-07-16T22:17:27Z by K_T